Jump to content
The Dark Mod Forums

Dark Mod Crashes


Iceblade
 Share

Recommended Posts

After a few minutes, the training mission crashes and never in the same place: so far object room, lockpick room, archery range, central room, and even outside. The game however, doesn't actually crash, it just hangs for a second, goes to black screen and I have to go to the task manager to end the game (without the use of my mouse as my pointer refuses to move).

 

I have the correct Doom version (followed the patch link on the Dark mod wiki) and I have steam loading up dark mod directly (-applaunch 9060...). I am running a gateway PC with Vista 64 bit OS, intel quad core, Nvidia GeForce GTX 285, and I think 4 Gb of Ram.

 

I've already tried dropping the resolution down to widescreen (16:10) 1080 x 600 and standard shading with all of the other setting off or low.

 

Any ideas what the problem might be? Conflict between Doom and the quad core or the drivers of video card?

 

Edit: updated my video drivers and no luck, still crashes

 

PS From what I have played so far, I love it. Esp. the jumping and mantling mechanic, a far side improvement over T2, but similar enough that I don't have to adjust hardly at all to jump effectively.

Edited by Iceblade
Link to comment
Share on other sites

Realtek High Definition Audio and EAX is and has been off.

 

oh and FYI, the music continues without a problem when it goes to a black screen.

 

Edit: I decided to check the version of room (which is correct), but I noticed where it gave me 12 warnings of being unable to load images related to extinguishable light. Would cause this kind of the issues I'm having?

 

Here are the warnings or at least the 11 that it would show me and yes that period warning is what it gave me:

Couldn't Load Image: .

Couldn't Load Image: extinguishable/lamp_shaded

Couldn't Load Image: extinguishable/lantern_oil_hand

Couldn't Load Image: extinguishable/lantern_oil_hand02

Couldn't Load Image: extinguishable/round_lantern_sitting

Couldn't Load Image: extinguishable/round_lantern_unattached

Couldn't Load Image: extinguishable/streetlamp/roundstreetlamp

Couldn't Load Image: extinguishable/streetlamp/roundstreetlamp_02

Couldn't Load Image: extinguishable/wallight2

Couldn't Load Image: extinguishable/wallight_3_unattached

Couldn't Load Image: extinguishable/wallight_outdoor3

 

Edit2: nevermind, I tried Doom3 and it crashes right when you are about to be bioscanned...only this time the screen goes grayish white instead of black...go figure.

 

 

Edit3: Dang it....looks like I'm going to be the odd one out from here on, no Dark mod missions for me.

Edited by Iceblade
Link to comment
Share on other sites

After a few minutes, the training mission crashes and never in the same place: so far object room, lockpick room, archery range, central room, and even outside. The game however, doesn't actually crash, it just hangs for a second, goes to black screen and I have to go to the task manager to end the game (without the use of my mouse as my pointer refuses to move).

 

I have the correct Doom version (followed the patch link on the Dark mod wiki) and I have steam loading up dark mod directly (-applaunch 9060...). I am running a gateway PC with Vista 64 bit OS, intel quad core, Nvidia GeForce GTX 285, and I think 4 Gb of Ram.

 

I've already tried dropping the resolution down to widescreen (16:10) 1080 x 600 and standard shading with all of the other setting off or low.

 

Any ideas what the problem might be? Conflict between Doom and the quad core or the drivers of video card?

 

Edit: updated my video drivers and no luck, still crashes

 

PS From what I have played so far, I love it. Esp. the jumping and mantling mechanic, a far side improvement over T2, but similar enough that I don't have to adjust hardly at all to jump effectively.

 

Get use to it I have a 64 bit version of windows and the game will not load a FM at all. Training mission normally take at least 2 startups.

  • Like 1
Link to comment
Share on other sites

Get use to it I have a 64 bit version of windows and the game will not load a FM at all. Training mission normally take at least 2 startups.

Just create a thread telling us exactly what the problem is, how you got there, what error messages you get, your Video Card and PC setup, and maybe we can help you.

 

There are at least three team members that can run it perfectly in Vista 64-bit, and I count at least three other people running vista 64 without issues.

yay seuss crease touss dome in ouss nose tair

Link to comment
Share on other sites

Couldn't Load Image: .

Couldn't Load Image: extinguishable/lamp_shaded

Couldn't Load Image: extinguishable/lantern_oil_hand

...

 

http://wiki.thedarkmod.com/index.php?title=FAQ#Textures_are_missing.2C_screen_mostly_black

You'll want to look at this part of the wiki. Especially that seta image_useAllFormats "1" part.

 

yay seuss crease touss dome in ouss nose tair

Link to comment
Share on other sites

After a few minutes, the training mission crashes and never in the same place: so far object room, lockpick room, archery range, central room, and even outside. The game however, doesn't actually crash, it just hangs for a second, goes to black screen and I have to go to the task manager to end the game (without the use of my mouse as my pointer refuses to move).

 

I have the correct Doom version (followed the patch link on the Dark mod wiki) and I have steam loading up dark mod directly (-applaunch 9060...). I am running a gateway PC with Vista 64 bit OS, intel quad core, Nvidia GeForce GTX 285, and I think 4 Gb of Ram.

 

I've already tried dropping the resolution down to widescreen (16:10) 1080 x 600 and standard shading with all of the other setting off or low.

 

Any ideas what the problem might be? Conflict between Doom and the quad core or the drivers of video card?

 

Edit: updated my video drivers and no luck, still crashes

 

PS From what I have played so far, I love it. Esp. the jumping and mantling mechanic, a far side improvement over T2, but similar enough that I don't have to adjust hardly at all to jump effectively.

 

It looks like you either have an overheating system or a memory error. You can download a CD that checks your memory from here:

 

http://www.memtest.org/

 

as for overheating, do you have a temp. monitor software?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to comment
Share on other sites

Okay, I delete local game files using Steam for Doom3, Steam reinstalls doom3 and it doesn't freeze. Then I copy and paste back in back ups of darkmod and the two fm folders, but it still crashes. In fact, Doom3 is crashing again. I will now try a complete reinstall of both to see if maybe I can get darkmod to work. I am currently that the problem lies in a config file or dll that I ended up pasting over with an older version (apparently removing game files keeps all of the mod stuff intact and when doom3 was reinstalled it changed something in the config file).

 

I think that the problem here is that the patch you suggest using screws up the steam version of doom3 in some fashion with regards to configurations or something. (which makes sense as apparently the Steam version is up to date, so nobody with the steam version would have encountered my problem as they didn't update their steam version like I thought I had to) If this is the case, I would suggest putting a warning saying that the steam version of Doom 3 is up-to-date and that updating it manually will cause freezing/crashing in-game.

 

Edit: My Video card and system is not supposed to be overclocked and my computer (or at least my processor) is not overheating.

Edited by Iceblade
Link to comment
Share on other sites

So, you're saying the Steam version is working fine for you out of the box, and no patching is required at all?

 

Okay, I deleted the game files using Steam, deleted all of the remaining files including dark mod stuff, installed doom3 and now it is freezing without doing anything to it. (oh and the steam version is the latest version...there is no patching and never supposed to be any patching required for steam games - manually anyway)

 

Edit: looked at the steam log, and apparently the game goes to a black screen because it has stopped recieving any new frames....which makes sense as the game halts, monitors blacks out (no display), and then I get a black screen (display).

Edited by Iceblade
Link to comment
Share on other sites

If that were the problem, I would think it would prevent me from playing the game at all.

 

You lie threw your teeth, then you must not have the Vista 64 version with a quad core processor..I reinstalled vista and before and after I up dated the dark mod I try playing and still get the same error. No objectives and after clicking on the objectives it says couldn't load maps maps/outpost, BUT it says this on every fm just the map name after /. And it still take at least 2 times to load the training mission..

Edited by robert256
Link to comment
Share on other sites

I've been noticing that Doom gets quite angry with some apps running in the background for me. It goes into a race condition loading maps if I have WinSCP in the background... I dont understand why.

 

Anyway, its a thought to try run it after a fresh restart and killing some background stuff that you dont need, I have a feeling things like xfire might cause it to get angry, also have you disabled the steam ingame overlay?

 

Just an idea - I have no idea if it will help :)

Link to comment
Share on other sites

Just create a thread telling us exactly what the problem is, how you got there, what error messages you get, your Video Card and PC setup, and maybe we can help you.

 

There are at least three team members that can run it perfectly in Vista 64-bit, and I count at least three other people running vista 64 without issues.

 

2.4 gig quad core Intel, 4 gig of memory 250 gig of HD. 8800GTS 640mb, 22 inch ViewSonic, are my system specs.

The error after it shows nothing on the objectives screen, couldn't load maps map/mapname (it says this regardless what map I load just uses map name. I also have the updated doom before starting the tdm.update. 1304 is shows on doom console.

 

Then after I click on buy equipment it loads up the menu screen. Now if coding is the problem I don't mind modify it threw notepad it helps the game to work. Everything is up to date. So if I can't run it after a fresh install then others WHO THINK they have Vista 64 are probably running it on 32 bit version. So if your telling me you team can run it then tell me what is causing it?

Edited by robert256
Link to comment
Share on other sites

So if I can't run it after a fresh install then others WHO THINK they have Vista 64 are probably running it on 32 bit version.

 

Yes, that must be the problem. Everyone else who says they can run it is too dumb to know what version they actually have. :rolleyes:

 

You know, your attitude is not going to make anyone want to go out of their way to help you out.

Link to comment
Share on other sites

*ephiphany*

Actually, robert, your error sounds suspiciously like a bad map compile.

 

After installing the training mission, and tdm restarts, go to the console (ctrl-alt-~) and type dmap training_mission. Let it compile (It could take several minutes), and then try starting the training mission.

 

Let me know how it goes.

yay seuss crease touss dome in ouss nose tair

Link to comment
Share on other sites

*ephiphany*

Actually, robert, your error sounds suspiciously like a bad map compile.

 

After installing the training mission, and tdm restarts, go to the console (ctrl-alt-~) and type dmap training_mission. Let it compile (It could take several minutes), and then try starting the training mission.

 

Let me know how it goes.

 

Thanks for you reply, the training mission does work without the compiling, it just take 2 times to start it up. (no big deal for me) I just can't get the FM's to work. I don't know if compiling the fm's would work or not?

Link to comment
Share on other sites

Well, I am able to get much farther in Doom 3 than before from a fresh boot up, however it still freezes. It would appear that for some reason, my system (almost certainly video card) is being overtaxed far more than it should be for an 04/05 game. Right now I am at a total loss as to how to deal with this problem as tests I have performed have found no issue what so ever.

Link to comment
Share on other sites

Well, I am able to get much farther in Doom 3 than before from a fresh boot up, however it still freezes. It would appear that for some reason, my system (almost certainly video card) is being overtaxed far more than it should be for an 04/05 game. Right now I am at a total loss as to how to deal with this problem as tests I have performed have found no issue what so ever.

 

Out of curiosity, have you upgraded your power supply? Your GTX285 requires a lot of power, and it's rare that an OEM PSU can properly handle that extra demand.

Link to comment
Share on other sites

Out of curiosity, have you upgraded your power supply? Your GTX285 requires a lot of power, and it's rare that an OEM PSU can properly handle that extra demand.

 

If that was the issue, I would think that my problems would not be isolated to just doom3 but would affect my whole system causing a reboot, shut down, or computer freeze. When the game freezes, I am able to actually access and use task manager and subsequently return to the desktop upon ending the task.

 

Edit: well unless the power supply was upgraded from the original model, I must have a 300 Watt Power supply....Doom3 does play fine on the lowest settings though (just not on medium).

Edited by Iceblade
Link to comment
Share on other sites

If that was the issue, I would think that my problems would not be isolated to just doom3 but would affect my whole system causing a reboot, shut down, or computer freeze. When the game freezes, I am able to actually access and use task manager and subsequently return to the desktop upon ending the task.

Poor or overworked PSUs can cause a lot of system instability, especially during gaming, which just crashes games or applications. One way to test is to underclock your GPU, which should reduce the total draw on your PSU. See if it crashes less, and if it does then it's likely your PSU that is the problem. If not then we'll keep trying to find the source of the crashes, but seriously, it's been uncommon for Nvidia cards to crash, especially randomly like in your case. See here if you need a guide.

You could also watch your temps to see if it's overheating.

 

 

Link to comment
Share on other sites

You know, after reading, and reading your posts, you have no clue. People have tried to help you. Bent over back wards, you aren't listening to their suggestion, and answers. Why do you persist, why do you continue to be a total whanker and douche bag. Its all the games fault, thats all you say. You cannot always blame a GAME for problems YOU are having. If you cannot listen to what people are saying, stop posting, and don't play it, simple as that. Stop wasting peoples time when they are trying to help you when you obviously don't want it, and strictly blame the game. Go away. This is getting old.

  • Like 3
Link to comment
Share on other sites

You know, after reading, and reading your posts, you have no clue. People have tried to help you. Bent over back wards, you aren't listening to their suggestion, and answers. Why do you persist, why do you continue to be a total whanker and douche bag. Its all the games fault, thats all you say. You cannot always blame a GAME for problems YOU are having. If you cannot listen to what people are saying, stop posting, and don't play it, simple as that. Stop wasting peoples time when they are trying to help you when you obviously don't want it, and strictly blame the game. Go away. This is getting old.

 

 

This is a real intelligent response, for someone who has low self-esteem (like yourself) this would be the type of answer a person would expect. Specially since you have no experience or intelligence in computer or software to say anything whatsoever. Say what you will, but no one will believe your lies and BS after posting such things as (name calling). If anything maybe its best for you to go away because we don't like children the post and use verbal language to build there self-esteem on a forum.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • STiFU

      I started skateboarding again after a 20 year hiatus. Whish me luck I don't break anything. 😄
      · 6 replies
    • freyk

      Some years earlier i created some launchers for TDM. uploaded today some new sourcecode and executables on my github repo.
       
      · 0 replies
    • Epifire

      Say, I know it's been a while since the site got overhauled from the crash. But did we ever figure out if/how to get the recent topics & replies list back? It's not a total deal breaker but it was nice for becoming a thread creeper again...


      · 2 replies
    • Epifire

      Some of you who've been on the TDM discord know I was out of work last Winter, just putting in hrs for the developer portfolio. Currently I've been working a seasonal job to pay the bills and now I'm finally in my last week before I get bumped off. Things will be tight but I'm planning a long off period to make as much content as I can. Big plans in Unreal Engine as well as my most ambitious TDM collab yet! Never been so excited to be a stuck at home to pursue my life's work. With a lotta time and maybe some luck, I'm hoping to get enough art work done that I may start applying around to studios.
      · 4 replies
    • STiFU

      I finally got around to play Prey and I truly loved it. It is an incredible homage to System Shock and Deus Ex. While the gameplay is not en par with those two titles, the game makes up for that with its well written lore and story. The whole "world" just feells so authentic and it features a ton of really god environmental story-telling. Recommended for every immersive sim fan, i.e., everyone on this forum.
      · 5 replies
×
×
  • Create New...