Jump to content
The Dark Mod Forums

water problems


Recommended Posts

I've followed the tutorial on the wiki on how to do water, but when I compile it with dmap I get the error 'node without a volume', on entering the water the player doesn't float or have a breath bar and sinks like a stone, theres also no sound of swimming, or walking through the water in the shallow section.

 

doom 3 is patched to 1304 and upto date, there are no leaks

 

it is a func_water, and liquid_water

Link to post
Share on other sites
on entering the water the player doesn't float or have a breath bar and sinks like a stone, theres also no sound of swimming, or walking through the water in the shallow section.

It used to happen to me as well. It was quite random - sometime my water entity worked, sometimes not, but after a while problem disappeared and now water works as it should always. I don't really know what has helped but try playing with brush dimension (extend it a little bit into solid brushes, or alter water surface level slightly and see if it works or not.)

You can change water entity brush by clicking TAB - this take you into brushe edit mode, rather than entity edit mode. TAB once again, when you're finished.

Link to post
Share on other sites

I've followed the tutorial on the wiki on how to do water, but when I compile it with dmap I get the error 'node without a volume'

Node without a volume is only a warning. It's not even a very important warning. I'll give 100,000 brownie points to anyone who can make a 3-room FM without "node without a volume" warnings. :P

 

...And follow PinkDot's instructions. Making it extend farther into solids is particularly important both visually and mechanically. Don't forget to dmap after moving entities or changing brushes!

yay seuss crease touss dome in ouss nose tair

Link to post
Share on other sites

I had a look at some of the released maps with swimable water, apparently the walls around the water areas were very thick.

 

the thing I said about water only working when visportals are around is wrong.

 

I found out that only some water surface textures work, some just dont, and therefore no water is created.

 

You dont even have to stick the water volume in the wall a bit, its depending on what texture is on the top surface.

Edited by stumpy
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...