Jump to content
The Dark Mod Forums

Vsync and Screen ratio


Recommended Posts

I once got tdm working on my desktop once, and it was great! But I have since scrapped it, and now have a laptop instead. Though I have got it running on my laptop, things aren't as smooth as hoped. For instance, if I enable vsync the game becomes VERY choppy, even from the menu screen. This makes it virtually unplayable. I've managed to get it to run by forcing vsync off in the nvidia control panel, but this has left me with the annoying lines that vsync corrects. Also, one thing I have not been able to change at all is the the screen size. For some reason the game doesn't utilize my entire screen. Instead it only takes up about only half of the screen, leaving black borders on the sides. I've tried messing with the aspect ratio an resolution to no avail. This, coupled with the vsync problem has proved very annoying. Has anyone had a similar issue?

My specs are:

Windows 7 64bit

i5 2.40GHz quad core

GeForce 335M

4gb DDR3 RAM

Note: This might even be a problem with my video drivers. Last I updated them, they've been conflicting with my source games.

 

Thanks!

Link to post
Share on other sites

Not having a similar issue, but maybe I can help. :) What resolution do you want the game to run in and what is you native resolution? Are your graphic card drivers up to date?

 

If you setup the native resolution of your display, the game should basically play without borders. If that resolution should not be available through the menu you can also set it up manually. Assuming you have a 16:9 display with a resolution of 1920 times 1080, here are the commands that you can enter in the console of Doom 3 (press ctrl+alt+^ to bring it up):

r_mode -1

r_customwidth 1920

r_customheight 1080

r_aspectRatio 1

vid_restart

 

Before you enter these commands, make sure you have no FM currently installed. r_aspectRatio takes the values 0 for 4:3, 1 for 16:9 and 2 for 16:10.

 

If you don't want to play in the native resolution of your display, because your performance is too low, things may possible get a little more complicated, but we'll tackle that problem when it becomes one. :)

 

Regarding the vsync, I've just recently found out, that enabling triple buffering helps performance in Doom 3 quite a bit.

Link to post
Share on other sites

Alright! So this time I tried something a little different by doing a clean install of my drivers. Vsync works now! And somehow I managed to fix the border issue using those commands! I'm not sure what I did, but after the vid_restart command I thought it crashed. After it came back up it was fixed! Strange thing is that all of the settings I had put into the console were already in the settings and the DoomConfig. I'm not complaining though. ^-^

Thanks for the help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...