Jump to content
The Dark Mod Forums

Fisheye Resolution 1920x1080


Recommended Posts

I got a new screen and a new graphics card. I run TDM at 1920x1080 and I have "fish eye optics", which means that the objects and brushes which are far from the screens center are stretched some way. Looks like I have a 270° field of view. It gets even worse if I lean on an edge with "Q" or "E".

 

Someone's already encountered this? My GPU is ATI Radeon 5770.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

When I first set a 4:3 resolution and then go back to 16:9 it works for me. But it seems like some of the upper screen is cut out (my bow shooting center isnt the center of the screen).

I guess I'll just have to play on some lower 4:3 resolution..

 

(edit: native screen resolution is 1920:1080)

Edited by SeriousToni

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

When I first set a 4:3 resolution and then go back to 16:9 it works for me. But it seems like some of the upper screen is cut out (my bow shooting center isnt the center of the screen).

I guess I'll just have to play on some lower 4:3 resolution..

 

(edit: native screen resolution is 1920:1080)

 

Try cg_fov 100

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

Try cg_fov 100

 

Can you please post a screenshot (one image > 1000 words :) and also another one after typing "cg_fow 100" in the console? If this fixes it, we might need to fix a bug in our code.

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

Try turning bloom off. It can act a little funky with ATi's drivers.

Edited by Trunks0

-Trunks0

Asus Maximus Formula(X38) - Intel Core2Quad 8400 @ 3.2Ghz - 4Gb PC2-6400 OCZ Gold XTC/Corsair XMS2(@800mhz) -

16X8X16 DL 8X Pioneer DVR-111D DL DVD±RW - 320GB HD(Seagate 7200.10) - 640Gb Westerm Digital w/16Mb Cache -

2 x Crossfired PowerColor Radeon HD 5770's - Audigy2 - Windows 7 64

Link to post
Share on other sites

Hi, thanks for your replies! :) So this may help:

 

Seems like the resolution is not 1920x1080, but 1080x1920! I made 2 screens of this.

 

FOV changes didn't helpout, so both screens are made with fov 90.

post-3542-130062255221_thumb.jpg

post-3542-130062256328_thumb.jpg

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Hi, thanks for your replies! :) So this may help:

 

Seems like the resolution is not 1920x1080, but 1080x1920! I made 2 screens of this.

 

FOV changes didn't helpout, so both screens are made with fov 90.

 

That's very odd! Are you running v1.04? I looked into the code, but the code appears to be correct. What are the values in your DoomConfig.cfg file for:

 

seta r_customHeight "XXX"
seta r_customWidth "XXX"
seta r_fullscreen "X"
seta r_mode "X"

 

?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

Make sure r_customWidth is set to 1920 and r_customHeight is set to 1080. Also make sure r_mode is set to -1. That will require a vid_restart if you do it in game.

But the in game res selection should have worked

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

Hmm, its okay:

 

seta r_customHeight "1080"

seta r_customWidth "1920"

seta r_fullscreen "1"

seta r_mode "-1"

 

Yes I do have the actual 1.04 version. Graphic drivers are also in the newest version installed.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Hmm, its okay:

 

seta r_customHeight "1080"

seta r_customWidth "1920"

seta r_fullscreen "1"

seta r_mode "-1"

 

Yes I do have the actual 1.04 version. Graphic drivers are also in the newest version installed.

 

That looks ok to me, and I cannot reproduce this on my system, the view looks correct. What is the value of "r_aspectRatio"?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

It says r_aspectratio = 0

 

Just a question, do we talk about the base/doomconfig or a mission specific one? I assmued that we talk about the one in the base folder.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

It says r_aspectratio = 0

 

Just a question, do we talk about the base/doomconfig or a mission specific one? I assmued that we talk about the one in the base folder.

 

Alright to avoid confusion, go into the game, start a mission (doesn't matter which), open the console and type:

 

r_customWidth and hit enter and see what it says. Same thing for all the other cvars.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

It says r_aspectratio = 0

 

Try to set this value to "1" (that is 16:9, "0" is 4:3)

 

Just a question, do we talk about the base/doomconfig or a mission specific one? I assmued that we talk about the one in the base folder.

 

Both should be in sync, but if you start a FM, the FM config is written back to the FM folder and the base folder when you edit something. If you edit them manually, I think editing either both, or the one in the FM folder should work.

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

I've done this now:

 

it says

height 1080

width 1920

fullscreen 1

mode -1

aspectratio 1

 

EDIT: aspectratio in base-folder was still 0. This may change automaticly after game start to 1 because of the screen size settings.Though, I changed it manually now to 1.

Edited by SeriousToni

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

DoomConfig.cfg is known to regress settings that are manually applied to it.

 

It is much more reliable to create an autoexec.cfg and place the settings there.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I've done this now:

 

Did it work?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to post
Share on other sites

Hi, thanks for your replies! :) So this may help:

 

Seems like the resolution is not 1920x1080, but 1080x1920! I made 2 screens of this.

 

FOV changes didn't helpout, so both screens are made with fov 90.

 

hmmm, something weird is going on there, just looking at the aliasing, there's no way that's actually running at 1920x1080. Make sure Catalyst AI is turned off, and turn off all bloom settings and take another screenshot for us.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

What the fuck it was the bloom! Turned off Post Processing in the advanced graphic settings and that did solve it!

 

I could not imagine that, and I still don't understand why this causes such unnatural errors, but without Post Processing, the resolution works fine.

 

Thumbs up for you guys for helping me! Hopefully someone got an idea if this can be fixed somehow for the next version :P

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

What the fuck it was the bloom! Turned off Post Processing in the advanced graphic settings and that did solve it!

 

I could not imagine that, and I still don't understand why this causes such unnatural errors, but without Post Processing, the resolution works fine.

 

Thumbs up for you guys for helping me! Hopefully someone got an idea if this can be fixed somehow for the next version :P

 

It's the fault of Catalyst AI in the ATI drivers, it's always been buggy, more so with the Doom3 engine. Turn it off in the ATI control panel.

 

EDIT: Also Trunks told you to do this in post #6 lol. Could have had this fixed this morning at 5 AM. Well at least it's working now.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

It's the fault of Catalyst AI in the ATI drivers, it's always been buggy, more so with the Doom3 engine. Turn it off in the ATI control panel.

 

EDIT: Also Trunks told you to do this in post #6 lol. Could have had this fixed this morning at 5 AM. Well at least it's working now.

 

Oh I may have overseen this, I am sorry! But nevertheless I can't find "Catalyst AI" in the CCC-settings. Which setting do you just mean?

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

What Catalyst version do you use, and what OS? In all versions starting with 10.12, you can't disable CatAI anymore, at least not with Vista/Win7.

My Eigenvalue is bigger than your Eigenvalue.

Link to post
Share on other sites

What Catalyst version do you use, and what OS? In all versions starting with 10.12, you can't disable CatAI anymore, at least not with Vista/Win7.

 

I thought I read that somewhere, great, fucking ATI and forcing "optimizations" on us that break shit.

I always assumed I'd taste like boot leather.

 

Link to post
Share on other sites

Yep.

 

For newer drivers you either need to use Guru3d's "Radeon Pro" to disable Catalyst AI

 

or...

 

You can try the Trunks0 method of:

 

Savegame + Mission PK4 + Rename the "Doom3.exe" to "darkathena.exe"

 

 

http://forums.thedarkmod.com/topic/12398-disabling-catalyst-ai/page__view__findpost__p__250122

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I use Windows XP - and yeah, I got the newest version of Catalyst Control Center 2011.0126 (graphics driver 8.821). So I'll have to use the darkathena method or just play without bloom.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...