Jump to content
The Dark Mod Forums

Resolution Problem: not full screen


Ladro
 Share

Recommended Posts

Hello Taffers,

 

Today when I tried TDM, and the resolution was not full screen. I don't know why, i changed absolutely nothing.

 

This is the effect on my screen:

 

http://bayimg.com/nAkOOAADG

 

(the game start perfectly but not scale at full screen, i have alway the the little black border on left high, as you can see on the image)

 

I tried configuring a lot of settings in the doomconfig.cfg on the darkmod root, but without any success :-(

 

Any idea/suggestion to solve this?

 

My HW/SW configuration is on my sign.

Link to comment
Share on other sites

What is your exact screen resolution?

 

Monitor brand and make will help also.

 

I tried 1280x720 and also other res up, same problem.

 

My monitor is an ASUS 16:9 24'' 1920x1080

Link to comment
Share on other sites

I tried 1280x720 and also other res up, same problem.

 

My monitor is an ASUS 16:9 24'' 1920x1080

 

That's strange indeed. But give this a try...

Run 'nvidia-settings' and go to the settings for your monitor under GPU0 > DFP-0 (most likely)... it is just below 'PowerMizer' setting. You may want to try tinkering with the GPU Scaling Method settings.

Mine defaults to Force Full GPU Scaling (checked), and GPU Scaling Method = Stretched.

You may want to try 'Centered' or 'Aspect Ratio Scaled', to see how the screen will display then. My guess would be that yours somehow got set to 'Aspect Ratio Scaled'... but that's just a guess.

See this screenshot:

post-3285-131829455308_thumb.png

Edited by PranQster

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

So you tried forcing either:

 


seta r_customHeight "1080"

seta r_customWidth "1920"

seta r_fullscreen "1"

seta r_mode "-1"

seta r_aspectratio "1"

 

or

 

 


seta r_customHeight "720"

seta r_customWidth "1280"

seta r_fullscreen "1"

seta r_mode "-1"

seta r_aspectratio "1"

 

...in DoomConfig.cfg ???

 

 

Edit:

 

(I fixed the last line in the configs above, sorry.)

Edited by nbohr1more

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

So you tried forcing either:

 


seta r_customHeight "720"

seta r_customWidth "1280"

seta r_fullscreen "1"

seta r_mode "-1"

seta r_aspectratio = 1

 

...in DoomConfig.cfg ???

 

Tried few times, but nothing :-(

 

The thing that i cannot understand is *what* changed this situation. I've done nothing to change my graphics settings in doom3/darkmod (and also on my global desktop enviroment), so it's strange.

 

That's strange indeed. But give this a try...

Run 'nvidia-settings' and go to the settings for your monitor under GPU0 > DFP-0 (most likely)... it is just below 'PowerMizer' setting. You may want to try tinkering with the GPU Scaling Method settings.

Mine defaults to Force Full GPU Scaling (checked), and GPU Scaling Method = Stretched.

You may want to try 'Centered' or 'Aspect Ratio Scaled', to see how the screen will display then. My guess would be that yours somehow got set to 'Aspect Ratio Scaled'... but that's just a guess.

See this screenshot:

post-3285-131829455308_thumb.png

 

Mmmh pity, this specific settings in my NV card it's not present (maybe my 8600GT it's too basic, or i use different version of proprietary NV video drivers). But I think you have found some way to a solution: i think too that it's how my card now make the scaling at fullscreen. The strangeness is that i never changed this :-(

 

Here's my NV proprietary panel and GPU driver version:

 

post-3257-131838142185_thumb.png

 

Anyway thanks a lot to both of you for your suggestions, DarkMod community really rocks! :laugh:

Edited by Ladro
Link to comment
Share on other sites

Tried few times, but nothing :-(

 

The thing that i cannot understand is *what* changed this situation. I've done nothing to change my graphics settings in doom3/darkmod (and also on my global desktop enviroment), so it's strange.

 

 

 

Mmmh pity, this specific settings in my NV card it's not present (maybe my 8600GT it's too basic, or i use different version of proprietary NV video drivers). But I think you have found some way to a solution: i think too that it's how my card now make the scaling at fullscreen. The strangeness is that i never changed this :-(

 

Here's my NV proprietary panel and GPU driver version:

 

post-3257-131838142185_thumb.png

 

Anyway thanks a lot to both of you for your suggestions, DarkMod community really rocks! :laugh:

 

Ah, ok. On yours, the setting would be for CRT-1. Maybe the scaling settings only work with flat panel screens.

Edited by PranQster

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

Ah, ok. On yours, the setting would be for CRT-1. Maybe the scaling settings only work with flat panel screens.

 

Mine it's a flat panel screen, not a crt :-)

 

(it's simple a LCD 24'')

Edited by Ladro
Link to comment
Share on other sites

The control area is listing it as a CRT from ASUS in your screen-shot though... ;)

 

How about some screens of the sub-menus for some of those options in the tree on the left ? ^_^

 

(edit: BTW... did you see the fixed configs above... :blush: )

Edited by nbohr1more

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

The control area is listing it as a CRT from ASUS in your screen-shot though... ;)

 

 

Ah ok :-D

 

I presume that the NVpanel sense a CRT because I use a classic VGA connection, i think the problem it's not there.

 

How about some screens of the sub-menus for some of those options in the tree on the left ? ^_^

(edit: BTW... did you see the fixed configs above... :blush: )

 

Nothing too with fixed "aspectratio" line :-(

 

Even more strange: if I run Doom3, all it's normal, the screen it's always full a well scaled with all the resolutions selected.

Edited by Ladro
Link to comment
Share on other sites

Ah ok :-D

 

I presume that the NVpanel sense a CRT because I use a classic VGA connection, i think the problem it's not there.

 

 

 

Nothing too with fixed "aspectratio" line :-(

 

Even more strange: if I run Doom3, all it's normal, the screen it's always full a well scaled with all the resolutions selected.

 

Hmmm... have you compared your doom3 and TDM config files side by side to be sure all graphics options are set the same?

Also, have you tried disabling full-screen mode in TDM, restarting the game in a window, then re-enable full-screen and restart the game again?

Edited by PranQster

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

Ladro, one thing you can try it to look a the cvar values during running TDM. Open the console (usually the key left of the "1") and enter:

 

r_customHeight

 

etc. and see what their values are. Maybe they are different from what you put in DoomConfig.cfg?

"The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore, all progress depends on the unreasonable man." -- George Bernard Shaw (1856 - 1950)

 

"Remember: If the game lets you do it, it's not cheating." -- Xarax

Link to comment
Share on other sites

Ladro, one thing you can try it to look a the cvar values during running TDM. Open the console (usually the key left of the "1") and enter:

 

r_customHeight

 

etc. and see what their values are. Maybe they are different from what you put in DoomConfig.cfg?

 

Tried, but nothing :-( :-( :-(

 

I really cannot understand.

The var display the right value "720" and mode 6 (1280x720). For me it'a mistery. May I'll try erasing al config file, and re-install doom and darkmod from scratch.

Link to comment
Share on other sites

I would just try deleting the TDM doomconfig file first and the next time you start TDM up it should create a brand new one.

 

Tried also with a brand new (autogenerated) doomconfig.cfg , nada :-(

 

I'm going crazy. I really cannot understand why i have this problem.

 

I've uploaded the log (started the game by shell to log and then quit), and my brand new doomgonfig.cfg

 

http://bayfiles.com/file/17uv/PYfHeO/tdm_res_prob_4_ladro.7z

 

If anyone has some suggestion, I accept any idea :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • STiFU

      I started skateboarding again after a 20 year hiatus. Whish me luck I don't break anything. 😄
      · 6 replies
    • freyk

      Some years earlier i created some launchers for TDM. uploaded today some new sourcecode and executables on my github repo.
       
      · 0 replies
    • Epifire

      Say, I know it's been a while since the site got overhauled from the crash. But did we ever figure out if/how to get the recent topics & replies list back? It's not a total deal breaker but it was nice for becoming a thread creeper again...


      · 2 replies
    • Epifire

      Some of you who've been on the TDM discord know I was out of work last Winter, just putting in hrs for the developer portfolio. Currently I've been working a seasonal job to pay the bills and now I'm finally in my last week before I get bumped off. Things will be tight but I'm planning a long off period to make as much content as I can. Big plans in Unreal Engine as well as my most ambitious TDM collab yet! Never been so excited to be a stuck at home to pursue my life's work. With a lotta time and maybe some luck, I'm hoping to get enough art work done that I may start applying around to studios.
      · 4 replies
    • STiFU

      I finally got around to play Prey and I truly loved it. It is an incredible homage to System Shock and Deus Ex. While the gameplay is not en par with those two titles, the game makes up for that with its well written lore and story. The whole "world" just feells so authentic and it features a ton of really god environmental story-telling. Recommended for every immersive sim fan, i.e., everyone on this forum.
      · 5 replies
×
×
  • Create New...