Jump to content

Fan Mission: Rightful Property - by jysk (2012/04/13)


Poll: Rightful Property  

55 members have voted

  1. 1. Gameplay: Enjoyment. Fun duration. Smooth flow, ect. Versus Bugs. Frustration, Boredom, framelag

  2. 2. Appearance: Vertical use, Visual pleasure, lighting, visual style, deduct bad texturing etc.

  3. 3. Story & Text: Story. Text. Briefing. Graphic storytelling

Recommended Posts

Yeah I figured there would be an updated version, I downloaded the version that came out right after you released it and have only just had time to play them, and haven't been looking in the threads for the contest FM's to avoid spoilers. I'll grab the 1.1 and give that another playthrough, hopefully I can get my votes deleted and re-vote the map properly.

Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Link to comment
Share on other sites

Finished this tonight. It has a great story that drew me right in.

Heartbreaker about the poor girl and her sad parents

I upgraded my computer and didn't have disernable framerate issues. I did think the ambient lighting issue was odd, but from reading this thread it appears this was not a design decision, and that it has now been improved. I think the non-linearity is very good. The multitude of patrols made for some very challenging moments, but there always seemed to be a place to hide and plan.

I missed the spider lair the first time around, and let me say, you know how to build a sense of dread. That "bang" when the spider drops put an extra load of adrenaline on my heart, heh

I also enjoyed climbing up on the wall near the beginning and knocking out the bowman. :) Excellent work!

Link to comment
Share on other sites

Very nice mission, lots more gameplay than I was expecting. I got around the framerate issues by knocking out all the AI in the streets :-) The bank was really well done although a bit small, very tense gameplay, especially getting into the vault. Well done and congrats!

Link to comment
Share on other sites

  • 3 weeks later...

Thank to the latest posters. ;)


Btw can the admins of the page update the p4k file to the most recent one from the rapidshare link (the various mirros on the mainpage have an outdated version)? There was just a number of small updates i made over the month back then (by suggestions from this thread), but it would be nice if it is the most recent version would be linked. :). The same goes for the ingame downloader. Sorry for the circumstances this way. x:

Edited by jysk
Link to comment
Share on other sites

Am I correct to presume the 1.1b version is the latest then?


My dropbox link is mirroring that one.


I think if I rename the file to the original pk4 name, it will push the change to the mirrors.

Please visit TDM's IndieDB site and help promote the mod:




(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

During the last updates i did not rename the pk4 file. Its just some iteration of the 1.1.b file (during which i included all the suggestions and error fixes of the forum posts) the newest *.map file is from 9 may, as noted in the entrance post. x:


Btw. its not a big deal its just some very minor bug fixing etc. ;)


If the map file is from 9 May its the most recent one.

Edited by jysk
Link to comment
Share on other sites

  • 3 weeks later...

I don't want to read any spoilers, but I've run into what seems like a significant bug.


I've snuck around behind the inn where the

drunk guard is.  There is a locked door and two horizontal cellar doors.  The locked door does not light up at all when I try to frob it.  The two cellar doors DO light up,

but when I try to frob them, nothing happens.


Are these doors supposed to be usable? Is this a known problem?

Link to comment
Share on other sites

The two flat cellar doors are locked. You have to pick them.


Are you playing with 1.08? We had a discussion a couple weeks ago about those doors being black in 1.08 (not black in 1.07) because their face is flush with their visportal. This was fixed in SVN since the discussion.


I just tried it and the doors are displayed properly, but their sound is now gone. It's next to impossible to pick them w/o hearing any feedback. I don't remember the sound not being there in 1.07.


I had a problem with a door like this in my WIP. The "I'm locked" sound and the lockpicking sound could only be heard on one side of the door, which had its visportal running right down the center of it. I solved the problem by adding handles to the door. The presence of a handle on the side of the door that had previously been silent allowed the sounds to be heard on that side.



Sounds (!!) like we have a new 1.08 bug.

Link to comment
Share on other sites

Ah, ok...I saw the lockpicks flash green but since I didn't hear anything I didn't think the lockpicking was actually working (I am playing with 1.08).

Link to comment
Share on other sites

Just finished this. Overall I quite enjoyed it. It felt very old-school to me. I had the feeling of having to fight for every hallway, every glimpse around a new corner, that I remember from T1 and T2.





Lots of varied environments (city, bank, warehouse, mansion, sewers, docks...) and lots of varied AI.

Challenging gameplay that really forced me to scout and plan.

Lots to see and do...it took me four nights to finish it.

The spider surprise was great.




I must have gotten an older version, because I still had the ambient light changes, unfrobbable arrow, etc.

The patrols were pretty robotic, which was ok (oldschool again) although some of them didn't make much sense, like the guard in the bank barracks that just walked in a tight circle in and out of the bedroom.

Loot totals seemed high. I played on Hard and was 150 short. I thought I'd find more loot in the warehouse and when I didn't I didn't have the heart to work my way back into town.

Some sounds seemed to cut off really sharply...the waves of the ocean stopped between one step and the next, and some machine sounds did as well.

Not much variety in AI heads or voices...oddly, I rarely heard idle barks in this mission.

The city map confused me at first because I had no idea where the player start was.



The framerates for me were low but it was still playable. Somehow I missed the part about the girl that everyone is talking about. The hints about what was in the warehouse was great, although I thought it was going to be zombies or something. I was totally ready for something to come out of the crate that was frobbable...was a bit disappointed when it was empty.




Overall I quite enjoyed this. I voted Excellent, Good and Good, and I really hope you'll make another mission...this definitely ranks up there as one of the best first efforts I can think of.

Link to comment
Share on other sites

Thanks, mb i will make another mission when I have time. :)




Yes the barrack guard was a bit off I guess. ^^


What did you miss with the girl? Her story how she became missing is explained in the house of her parents. Its the western one of the two houses which are directly on the market place. The girl has been dragged away by the spider into the sewers. There are some bones and a doll down there to indicate what happened to her.



Edited by jysk
Link to comment
Share on other sites




Never noticed the doll.


Her story how she became missing is explained in the house of her parents. Its the western one of the two houses which are directly on the market place.


I don't think I went into that house.




Link to comment
Share on other sites

I'll have to go back and see it. I went around the east side, and went into that house first. Then got into the inn and the bank. I went the west way on my way out, but I must have missed the door. Still enjoyed the mission, but it seems like I missed the best part. :)

Link to comment
Share on other sites

Well then you may have missed the another house too: You can get into the upper floor of the house to the east of the inn (the one with a balcony) too, by either climbing on the wooden small roof, or by coming from the inn where you can open a window on the upper floor (and then on the balcony this way). But its not so story relevant as the other house, just another route into the inn and some loot)

Link to comment
Share on other sites

I'm still playing through this now, but just noticed something badly broken in the latest SVN build:


At the cellar door entrance of the Inn around back, the lockpicking sounds cannot be heard from the outside (also, there is no handle). One can see the lockpick light up green, and I noclipped through and could hear picking sounds on the inside, but not the outside. The doors also have no visible handles, not sure if they are supposed to. Might this be due to a door handle location/model change, assuming it doesn't happen in 1.07?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • peter_spy

      It's funny how perception changes over the years. I've been replaying Bioshock in its Remastered version, and I'm surprised how bad the level design actually is. It's just a series of abstract corridor mazes that you can't really map out in your head. There's nothing that would ground them in any kind of reality, fictional or otherwise, no sense of place people could live in. It's almost like Wolfenstein 3d with cool art deco assets.
      · 9 replies
    • STiFU

      Anyone here played Inscryption? At first, I was like "no, I am not going to play a stupid card game", but this game is so much more than that. It is so meta, full of 4th wall breaks, and feels so damn spooky and weird because of it. Absolutely recommended, if you can stand the visuals. I recommend not reading up too much on it, as that could easily spoil half the incredible surprises. Just know that what you see in the beginning is by far not everything.
      · 4 replies
    • freyk

      Tried to make a tdm advertisement commentpost at one of civvie11 youtube videos about T2. Post got marked as spam. His problem (to not discover TDM for himself),..not my problem.
      But some help of some fellow TDM yt-videocomment posters would be nice. To ask him and others, to play TDM. To get more players/creators. 
      · 5 replies
    • datiswous

      Currently Profile Information has 3 fields, these are shown in forum posts under your avatar:
      1. Gender
      2. Location
      3. Interests
      I think that it could be useful to have an extra field called "Operating system" (under location). It can be useful for tech support and to see what people use.
      Alternatively it could be a more general term, like PC system, so that you can for example state that you use an AMD gpu.
      · 2 replies
    • OrbWeaver

      Greetings fellow kids.
      · 11 replies
  • Create New...