Jump to content
The Dark Mod Forums

How should LWO models be imported to TDM?


someTaff
 Share

Recommended Posts

No shader issue with the model. Even if path to textures set to like "//doom\darkmod\textures\props\trees"

Do i need MTR file to represent model in DR or what?

Thanks!

Edited by someTaff

What excuse do we have not to sculpt, and sculpt, and sculpt, until the job is done?

Link to comment
Share on other sites

All textures in the game require a material shader, because a "texture" in D3 is usually a mixture of three or more different image files.

 

For basic testing, all you need is this:

 

shader_name

{ diffusemap "[path and name of image file]"}

 

Then name the surface "shader_name" in LW.

  • Like 1
Link to comment
Share on other sites

Then name the surface "shader_name" in LW.

Can you be more specific about shader and LW?

Got mtr and textures, they look allright in TDM

treetr.jpg

Goodbumpkins i just renamed shaders in LW with TDM mtr-names and it worked!

tree_tr.jpg

it's ugly, too hipoly, but it works!

Gona make more pretty trees!

tr_ar.jpg

Whats the tris policy on trees? About <3k?

Edited by someTaff

What excuse do we have not to sculpt, and sculpt, and sculpt, until the job is done?

Link to comment
Share on other sites

Whats the tris policy on trees? About <3k?

 

Yes, as long as the majority of it doesn't cast shadows that should be fine. A lower poly version for LOD would also be useful.

Link to comment
Share on other sites

  • 7 months later...
Then name the surface "shader_name" in LW.

specifying my own paths to the textures but retaining the original texture names didn't work, so I have to open up the .LWO model in a text editor (in this case notepad++) and see what path the model was expecting to see.

 

Is there no way to use custom paths with an .LWO model then..?

Link to comment
Share on other sites

You could either use a skin, or remake the material shader to point to your own textures.

Link to comment
Share on other sites

It should. The .lwo model just points to a regular material shader, like tdm_dark_wood.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • peter_spy

      Perhaps an unpopular opinion: TDM team might benefit from someone with actual QA experience; someone with naturally and professionally developed curiosity, who is interested in how and why things work, how they break At least to me it's kind of mind-boggling how untested some rather important features are (first the absence alert feature for items, now the rope +body carry behavior).
      · 4 replies
    • nbohr1more

      The Dark Mod is hosting an Ask Me Anything thread on the PC Gaming reddit forum:  https://www.reddit.com/r/pcgaming/comments/10nfcwj/hello_we_are_the_international_development_team/
      Feel free to join the discussion there
      · 2 replies
    • stgatilov

      Bumped into an interesting piece of wisdom called Hyrum's Law:
      With a sufficient number of users of an API, it does not matter what you promise in the contract: all observable behaviors of your system will be depended on by somebody.
      · 5 replies
    • The Black Arrow

      I love playing The Dark Mod when it's cold in my place. Bonus points when it's a bit (or even very) dark and it's raining, too.
      · 2 replies
    • The Black Arrow

      I've been having stutters in Vulkan, apparently it's Nvidia Drivers' fault, so I reverted to 512 according to this: https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/505679/regular-microstutter-in-vulkan-applications-after-/?topicPage=40

      And no, that did NOT fix it. What's going on? My GPU is an RTX 2070, by the way.
      · 4 replies
×
×
  • Create New...