Jump to content
The Dark Mod Forums

Poor framerate with vsyn on.


Recommended Posts

Try disabiling Catalyst AI from the catalyst control center. Also, you might want to check the vsync options from there as well.

 

You might get improved framerates with vsync on by turning anti-aliasing off, from TDM graphics options.

Clipper

-The mapper's best friend.

Link to post
Share on other sites

No matter what aa and others options , framerate with vsyn on is always the same.

 

There is little progress ; d

 

I disable vsync in game, and made a Dark mod profile in CCC. I enable vsync and 3 buffer OpenGL. Now, the framerate is always 60 and tearing is gone but a little stuttering appears. Damm, so close ; d

Link to post
Share on other sites

Vsynch limits the possible framerate because that is how it works (from my understanding) to synchronize frames to avoid the horizontal line in the middle. So you'll never get over 60 fps - you shouldn't see freezes or such things under 20 fps. Try deinstalling catalyst control center and installing the newest driver. I am having no problems with this setup.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

@John

 

One of my spare gfx cards is a HD5870 which is about the same or slower than your HD6850 and it runs TDM at max all of the time in the Training mission. So with the greatest respect there has to be an issue with your setup, did you do my driver remove/install list above..? Can you confirm what ATi/AMD driver version your currently running..?

 

And regarding Vsync, is it really such an issue to have it off..?

Link to post
Share on other sites

I installed 13-9_win7_win8_64_dd_ccc_whql ( cleaned with driver sweeper too ) and no improvement. With "vsync off", the screen tearing is so big ( on my PC ), that I can not concentrate on the game : (

Edited by John5
Link to post
Share on other sites

1. Uninstall your driver with driver clean.

2. Install the new driver using custom installation and uncheck the catalyst control center.

 

@ bikerdude, it is difficult, because for some people it works when CCC is installed and they deactivate all ATI custom settings. For me, it worked when I did a clean driver install without CCC. So I guess it is worth a try.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to post
Share on other sites

Hi John5,

 

I don't run an ATI card at the moment but have in the past.

I suggest you change some setting and see if your frame rate improves as Bikerdude eluded to above there are many settings that can effect performance.

Try changing some advanced settings within TDM and keep all setting in the CCC to default with the exception of: Turn anti aliasing off.

post-20393-0-07478000-1381415407_thumb.jpg

Try changing these settings to simple or normal.

post-20393-0-68144600-1381415657_thumb.jpg

These settings should be anti aliasing off and anisotropic 8X max for your setup I would think.

 

Vsync is almost always better on as the game engine is as I understand it coded to time at a 60 Hz refresh rate. So if the hardware is not capable of producing more than this then Vertical synchronization can help to minimize choppiness.

 

Just a suggestion and don't give up as your setup is pretty good and should perform well. You may also try a resolution of 1280 X 720.

It also makes me think that the problem could be something else running in the background as freezing in game is usually due to processor limitation and the I3 your running has plenty of cycles to spare.

Laptop:Metabox P370SM3- Intel Core i7-4800MQ- 2x GTX780M SLI- 16G 1600Mhz- 500G Samsung mSata-1TB Hitachi HDD- 120Hz LG 1080p.Desktops:i75930k-2x GTX980 SLI-16G 2133Mhz-Evo120GSSD-Swift PG278Q1440p Gsync.Spare:AMD A10-7850K-APU-8G 1866Mhz-seagate 4TB-120G ssd. LoL Old:P75-1:1FSB-8M ram 512MB Maxtor HDD-1MB Cirrus Logic video chip-still got the parts somewhere?First PC-Tandy 512K Color computer.

Link to post
Share on other sites

Sorry for the double post it's not my fault.

Edited by Tr00pertj

Laptop:Metabox P370SM3- Intel Core i7-4800MQ- 2x GTX780M SLI- 16G 1600Mhz- 500G Samsung mSata-1TB Hitachi HDD- 120Hz LG 1080p.Desktops:i75930k-2x GTX980 SLI-16G 2133Mhz-Evo120GSSD-Swift PG278Q1440p Gsync.Spare:AMD A10-7850K-APU-8G 1866Mhz-seagate 4TB-120G ssd. LoL Old:P75-1:1FSB-8M ram 512MB Maxtor HDD-1MB Cirrus Logic video chip-still got the parts somewhere?First PC-Tandy 512K Color computer.

Link to post
Share on other sites

I have to agree with this problem! I have pretty decent PC that can run this game maxed out with < 30% GPU usage! I am using Radeon 7950 3GB @ 960/1250 and turning on VSync, drop the framerate to 30fps all the time...its a double buffered VSync...without VSync like the OP mentioned, the screen tearing is horrendous and unbearable! I tried forcing Triple Buffering and VSync externally using D3DOverrider but it doesn't seem to work!

Link to post
Share on other sites

Games hate it when you try force driver side stuff.

 

The game supports extra buffering, just use that. The way that frames are drawn will try to handle something similar to v-sync, extra buffering that the game doesn't know about will often lead to the performance falling off in multiples. Try not forcing vsync or anything from the driver, leave it all up to the application. Set what you want in the game options.

 

The tearing you mention is quite likely the result of AMD's overly aggressive power management, which will swap power profiles many times per second and lead to all kinds of trouble. However since I have a 7850, I will try and test different things tomorrow.

Link to post
Share on other sites

Again I don't remember having any of this issue with my old HD5870, yes there is tearing with vync off, but how bad is bad is a matter of context.

 

I actually don't care for screen tearing most of the time, but sometimes its a bit too obvious and explicit! That's when it bother me a little....but I guess for now I am just gonna keep it off...

 

Games hate it when you try force driver side stuff.

 

The game supports extra buffering, just use that. The way that frames are drawn will try to handle something similar to v-sync, extra buffering that the game doesn't know about will often lead to the performance falling off in multiples. Try not forcing vsync or anything from the driver, leave it all up to the application. Set what you want in the game options.

 

The tearing you mention is quite likely the result of AMD's overly aggressive power management, which will swap power profiles many times per second and lead to all kinds of trouble. However since I have a 7850, I will try and test different things tomorrow.

 

How do I use the extra buffering? Is there a cvar for it?(I am too lazy to look for it right now! :))

Link to post
Share on other sites
  • 2 years later...

For the purpose of not writing in another thread I'll do it here.

 

Is there any way to enable the monitor refresh rate to 72 Hz in-game?

There is a conveniantly placed widescreen togglable settings for 16:9 and vice versa to 4:3 but... not this crucial graphics option.

 

The game runs by default at 60 Hz. Whenever it's running at 60 - screen tearing may occur due to circumstances that may be, this in turn hits performance because by running the game at 30 FPS by default, any framerate hit will be more noticeable, whereas with 60 FPS as the max. the human eye can't notice it.

My current LG Flatron screen supports 72.

 

Please tell me if there's a console command for that to use and thanks in advance.

Edited by Anderson

"I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

Link to post
Share on other sites

inside .ini

 

;RefreshRate=0 (driver default, set to 72?)

 

?

I've got 3 .ini files and none of them have Refresh rate paragraphs in The Dark Mod folder.

 

The console doesn't recognize these parameteres.

Edited by Anderson

"I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...