Jump to content
The Dark Mod Forums

Call for TDM 2.0 Mac builds


texmex
 Share

Recommended Posts

Malex, i dont get your build (both debug and release files in the tdm.app) running on osx snow leopard (and now on) mavericks.

Build your build of 1.08 runs fine on those os'ses.

 

What do you need from me to fix this?

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Here's a quick guide to installing, so you can see if you missed any steps:

 

1. Download the 2.0 binaries from Malex' mydrive: mydrive.ch with username darkmod@malex984 and password darkmod

2. Download the full 2.0 pack. This torrent works.

3. Put the full 2.0 pack in ~/Library/Application Support/Doom 3/darkmod

4. Extract and copy over the binaries from Malex, overwriting any conflicts.

5. TDM should now work. If it doesn't, run gdb.sh using the terminal (just type in ~/Library/Application\ Support/Doom\ 3/darkmod/gdb.sh and it should work) and post your output here.

 

Did you check it was in the /application support/doom 3/darkmod folder?

  • Like 2

You can call me Phi, Numbers, Digits, Ratio, 16, 1618, or whatever really, as long as it's not Phil.

Link to comment
Share on other sites

Okay, so I couldn't run the game in fullscreen mode: it would just reset the r_fullscreen to 0 every time it loaded. Turns out it was an arg on a file inside the package: contents/MacOS/Doom 3 automatically sets r_fullscreen to 0, which is annoying if you want to play the game in full screen.

 

Looks stable otherwise. I'll go test some missions now.

Edited by 161803398874989

You can call me Phi, Numbers, Digits, Ratio, 16, 1618, or whatever really, as long as it's not Phil.

Link to comment
Share on other sites

I got finnaly also tdm 2.0 working on mac os x mavericks.

 

My solution are the following steps:

  1. Download the full installer from modddb
  2. Download Malex Binary
  3. Open the finder and go to your home folder > Library > Application support
  4. Create the folder and give it the name "Doom 3"
  5. Extract the content of the full installer into the Doom 3-folder.
  6. Go to the Doom 3 folder and rename the unpacked folder "THE DARK MOD Version 2.0 - Standalone Release/" to "darkmod"
  7. Unpack the content of malex's binaries to the darkmod folder.
  8. go to the darkmod folder
  9. delete existing file "tdm_game03.pk4"
  10. rename "tdm_game03.pk4.tdm2.release" to "tdm_game03.pk4"

To run the game, open the terminal and type the following commands (for every line hit the enter-button):

cd ~/Library/Application Support/Doom\ 3/darkmod/TDM.app/Contents/MacOS/
./thedarkmod.x86.release +set fs_basepath "/Users/yourusername/Library/Application Support/Doom 3/darkmod/"

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Some notes using my sollution:

  • You don't need to download the torrent. (downloading that torrent was to slow for me)
  • An standard Mavericks installation/upgrade doesn't have gdb. (And i didn't find gdb Binaries on the internet. Only the source. Some doom 3 users advices lldb.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Some notes using my sollution:

  • You don't need to download the torrent. (downloading that torrent was to slow for me)
  • An standard Mavericks installation/upgrade doesn't have gdb. (And i didn't find gdb Binaries on the internet. Only the source. Some doom 3 users advices lldb.

 

I also never used torrent since tdm_update.macosx worked for me - just don't forget that official TDM sites provide TDM1.08 binaries for OSX at the moment (AFAIK).

 

Running TDM under a debugger (e.g. gdb or lldb) is not necessary for playing (as it will slow down TDM) but a great thing while reporting a problem.

Link to comment
Share on other sites

  • 2 months later...

@161803398874989 I followed your directions and it worked flawlessly. Thanks a lot. I didn't even have doom 3 installed and it worked. Two questions: At this point can I just run the updater and update to 2.1 or would that bring about more issues? And does anyone know how to fix the fullscreen problem?

Edited by mintmind
Link to comment
Share on other sites

  • 3 weeks later...

Heh, I'm looking for a cheap second-hand MacMini for development and testing of Mac builds. No idea when that will materialise though, but hopefully we'll be able to start packaging tested Mac builds again in the future (New Horizon #1).

I am the bat. The night is mine.

Link to comment
Share on other sites

You could build a hackintosh instead, but it want be as conveniient as a mac mini though.

 

I've been considering that as well. Just comes down to cost really since I don't want to spend too much on the full package (kinda hoping that the new HP and ASUS ChromeBox can be made to run OS X).

I am the bat. The night is mine.

Link to comment
Share on other sites

Ok well good places to go for info regarding usein older 7 cheaper PC laptops -

 

- http://myhack.sojugarden.com/guide/

- http://www.osxlatitude.com/ and list of laptop that already have boot packs - http://www.osxlatitu.../compatibility/

- http://www.osx86.net/index.php?

 

I was able to turn my Dell Latitude E6420 into a hackintosh (core i7 & nVidia E4200), I havent got around to making dual boot though (Win7/OSX)

Link to comment
Share on other sites

  • 4 weeks later...
  • 4 weeks later...

The link on that site points to TDM's downloadpage, Bikerdude.

 

if you boys are thinking about this, I will make a point of trying to get my hackintosh up and running with Mavricks

I upgraded my darkmod installation to 2.01 with the windows updater, because the mac updater didn't find any mirrors.

After running the update, I was hoping to find an 2.01 mac binary inside the folder, but didn't. :(

So i copied malex's 2.0 app to the 2.01 folder and run it.

Malex app works with the updated files(!) and I played succesfully an old saint lucia's mission.

 

But after the update running the malex binary, darkmod shows the version 2.0 instead of 2.01.

The windows version detects version 2.01.

Is there a way to manually change my version in the mac binary or something else to solve it?

 

To make new windows/mac players easier, is it possible to port the updater and excutable to unity3d?

 

At this point can I just run the updater and update to 2.1 or would that bring about more issues?

I updated my installation to 2.01 with the windows updater (through wine).

(if you dont trust the updater, just make an backup of your darkmod folder. Or change the download location in the updater for a full new installation)

At the moment, I dont have full screen problems.

 

..Now if only there was a DarkRadiant OSX build...

For the time beeing, Run Darkradiant with Wine.

I succesfully started Darkradiant with Wine (through playonmac), but have not the knowledge to create an map.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I updated my installation to 2.01 with the windows updater (through wine)...

..For the time beeing, Run Darkradiant with Wine.

I succesfully started Darkradiant with Wine (through playonmac), but have not the knowledge to create an map.

For the people who want to know:

Darkmod 2.01 runs quite good under wine (with wine, with playonmac as frontend under mac os x mavericks).

The only bug i found is a standard doom3-wine-bug, you cant change the brightness/gamma in the game.

(looking for solutions,..)

With playonmac you can also create an .app-shortcut, to place it in your applications folder and dock.

 

Ok, it doesn't work natively. But for the time beeing, it is a good alternative for the missing mac 2.01 build.

If you would like, i can write a instruction for the wiki how to set this up.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • duzenko

      Please, can we finally group the missions by year in the game menu?
      · 3 replies
    • duzenko

      I vaguely recall someone recently complained about two-sided materials (curtains?) not getting lighting from both sides
      I just found a piece of code that's supposed to do just that
      Where was that discussed? (@nbohr1more?)
      · 8 replies
    • Xolvix

      I still play classic Doom (albeit with user-made mods and maps rather than the original campaign) on a regular basis. A game from the early 90's which has still got a healthy following in 2022. Pretty amazing.
      · 3 replies
    • Nort

      I'm beginning to understand why people who aren't into social clubbing "don't last long" on this project, and why it's so full of holes. When moderators are siding with bullies, by closing down threads that they derail, then I start to wonder if I should support the platform to begin with.
      I'm sure that the core development is solid, but when you're constantly tone policed and bullied, and moderators are playing into it too, then the project will just drive away talent, and replace it with socialites instead. ...and without talent, you only end up with a small skeleton crew trying to do everything themselves.
      ...so Dragofer and Airship Ballet, and all you other socialites, you win. From now on I'll just keep to myself. You'll never be able to do my work, but at least you'll be happy together, and that's what matters to you.
       
      Update
      Actually, I have to revise my statement:
      I actually messaged greebo - the top dog, I gather - about nbohr1more's outburst of insanity below, and since I haven't even heard back from him, I just have to assume that there's not a single core programmer here, who's not backing nbohr's threats. ...and that's bad.
      ...so if you're a newbie reading this, or an honest soul like ZergRush, then just slowly back out of these forums, run, and don't look back. This is nothing more than a cult posing as a game development project, using Thief and IDTech4 to sucker hopefuls in, to do work for them, while trying to cajole them into something going on behind the scenes, which apparently - according to nbohr - is something that should be hidden from the state. These people aren't programmers - they don't even understand things like how to fix the simplest bugs. All they have, is an engine, and an IP, and some sort of fascist social cult. There was some other project I saw being made in the Unreal Engine. Try joining that project. ...or start a project of your own. Anything but this asylum.
      Hopefully that was "divisive" enough for a final post, because at this point I really want people to leave this place. This project is, on a management level, just awful garbage, run by garbage people, apparently from the top down, and I'm just glad that they have a garbage place to stay, together, and hopefully forever.
      Nort
      · 9 replies
    • The Black Arrow  »  Araneidae

      A spidey! I love spideys 🕷️
      · 0 replies
×
×
  • Create New...