Jump to content
The Dark Mod Forums

Standalone has extremely glitchy sound on linux.


Recommended Posts

Basically on the linux standalone version I will have laggy sounds that delay for 30 seconds maybe even a minute. I have found a way to temporaraly fix it but its only a matter of time before it breaks again, and it seems to break whenever something happens like a guard kills or sees me, i mess with the settings, etc. Just walking around and moving stuff doesn't seem to break it.

 

So I've done some searching on this topic and have found various fixes such as:

Killing pulse audio

tinkering with s_alsa_pcm

pasuspender

s_driver oss

and a few more that could easily be found with google

 

None of these worked for me, however I have found that deleting my darkmod.cfg file has fixed it, but i have to reset all my binds and stuff so I started narrowing it down to the problem and I've found deleting the line: seta r_mode "-1" fixes it. The game boots up in god awful resolution which needs to be tweaked to fix it, but for some reason r_mode is related to the sound breaking. None of the S_ commands (which I assume are sound related) have any impact on it.

Edited by FatSpy
Link to post
Share on other sites

Yeah I had that problem too when I was running a vanilla Linux install with PulseAudio. I didn't know about any r-mode setting affecting it though. I just scrubbed PulseAudio (as I always do) to get good sound.

--- War does not decide who is right, war decides who is left.

Link to post
Share on other sites

I sort of depend on pulse audio a bit because so far its the only thing that can detect my microphone. Is there a good program in place of it that isn't as glitchy?

 

Whats weird though is I tried killing pulseaudio but that didn't seem to help.

Edited by FatSpy
Link to post
Share on other sites

Not really. I use vanilla ALSA because I use a wide variety of programs, and some of them do not get along with PulseAudio: Audacity, games in Wine, music trackers, etc.

 

It seems weird that your mic doesn't function unless you use PulseAudio. Is it a USB mic? Those are (technically) another sound card.

 

I'm not advising you to rip out the entire audio stack and replace it though because that can cause lots of trouble. e.g. some desktops' integrated volume controls REQUIRE PulseAudio and will not function without PA, as dumb as that is.

--- War does not decide who is right, war decides who is left.

Link to post
Share on other sites

Check to see that your s_alsa_pcm is set to default and your s_driver is set to best or alsa.

 

Also, last time I got rid of PulseAudio, all my audio was muted afterwards. Run alsamixer and make sure critical things like PCM and speakers are not muted and at decent volumes.

Edited by lost_soul

--- War does not decide who is right, war decides who is left.

Link to post
Share on other sites

Check to see that your s_alsa_pcm is set to default and your s_driver is set to best or alsa.

 

Also, last time I got rid of PulseAudio, all my audio was muted afterwards. Run alsamixer and make sure critical things like PCM and speakers are not muted and at decent volumes.

 

That actually fixed it, thanks.

 

I still think that r_mode should be looked into if pulseaudio is to work with the dark mod stand alone.

Link to post
Share on other sites

I don't recall r_mode having anything to do with sound (r_ refers to renderer settings)? What hardware are you running on and which distro+version?

 

Not really sure if hardware is really relevant as it seems to just be completely related to pulseaudio, the problem was (seemingly) permanently fixed after I deleted and purged pulseaudio then changed s_alsa_pcm deleting r_mode just temporarily fixed it and I'm not saying r_mode specifically fixed it, just maybe had a side effect that made pulseaudio not glitch out.

Link to post
Share on other sites

This will be great. Plain ALSA is too glitchy to enjoy TDM.

PA is the real issue here, ALSA and OSS are working correctly :) But yeah -- I will try get this stuff sorted, since I myself need it. Wont be in the next minor release however!

Link to post
Share on other sites

I have the same problem here.

 

With standalone and PA, I have glitchy sounds all the time. I stopped PA, stopped also the autorespawn, but I have problems because I use and external USB soundcard, so Alsa it's no working.

It's not possibile to have a script in standanlone that if he found PA, he use instead something different?

Edited by Ladro
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...