Jump to content
The Dark Mod Forums

darkmod-2.0 standalone on linux: Black menu screen, image loading error


Recommended Posts

Hi,

 

I've tried to run TDM-2.0 downloaded via torrent (not from TDM website, it wasn't available there at that time) on my gentoo-x64 box. I've fixed a relative path problem by renaming the game's folder to "darkmod", but now it prints lots of errors like "WARNING:Couldn't load image: guis/assets/mainmenu/buttons_loadsave/loadmission" on startup. It finds all files in the search path, but can't load the images.

 

The menu screen is completely black. Sound works fine, I can hear the feedback when I hover the mouse over a button. I guess not being able to see anything has to do with those image loading failures, right?

 

Any idea how I can solve them?

 

I've deleted the Darkmod.cfg and re-ran the updater, but that didn't solve the problem.

Link to post
Share on other sites

I guess it's also a problem with S3TC:

 

Checking portable OpenGL extensions...

v - using GL_ARB_multitexture

v - using GL_ARB_texture_env_combine

v - using GL_ARB_texture_cube_map

v - using GL_ARB_texture_env_dot3

v - using GL_ARB_texture_env_add

v - using GL_ARB_texture_non_power_of_two

v - using GL_ARB_texture_compression

X - GL_EXT_texture_compression_s3tc not found

v - using GL_EXT_texture_filter_anisotropic

maxTextureAnisotropy: 16.000000

v - using GL_EXT_texture_lod_bias

v - using GL_EXT_texture3D

v - using GL_EXT_stencil_wrap

v - using glStencilOpSeparate

X - GL_NV_register_combiners not found

X - GL_ATI_fragment_shader not found

X - GL_ATI_text_fragment_shader not found

v - using GL_ARB_vertex_buffer_object

v - using GL_ARB_vertex_program

v - using GL_ARB_fragment_program

X - EXT_depth_bounds_test not found

 

It's strange because my hardware/software actually supports S3TC. Could it be I would need to install libtxc_dxtn for 32bit?

 

The solution from the FAQ doesn't work:

seta image_usePrecompressedTextures "1"

seta image_useNormalCompression "2"

seta image_useAllFormats "1"

seta image_useCompression "0"

seta image_preload "1"

Besides, I've got a completely black screen, not a "mostly" black screen.

Link to post
Share on other sites

For some distros it is not enough to have the package installed, you also need to enable its use. Just google for your distro name and s3tc and you should find something. Most of the time you can get away with just adding an env, s3tc_enable=1 iirc.

Link to post
Share on other sites

Yes, I think I have that env enabled. Other games work with S3TC. I believe libtxc_dxtn for 32-bit is not installed on my system, only the 64bit version. It may also be that the 32bit emulation libs/drivers provided by the distribution have no S3TC support built-in. Is it already possible to compile a 64bit TDM?

 

X - GL_EXT_texture_compression_s3tc not found

 

Relevant parts of glxinfo:

GL_EXT_texture_compression_rgtc, GL_EXT_texture_compression_s3tc,

GL_OES_read_format, GL_S3_s3tc

GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,

GL_OES_read_format, GL_S3_s3tc, GL_SGIS_generate_mipmap,

 

R600_ENABLE_S3TC=1

Link to post
Share on other sites

Thanks, such a port would certainly be much appreciated. More and more systems are 64bit nowadays. By now, I've gotten rid of anything 32bit on my system, which has been a problem 2 years ago. Package maintainers of all linux distributions could integrate it more easily into their systems. Recently, we linux users get nice improvements on the graphics driver side too.

 

I've copied the game dir to my windows partition; On the first launch, I had the same error. I then deleted the cfg and ini files and relaunched the updater, which downloaded/updated one additional dll file. This solved the issue in Windows (or probably only deleting the ini file solved it, don't know).

 

On gentoo, grabbing a lib from somewhere might work but that is quite a hack and works around the good build/packaging system. The proper way would be to compile it myself so that it integrates properly. I think that would require to set up a 32bit chroot just for that. A bit overkill just for playing a game ;-) Besides, it might not only be a problem with the libtxc_dxtn, but with other missing dependencies too.

 

Thanks for your help, but for the moment I'll stick to booting Windows for playing this game. Hibernating and dual-booting is a nice and cheap solution to this problem.

 

I'm looking forward to your x64 port, though. It could make the game more future-proof and avoid memory limits.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...