Jump to content
The Dark Mod Forums

Thief 4 - How to make 33 FPS on a slow PC


Recommended Posts

WHEN MAKE CHANGES MY PC DO 33 FPS in THIEF 4 Benchmark test.

I have been testing a lot of config before this and this was the most stable non visual change setting.

 

Find file "BaseEngine.ini" file and edit the following lines. (Mine was found in e:\StreamApps\common\Thief\Engine\Config\BaseEngine.ini)

LINE TO BE CHANGED > TO ; SPEED UP GAMEPLAY TIP WITH NO VISUAL CHANGE. > Set BaseEngine.ini to "Read-Only" after changed it.

MotionBlur=True > MotionBlur=False ; Verified OK Disable motion blur

MotionBlurPause=True > MotionBlurPause=False ; Verified OK

AllowRadialBlur=True > AllowRadialBlur=False ; Verified OK Adds shadows on existing objects

Bloom=True > Bloom=False ; Verified OK

UseHighQualityBloom=True > UseHighQualityBloom=False ; Verified OK

 

 

There is one thing more.

When you start THIEF 4 a Menu shows up, select OPTIONS right away and mark/use/tick "32-bit" mode.

Then you are ready to start the game itself.

 

I was not able to add this to http://forums.thedarkmod.com/topic/16001-thief-4-tweaks-fixes/ it was locked.

I maked the account yesterday.

 

I just have to give you this advice because it seems like the game really start to get speedy.

 

My PC/MACHINE is an not the fastest, I buyed it 2008

2x2.2GHZ Intel Processor

4GB ram(800Mhz)

ASUS Nvidia Geforce GTX 750 Ti (the graphics without the 6 pin powersupply) very new graphics and QUIET card, Settings SPEND POWER, Just fast.

Windows8.1 64-bit SSD

 

When first running the THIEF 4 at the start I got 15 FPS maximum in Benchmark in thief4. (What the hell Tom raider & GRID2 = 60FPS)

Changed everything in Nividia controlpanel global settings to

"Primary screen"

NO ENERGY SAVING mode.

Performance mode.

No "Make it more quality" settings.

Then i got 25FPS maximum.

 

And after "BaseEngine.ini" was changed saved and "write-protected". And before game start in options "32bit-mode" selected.

I finally got 33fps with is pretty much better.

 

I use resolution 1280x720 Tripple buffer "Exclusive fullscreen" "Fullscreen" Preset "Very low"

 

I hope i help someone make thief4 playable.

 

/Jetpack5

Link to post
Share on other sites

You should have posted this in this thread-->http://forums.thedarkmod.com/topic/16001-thief-4-tweaks-fixes/

 

In any case, this:

 

"NO ENERGY SAVING mode.

Performance mode."

 

Has been fixed by Nvidia in the latest driver.

 

And this:

 

"I use resolution 1280x720 Tripple buffer "Exclusive fullscreen" "Fullscreen" Preset "Very low""

 

I get smoother framerate in-game if I turn double/triple buffering OFF and turn Exclusive Fullscreen OFF as well. YMMV.

Edited by Lux
Link to post
Share on other sites

I tried to add it in http://forums.thedar...4-tweaks-fixes/ first but "Topic locked" prevented me, sorry, (Admin may change that)

Maybe i should add screenshots of settings, i dont know?

I was write this because I almost thinking of buy a new computer.

What your computer configuration ?

I got the best gameplay flow in framerate with tripple buffering. Using benchmark in thief 4 all the time.

When i did NOT use "Exclusive fullscreen" the game was not playable 10fps is not i just like you know.

When did they update to the driver i got the version 9.18.13.3217 right now.

Maybe it is not working for all computers, but it sure worked on mine.

Thanks for reading it :) /Jetpack5

Edited by Jetpack5
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...