Jump to content
The Dark Mod Forums

TDM Updater - Repeatedly Downloading


Recommended Posts

I have version 2.0 and It keeps trying to download TDM_update_2.00_to_2.01.zip, then restarting the download again once it finishes (29.3mb over and over again with a average download speed of 200kbps, there is no zip file in the darkmod folder apart from with with 2 underscores before its name and 0 bytes big). I've waited patiently but every download mirror it tries downloading from does the same thing, downloading keeps restarting but gives no zip file and just starts restarts the download for the next mirror in a continuous loop. Its already bad enough that I need the whole Darkmod installation folder with me to the internet cafe just to download a measly patch, but this is bizarre. I tried copypasting the download link from the logfile into the browser, which worked but honestly that took longer than it needed for me to figure out the updater isn't doing its job. But then.. ugh again an issue.


I extracted the patch from the zip, 2.00 to 2.01, overwriting.. but now its saying my version is "no exact match" and trying to download the zip again :/


I put the zip file in the darkmod folder so I would think that the updater would notice that the update package zip is already there and shouldn't be downloaded, no luck still tries to download it regardless. This is ridiculous, doesn't matter what way I do it, it still won't allow me to get the next 2 updates.


I tried downloading the updater manually from the website: http://www.thedarkmod.com/download-the-mod/

Same issue.


My system is XP SP3, same as I've always had for TDM.

Edited by TheUnbeholden
Link to comment
Share on other sites

The update is definetely bigger then 29.3MB. Maybe something is wrong with the mirrors, or your connection. Can't really help you here, though.

FM's: Builder Roads, Old Habits, Old Habits Rebuild

Mapping and Scripting: Apples and Peaches

Sculptris Models and Tutorials: Obsttortes Models

My wiki articles: Obstipedia

Texture Blending in DR: DR ASE Blend Exporter

Link to comment
Share on other sites

I see in the updater's log file that the updater is checking the filesize of the 2.00->2.01 zip file after it's downloaded, finding that it doesn't match expectations, at which point it wipes the zip and tries again, endlessly.


I'm afraid there's no way around this short of fixing the bug in the updater in 2.04.


I'll see if there's a way of collecting the necessary zip files separately and making them available to you.


If I can't do that, then you'll need to do a full install of 2.03.

Link to comment
Share on other sites

Edit: try again. The main 2.00->2.01 zip file has been corrected, and pushed to a couple mirrors. Other mirrors will get the update tomorrow. If the updater does a retry, hopefully at some point it'll find the correct version and stop looping. The 2.01->2.02 and 2.02->2.03 zip files work fine.




Alternatively ...


taaaki has found that the 2.00->2.01 zip file has lost some weight since we released 2.01. Don't know why. Don't know if we can repair it. Still looking at the problem.


If you want to proceed with a cobbled-together solution, you can grab the 2.00->2.01 zip file here. Say yes when asked if you want to overwrite existing files.


After unzipping it to your 2.00 folder, you can grab the 2.01->2.02 zip file here. Say yes when asked if you want to overwrite existing files.


And, finally, after unzipping that to your 2.00 folder, you can grab the 2.02->2.03 zip file here. Say yes when asked if you want to overwrite existing files.


After unzipping that to your 2.00 folder, you should have 2.03. The new files will have been dropped into separate folders, rather than put into the pk4s, but it should work the same.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • peter_spy

      Deathloop – what a mess of a game. I'd love to see a post-mortem on it some day. I hope Arkane is doing okay though.
      · 15 replies
    • OrbWeaver

      I like house-cleaning and taking out the trash.
      · 1 reply
    • STiFU

      Be honest: Who of you have actually finished Cuphead? This game is freaking tough! It might even be harder than Sekiro. Dark Souls is a joke in comparison to Cuphead! :-D 
      · 8 replies
    • duzenko

      Please, can we finally group the missions by year in the game menu?
      · 6 replies
    • duzenko

      I vaguely recall someone recently complained about two-sided materials (curtains?) not getting lighting from both sides
      I just found a piece of code that's supposed to do just that
      Where was that discussed? (@nbohr1more?)
      · 9 replies
  • Create New...