Jump to content
The Dark Mod Forums

Errors when opening TheDarkMod.exe


Recommended Posts

Error During Initialisation

 

I have windows 10

 

I have followed all the directions for installing the darkloader. I couldn't find TheDarkMod.exe although the log showed that it had downloaded it.

I turned off UAC, and it showed up.

I clicked on TheDarkMod.exe and I had errors...a lot

 

I copied the logfile. The only thing I've tried to do with no success is the Read Only attribute. I have read comments online and I'm lost.

TheDarkMod.exe had the Read Only attribute unticked so I guess that's how it should be?

 

TDM 2.03 #6455 win-x86 Feb 8 2015 10:06:14
2195 MHz Intel CPU with MMX & SSE & SSE2 & SSE3
2016 MB System Memory
64 MB Video Memory
Winsock Initialized
Found interface: {22A4C23F-6B5A-4B52-AD8C-39D7CA2F2D43} Realtek PCIe GBE Family Controller - 192.168.1.64/255.255.255.0
Sys_InitNetworking: adding loopback interface
Found Intel CPU, features: MMX SSE SSE2 SSE3 CMOV
tdm using MMX & SSE & SSE2 & SSE3 for SIMD processing.
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Current search path:
C:\Games\DarkLoader/
C:\Games\DarkLoader\tdm_textures_wood01.pk4 (317 files)
C:\Games\DarkLoader\tdm_textures_window01.pk4 (345 files)
C:\Games\DarkLoader\tdm_textures_stone_sculpted01.pk4 (424 files)
C:\Games\DarkLoader\tdm_textures_stone_natural01.pk4 (123 files)
C:\Games\DarkLoader\tdm_textures_stone_flat01.pk4 (281 files)
C:\Games\DarkLoader\tdm_textures_stone_cobblestones01.pk4 (214 files)
C:\Games\DarkLoader\tdm_textures_stone_brick01.pk4 (440 files)
C:\Games\DarkLoader\tdm_textures_sfx01.pk4 (64 files)
C:\Games\DarkLoader\tdm_textures_roof01.pk4 (65 files)
C:\Games\DarkLoader\tdm_textures_plaster01.pk4 (140 files)
C:\Games\DarkLoader\tdm_textures_paint_paper01.pk4 (42 files)
C:\Games\DarkLoader\tdm_textures_other01.pk4 (51 files)
C:\Games\DarkLoader\tdm_textures_nature01.pk4 (256 files)
C:\Games\DarkLoader\tdm_textures_metal01.pk4 (465 files)
C:\Games\DarkLoader\tdm_textures_glass01.pk4 (46 files)
C:\Games\DarkLoader\tdm_textures_fabric01.pk4 (41 files)
C:\Games\DarkLoader\tdm_textures_door01.pk4 (171 files)
C:\Games\DarkLoader\tdm_textures_decals01.pk4 (367 files)
C:\Games\DarkLoader\tdm_textures_carpet01.pk4 (92 files)
C:\Games\DarkLoader\tdm_textures_base01.pk4 (375 files)
C:\Games\DarkLoader\tdm_standalone.pk4 (4 files)
C:\Games\DarkLoader\tdm_sound_vocals_decls01.pk4 (27 files)
C:\Games\DarkLoader\tdm_sound_vocals07.pk4 (1111 files)
C:\Games\DarkLoader\tdm_sound_vocals06.pk4 (688 files)
C:\Games\DarkLoader\tdm_sound_vocals05.pk4 (128 files)
C:\Games\DarkLoader\tdm_sound_vocals04.pk4 (2854 files)
C:\Games\DarkLoader\tdm_sound_vocals03.pk4 (743 files)
C:\Games\DarkLoader\tdm_sound_vocals02.pk4 (1300 files)
C:\Games\DarkLoader\tdm_sound_vocals01.pk4 (82 files)
C:\Games\DarkLoader\tdm_sound_sfx02.pk4 (596 files)
C:\Games\DarkLoader\tdm_sound_sfx01.pk4 (924 files)
C:\Games\DarkLoader\tdm_sound_ambient_decls01.pk4 (8 files)
C:\Games\DarkLoader\tdm_sound_ambient03.pk4 (24 files)
C:\Games\DarkLoader\tdm_sound_ambient02.pk4 (156 files)
C:\Games\DarkLoader\tdm_sound_ambient01.pk4 (209 files)
C:\Games\DarkLoader\tdm_prefabs01.pk4 (556 files)
C:\Games\DarkLoader\tdm_player01.pk4 (125 files)
C:\Games\DarkLoader\tdm_models_decls01.pk4 (93 files)
C:\Games\DarkLoader\tdm_models02.pk4 (1836 files)
C:\Games\DarkLoader\tdm_models01.pk4 (1915 files)
C:\Games\DarkLoader\tdm_gui_credits01.pk4 (49 files)
C:\Games\DarkLoader\tdm_gui01.pk4 (673 files)
C:\Games\DarkLoader\tdm_game02.pk4 (2 files)
C:\Games\DarkLoader\tdm_game01.pk4 (2 files)
C:\Games\DarkLoader\tdm_fonts01.pk4 (696 files)
C:\Games\DarkLoader\tdm_env01.pk4 (98 files)
C:\Games\DarkLoader\tdm_defs01.pk4 (166 files)
C:\Games\DarkLoader\tdm_base01.pk4 (155 files)
C:\Games\DarkLoader\tdm_ai_steambots01.pk4 (24 files)
C:\Games\DarkLoader\tdm_ai_monsters_spiders01.pk4 (82 files)
C:\Games\DarkLoader\tdm_ai_humanoid_undead01.pk4 (50 files)
C:\Games\DarkLoader\tdm_ai_humanoid_townsfolk01.pk4 (95 files)
C:\Games\DarkLoader\tdm_ai_humanoid_pagans01.pk4 (10 files)
C:\Games\DarkLoader\tdm_ai_humanoid_nobles01.pk4 (48 files)
C:\Games\DarkLoader\tdm_ai_humanoid_mages01.pk4 (8 files)
C:\Games\DarkLoader\tdm_ai_humanoid_heads01.pk4 (96 files)
C:\Games\DarkLoader\tdm_ai_humanoid_guards01.pk4 (373 files)
C:\Games\DarkLoader\tdm_ai_humanoid_females01.pk4 (169 files)
C:\Games\DarkLoader\tdm_ai_humanoid_builders01.pk4 (91 files)
C:\Games\DarkLoader\tdm_ai_base01.pk4 (8 files)
C:\Games\DarkLoader\tdm_ai_animals01.pk4 (80 files)
File System Initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
I18N: SetLanguage: 'english'.
I18N: Found no character remapping for english.
I18N: 1228 strings read from strings/english.lang
I18N: 'strings/fm/english.lang' not found.
WARNING:Couldn't load image: guis/assets/splash/launch
Couldn't open journal files
Couldn't exec editor.cfg - file does not exist.
execing default.cfg
Unknown command 'use'
Unknown command 'console'
Unknown command 'next'
Unknown command 'prev'
Unknown command 'previous'
Unknown command 'next'
Unknown command 'crouch'
Unknown command 'Lean'
Unknown command 'lean'
Unknown command 'Readables'
Unknown command 'spyglass'
Unknown command 'compass'
Unknown command 'lantern'
Unknown command 'maps'
Unknown command 'objectives'
Unknown command 'keys'
Unknown command 'lockpicks'
Unknown command 'lean'
Unknown command 'Inventory'
Unknown command 'Mantle'
Unknown command 'creep'
Unknown command 'frob'
Unknown command 'inventory'
Couldn't exec autoexec.cfg - file does not exist.
I18N: SetLanguage: 'english'.
I18N: Found no character remapping for english.
I18N: 1228 strings read from strings/english.lang
I18N: 'strings/fm/english.lang' not found.
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...getting default gamma ramp: success
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 7 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
Checking portable OpenGL extensions...
X - GL_ARB_multitexture not found
X - GL_ARB_texture_env_combine not found
X - GL_ARB_texture_cube_map not found
X - GL_ARB_texture_env_dot3 not found
X - GL_ARB_texture_env_add not found
X - GL_ARB_texture_non_power_of_two not found
X - GL_ARB_texture_compression not found
X - GL_EXT_texture_filter_anisotropic not found
X - GL_EXT_texture_lod_bias not found
X - GL_EXT_texture3D not found
X - GL_EXT_stencil_wrap not found
X - GL_NV_register_combiners not found
X - GL_ATI_fragment_shader not found
X - GL_ATI_text_fragment_shader not found
X - GL_ARB_vertex_buffer_object not found
X - GL_ARB_vertex_program not found
X - GL_ARB_fragment_program not found
ERROR:The current video card / driver combination does not support the necessary features.
--------------------------------------
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...restoring hardware gamma: success
...shutting down QGL
...unloading OpenGL DLL

fosig_zpshhfnjs18.png

Link to post
Share on other sites

Looks like you do not have proper driver support for the application.

 

Do you have the latest Video and Chipset drivers installed?

 

What hardware are you running?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

I have Intel G45/43 Express Chipset.

I've done the update driver option and it says I have the latest driver. I also went to their website and run their scan and got the same results.

Driver v 8.15.10.2702

fosig_zpshhfnjs18.png

Link to post
Share on other sites

@nbohr1more Do you know how to find out whether there's a compatibility problem here? Whether those functions are supported by that driver? Most of these functions were temporary EXT variants of what later became standard, but I can't imagine why a newer driver would ever remove any old function hooks, because it's almost zero cost to keep them in, and the cost of removing them is lack of backwards compatibility, which is very costly for driver manufacturers. So the problem is likely something different, but it would be good to exclude dropping of support for old EXT functions.

 

 

Edit: In fact, the list in the console dump seems to be ALL of the opengl function hooks that the engine tries to tap in to, in two affected places. So it's not likely to be down to support for individual functions.

Edited by SteveL
Link to post
Share on other sites

Slightly more info about llanita's specs here:

 

http://www.ttlg.com/forums/showthread.php?t=145709

http://www.ttlg.com/forums/showthread.php?t=145699

 

Dell Inspiron 560 with 2 GB of RAM... possibly with a Pentium E5700 + integrated graphics, although the clockspeed doesn't match what's listed in the error log above.

Edited by jaxa
Link to post
Share on other sites

Appears to be a DX10 compliant chip but that graphic driver looks like one that Windows supplied and there's no new Windows 10 version.

 

If you are on Windows 10 64-bit, you could try installing the Windows 7 driver:

 

https://downloadcenter.intel.com/download/22167/Intel-Graphics-Media-Accelerator-Driver-Windows-7-64-Windows-Vista-64-exe-

 

If you are on 32-bit here's the build:

 

https://downloadcenter.intel.com/download/22165/Intel-Graphics-Media-Accelerator-Driver-Windows-7-Windows-Vista-exe-

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Eww, I guess they will never be creating drivers for Windows 10 or Windows 8.x:

 

https://communities.intel.com/thread/49444

 

Still, as I recall, you should be able to install drivers as long as they are WDDM. I think Vista even allowed you to install pre-WDDM drivers

so it may even be possible to install the XP driver.

 

Caveats:

 

* You may need to use the Install Driver option in Device Manager and manually locate the exploded INF files (or deselect the "show only compatible drivers checkbox

and browse the Intel section) if the installer doesn't let you replace the native one.

 

* Supposedly, Windows 10 will keep trying to replace the driver with the one in their Windows Updates repo so you'll either need to get the tool to disable that behavior

or keep reinstalling drivers after every Windows Updates.

 

Time to install Windows 7 ;)

 

Or install an Nvidia or AMD video card into your PCIE slot.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

well I downloaded the vista 64 that you linked for me, and after opening it to install it, an error popped up saying

This computer does not meet the minimum requirements for installing the software

 

That's confusing to me. How can win 10 not meet the requirements for Vista?

I was thinking of getting a geforce graphic card but then I expect I'd have to upgrade one thing after another in order for it to work properly.

 

Thanks very much for all your help. I am very grateful for the time and patience you've all shown me.

thanks again

fosig_zpshhfnjs18.png

Link to post
Share on other sites

You could try running the installer under windows 7 compatibility mode (right click).

 

Video cards don't require other components except for power connectors for the high end ones. I've got a GeForce gt 730 for about $60 and all I had to do is seat it in and install the driver.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Yes, the GT 730 will work with your system.

 

*Really any PCIE card will work,

 

(*The more expensive graphic cards require a new power supply, so if you don't want to learn how to install

a new power supply or you don't want to rig some ghetto secondary power supply outside your chassis then you'll

want to stick with a mid-range to low-end graphic chip.)

 

you just need to temper your expectations and understand that more powerful graphic cards

might not run the latest games well because those games also tax your CPU.


 

But that's not a uniform statement.

 

For example, it's practically guaranteed that the new Serious Sam game will run on a very weak CPU

because that's how they make their game. They don't do lots of complex AI or physics, just simple 90's style action.

I know folks who have the latest graphics cards and use them for nothing other than cranking-up the image quality on the original Unreal Tournament

(which would run on a Pentium II), so it's all a matter of degree.

 

If you don't mind sticking with older games like Far Cry and HL2, and you want to be able to run them at ULTRA HD resolutions with

AA and AF all the way up you could go for a $200 or more video card and have a premium experience there...

just don't expect Battlefield 4, Thief 2014, etc to run as smoothly, they would most likely chug or stutter a bit during heavy scenes.

(Wolfdale will run GTA IV, Crysis, Skyrim and a lot of "fairly modern" games pretty well too. )

 

 

Wolfdale isn't such a relic really either. I think the TTLG folks were exaggerating a bit there.

 

We hit the GHZ ceiling around 2004 and now architectures are more about IPC gains but are mostly like

super Pentium III's. Sure a new 4ghz Skylake will blow this thing away, but this chip will go toe-to-toe with most

mid-range mobile CPU's and low-end systems today and most sane game developers want a wide audience so

they will make their games scale to lower-end CPU's.

 

I was playing TDM on an old Pentium 4 3ghz with an HD4650 before I got my new PC. Most missions would run from 30fps or

higher with occasional dips into the 10fps range, though a few were squarely in the 5 to 7 fps range and were mostly unplayable.

Your Wolfdale would smoke that old system so it should be fine with anything you choose. I just wouldn't go much lower or older

than the GT 730 since you'll probably want to run at close to native resolution. I run at 1440x900 most of the time and get mostly

60FPS, if I notch-up I have some pretty severe performance cliffs because that's about the limit of my 64-bit memory interface. If

you got a GT 740 with a 128-bit interface you'd probably be able to do 1920x1080 in most missions with no problem.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...