Jump to content
The Dark Mod Forums

configure fails with boost_major_version error


Recommended Posts

I upgraded from openSUSE 13.2 to openSUSE Tumbleweed today. Darkradiant has apparently stopped compiling, and I get the following error during ./configure:

configure: error: invalid value: boost_major_version=

I checked my packages and should have all boost libraries installed. My boost version is 1.58.0. Any thoughts?

Edited by MirceaKitsune
Link to post
Share on other sites

I googled this issue today. Apparently the problem lies on DarkRadiant's side, and the autogen / configure script might need some tweaking. I tried a fix of my own as follows:

 

In mp/boost.m4, I commented out lines 217 and 422, which are both errors that were encountered by ./configure. They are:

AC_MSG_ERROR([invalid value: boost_major_version=$boost_major_version])

AC_MSG_ERROR([cannot find the flags to link with Boost $1])

Configuration succeeded afterwards. I was able to compile Darkradiant for well over 15 minutes, until it eventually failed with the following error:

  CXXLD    darkradiant
/usr/lib64/gcc/x86_64-suse-linux/5/../../../../x86_64-suse-linux/bin/ld: cannot find -lboost_filesystem-d
collect2: error: ld returned 1 exit status
Makefile:2043: recipe for target 'darkradiant' failed
make[1]: *** [darkradiant] Error 1

Obviously I have libboost_filesystem installed, adding the file /usr/lib64/libboost_filesystem.so.1.58.0. The setup simply fails to see them apparently.

Link to post
Share on other sites

Worked around this by downloading Boost 1.54.0, and using "./configure --with-boost=foo/bar/" to point the scripts to it. Didn't compile yet but I imagine it should fix this specific issue.

 

Also reported this as a bug on the tracker: http://bugs.thedarkmod.com/view.php?id=4239

Link to post
Share on other sites
  • 2 months later...

I have Arch Linux and use boost 1.59. To bypass this bug until it gets fixed, I opened the configure script and simply changed the line to boost_major_version=159.

-    boost_major_version=`echo "$boost_cv_lib_version" | sed 's/_//;s/_.*//'`
+    boost_major_version=159

Also, I had to change the AUTOMAKE and ACLOCAL variables in the generated makefile, because they were set to aclocal-1.14 and automake-1.14 even though I have version 1.15 on my system. WTF? Maybe the DarkRadiant devs should consider using CMake.

Edited by Radegast
Link to post
Share on other sites
  • 11 months later...

I know it's a long time since the thread has been started, but is this still an issue on your systems?

 

The automake problems typically go away if ./autogen.sh is invoked before compiling. It works for me regardless of the automake versions, be it 1.14 or 1.15.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...