Jump to content
The Dark Mod Forums

Recent compilation instructions


kritzefitz
 Share

Recommended Posts

I recently halfheartedly tried to comile TDM on my Debian Stretch (amd64) system.

I didn't succeed, mostly due to the fact that I couldn't find any recent compiling instructions. The file COMPILING.txt just directs to this wiki site which seems terribly outdated and many of the listed dependencies aren't available in recent Debian versions anymore.

I tried to just compile it by running scons, but I ran into lots of compilation errors, probably because I missed to do many things, which recent compiling instructions would tell me to do.

 

Did I just not find recent instructions or are there really no recent instructions?

Link to comment
Share on other sites

I'm not experienced with compiling TDM on Linux distro's.

But please post your compilation errors, so we can have a look at it.
Maybe you can find/make your solution by reading the user topics from ProfessorKaos64 (who compiled tdm (i386) for Steam-os) and people who want TDM to run on their 64 bit systems.

I know that the some wiki articles don't get recent updates. (the latest edits for linux build article are from 2014).
So you need to find your own solution, create/try it yourself, post the results again on this forum and send an update request to the wiki-article writer.
(as what i did)

Could you tell me why people compile software, knowing when there binaries are available (for their system) (from the official source/site)?
(and that 64 bit linuxsystems can run 32bit aplications, with some os modifications)
As a multi-os user, I always wanted to know that.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Possible reasons to use the source:

- Getting the version compiler-optimized for the user's CPU

- Getting the thing running on a 64.bit-only rig (its 2016 - some hardliners dropped 32-bit-support on their Linux boxes ten years ago)

- Ensuring that you really only get, what is in the source (yeah, not that much - but it is one of the foundations of FLOSS)

- Getting the latest unstable with all the shiny new features that did not make it in the last release (okay, not that relevant today, but i guess it was for some people a few months ago)

- Trying to implement own features or patches making the great thing even better

- And the most obvious one: For religious reasons (and don't get me wrong on this one - it is a valid cause)

 

Possible reasons to keep the build instructions up to date and dependencies well managed:

- Someone from outside the inner circle might start helping with development, fixing bugs or even implementing new features

- There may be more but that one above should be anough to make it worth the work

 

Link to comment
Share on other sites

I want to build from source, so I'm able to confirm that I'm actually running the source.

I'm also playing with the thought of packaging TDM as a Debian package, but that mostly depends on available time in the near future and various other factors.

A build log is attached. It contains a lot of errors, but I don't think I'm able to filter out the relevant parts.

scons.log.txt

Link to comment
Share on other sites

I just tried compiling TDM 2.04 with scons in Mageia Linux 6. Looking at kritzefitz' scons.log.txt, and doing a search for 'error', I see the exact same errors as I get on my system, starting with the following:

In file included from include/boost/filesystem/path_traits.hpp:23:0,
                 from include/boost/filesystem/path.hpp:25,
                 from include/boost/filesystem.hpp:16,
                 from game/../idlib/../idlib/Image.h:29,
                 from game/../idlib/../idlib/Lib.h:230,
                 from game/../idlib/precompiled.h:106,
                 from game/precompiled_game.h:28:
include/boost/system/error_code.hpp:221:36: warning: 'boost::system::posix_category' defined but not used [-Wunused-variable]
     static const error_category &  posix_category = generic_category();

This, being the first error in the log, is the first to look into fixing.

System: Mageia Linux Cauldron, aka Mageia 8

Link to comment
Share on other sites

I would also like to package TDM for Fedora Linux. It makes installing a breeze when you can use the software center and having a native 64bit build keeps you from having to install 32bit compatibility libraries.

 

 

I just tried compiling TDM 2.04 with scons in Mageia Linux 6. Looking at kritzefitz' scons.log.txt, and doing a search for 'error', I see the exact same errors as I get on my system, starting with the following:

In file included from include/boost/filesystem/path_traits.hpp:23:0,
                 from include/boost/filesystem/path.hpp:25,
                 from include/boost/filesystem.hpp:16,
                 from game/../idlib/../idlib/Image.h:29,
                 from game/../idlib/../idlib/Lib.h:230,
                 from game/../idlib/precompiled.h:106,
                 from game/precompiled_game.h:28:
include/boost/system/error_code.hpp:221:36: warning: 'boost::system::posix_category' defined but not used [-Wunused-variable]
     static const error_category &  posix_category = generic_category();

This, being the first error in the log, is the first to look into fixing.

 

I don't see an error here, just a warning, you may need to look a little further down.

 

Thanks,

Richard

Link to comment
Share on other sites

  • 2 weeks later...

I'm also playing with the thought of packaging TDM as a Debian package, but that mostly depends on available time in the near future and various other factors.

I would also like to package TDM for Fedora Linux. It makes installing a breeze when you can use the software center and having a native 64bit build keeps you from having to install 32bit compatibility libraries.

I'm working on RPM and DEB packages for TDM (topic / download site / GIT).

If you would like to help me, please pm me.

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...