Jump to content
The Dark Mod Forums

Mouse locking to borders of screen error in Antergos Linux


Recommended Posts

I'm running antergos linux. The game is installed, I've changed my resolution in the config file, and everything seems fine, until I load up the game. As soon as I get to the opening menu, my mouse locks to the edges of the screen, and it's nigh impossible for me to move it anywhere else. I've looked through a ton of different articles but nothing seems to help. A fix would be greatly appreciated. I cannot use the ingame config because I can't move the mouse to click on anything. I've tried running it in windowed only to have the same thing happen. I've posted this same thread on reddit but didn't really get a lot of help.

Edited by supergr35
Link to post
Share on other sites

Its safer to change the game screenresolution inside the game, instead of changing this in the config file.
So please delete file "darkmod.cfg" in your tdm-folder and run tdm again (to generate the config file with standard values).
Check if the mouse problem still exists. if not, set the game screen resolution and play tdm.

If the the mouse problem still exists, some user solllutions are

  • Disable vsync
  • Reinsert mouse cable
  • Disable compiz

(I searched with https://www.google.com/search?q=doom+3+linux+mouse+lock&oq=doom+3+linux+mouse+lock )

And does the console or log show something?
Can we see some logs created using some console commands and startup arguments, mentioned in/starting from crash in training arena, #entry 396389
(instead using the tdm-launcher, use your terminal. In your terminal window, navigate to your darkmod folder and run the tdm binary with some arguments.
For example: ./thedarkmod.x86 +gfxinfo +condump mylog.txt +quit)

Edited by freyk

Info: My portfolio and darkmod graphical installer
Amnesty for Bikerdude!

Link to post
Share on other sites

Disabling vsync did nothing. I cleared the config and nothing really changed other than the resolution becoming tiny. However, in this lower resolution, if I fiddled with the mouse enough, then it actually would eventually come across the small screen, however, it had extremely.....wonky.....sensitivity.

 

Here is a pastebin of the command you recommended me to use:

http://pastebin.com/ZMrVvtCm

Link to post
Share on other sites

Mousecorner problem is now solved. The playonlinux version runs a bit better than the one for linux. However, the mouse sensitivity is awful. I'll move it a direction, then move it back, and it will cause considerable cursor lag. This made changing the sensitivity and starting missions a pain, but it really didn't change much.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...