Jump to content
The Dark Mod Forums

Bugs with update to 2.05 - strange physics


Recommended Posts

 

... aaaaaand that may very well be the bug that was introduced.

 

I'll start with that.

 

That should have only affected belt-purses, not the spilled purse entity.

Link to post
Share on other sites

All the purses received a new frobbox_size of 10. If I remove that addition, the split purse in the safe is frobable.

 

I'm trying to understand why the addition of a frobbox_size should make the object appear twice, once with a reasonable bounding box and once with a large bounding box.

Link to post
Share on other sites

I'm going to leave the frobbox_size in place (and thus the second bounding box it creates). I don't want to tinker with frobability for items that define their frobboxes.

 

It's cleaner to verify that an item's physical clipmodel is touching the setFrobable target brush when that brush is building its list of 'contained items'.

 

This ignores the false positive that was telling the safe's lock that the spilled purse was inside its setFrobable target brush, which allows the purse to be frobbed when the safe is opened. (I also need to check that this is what was affecting the button inside the other safe.)

 

The solution should also fix the problem we had with the elevator switch in A New Job, but I need to verify that assumption. Adding this solution will not affect A New Job.

  • Like 1
Link to post
Share on other sites

The button in the floor safe worked fine for me with and without the fix. I would need more failure reports before I look at the button again.

 

The fix solved the problem with the elevator switch in A New Job. I removed the "immune_to_set_frobable" flag on the switch and it still worked fine.

 

I'm going to submit the fix for 2.06.

Link to post
Share on other sites
  • 3 months later...

The Creeps

 

I've found another unfrobbable purse that has not been reported in the forum before and it's easily frobbed in Fen's video of this mission.

 

It's the purse in the hidden compartment of the bureau in the room you get to by mantling up onto a couple of crates on top of the bales in the courtyard next to where you start the mission.

 

Hopefully this quicksave works though.

https://drive.google.com/open?id=0B7UExWqHXPI2M3loZkN4TEZWeDA

Link to post
Share on other sites
  • 5 months later...

Eh? I wasn't aware of this.

 

I hope you're going to tell me that physics behaves better.

Several months late, but:

 

With Dunia [2] engine - over 60FPS render will cause physics and scripting bugs. Have to choke it on modern hardware to stop many bugs and strange behaviours.

Maybe NASA could run Farcry2 on max settings back then, but no-one else could... Even still - who had a monitor with more than 60hz / 58hz no vsync against tearing?

 

http://www.moddb.com/engines/dunia <--- old crytek cryengine, 2008.

 

It's why new Farcry games are 60 FPS render capped, I believe.

 

Engine 1 or 2 can't cope.

2 is mostly DX11 and graphics updates. Core remains.

 

TDM is rehashed 2004 iDtech..?

 

Farcry sucked after 2/3 anyway... 2 remains the best.

 

Id5 is capped at 60...

Maybe try this: https://community.pcgamingwiki.com/files/file/849-id5-tweaker/

 

(but check out "known issues" re: physics and scripting)

Edited by teh_saccade
Link to post
Share on other sites

With Dunia [2] engine - over 60FPS render will cause physics and scripting bugs.

The same is true for the Source engine which is based on the Quake engine, so it might be relevant for the Doom3 engine too. If your FPS are higher that 90 you will regularily get stuck in opening doors and if you go even higher you can't push some physical items anymore...

Link to post
Share on other sites

Source Engine uses havok physics so unfortunately is not relevant for idtech 4, this last one uses a custom made physics engine, this is also pretty much the standard way in the industry to conciliate physics time with the rest of the game time and prevent inconsistencies, unfortunately the faster the game runs the less reliable the physics calculations become, one way that i think could help is to make the physics always run to max 60fps, even if the game runs at more, this will have their own problems tho, like objects moving slower than expected compared to the rest of the game, afaik is not a easy problem to solve.

 

btw one of the most prevalent problems of most old games in modern systems, is not because of windows compatibility problems, or because we have modern GPU's with modern API's, many are almost CPU based anyway, the fact for most of them is, they run faster then they should, one recent example i add was Soul Reaver 2, on my new windows 10 PC was only able to play the game after, one forcing it to run on one CPU core, two finding a way to make it run at less than 60fps, used reshade to force post process effects and make it run slower (and prettier ;P ), before this, some controls didn't work, i couldn't change worlds, would become stuck in one place, etc, pretty much unplayable.

Edited by HMart
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...