Jump to content
The Dark Mod Forums
Sign in to follow this  
Springheel

Texture not working for some

Recommended Posts

During beta-testing, I had one tester report a black texture, but everyone else see is properly. The texture has an alpha channel, but that is the only unusual thing about it I can think of.

 

Anyone able to test this, just add the entity movers/doors/atdm:mover_door_industrial01_grate to your map and see how it appears to you. Below is how it looks to me, and how it looks to Xarg:

post-9-0-37465800-1493225767_thumb.jpg

post-9-0-90055200-1493225772_thumb.jpg

Share this post


Link to post
Share on other sites

What are his video settings vs yours Spring?

 

His settings are:

-ambient rendering simple

-interaction shader default

-post processing disabled

-bloom is grayed out

-object details (lod) lowest

 

I tried with the same settings and it still looked correct to me.

Share this post


Link to post
Share on other sites

Xarg ran the updater again and everything says it is up to date, but when he does a condump, that one texture is listed as missing.

 

WARNING:Couldn't load image: textures/darkmod/metal/grate/iron_grate_square_variants_seethru

 

I don't see anything else out of the ordinary in his condump.

 

 

 

 

Found 0 new mission packages.
Found 112 mods in the FM folder.
DisplayBriefingPage: briefingData is maps/speedbuild7/mission_briefing
DisplayBriefingPage: xdata found.
DisplayBriefingPage: numPages is 2
DisplayBriefingPage: current page is 1
Objective 1: Parsing success and failure logic
Objective 2: Parsing success and failure logic
Objective 3: Parsing success and failure logic
Objective 4: Parsing success and failure logic
Objective 5: Parsing success and failure logic
Objective 6: Parsing success and failure logic
Objective 7: Parsing success and failure logic
Applied 0 objective conditions.
reloading guis/mainmenu.gui.
reloading guis/restart.gui.
reloading guis/msg.gui.
Widescreenmode was set to: 7 (1920x1080)
--------- Map Initialization ---------
Map: speedbuild7
glprogs/ambientEnvironment.vfp
glprogs/ambientEnvironment.vfp
----------- Game Map Init ------------
collision data:
50 models
5236 vertices (122 KB)
8599 edges (302 KB)
3423 polygons (238 KB)
618 brushes (84 KB)
4048 nodes (110 KB)
9497 polygon refs (74 KB)
3715 brush refs (29 KB)
2454 internal edges
68 sharp edges
0 contained polygons removed
0 polygons merged
962 KB total memory used
18 msec to load collision data.
map bounds are (2923.0, 2014.0, 550.0)
max clip sector is (91.3, 125.9, 68.8)
560 bytes passage memory used to build PVS
0 msec to calculate PVS
24 areas
50 portals
5 areas visible on average
96 bytes PVS data
[Load AAS]
loading maps/speedbuild7.aas48
[Load AAS]
loading maps/speedbuild7.aas96
[Load AAS]
loading maps/speedbuild7.aas32
done.
[Load AAS]
loading maps/speedbuild7.aas100
[Load AAS]
loading maps/speedbuild7.aas_rat
[Load AAS]
loading maps/speedbuild7.aas_elemental
ConversationManager: Found 0 valid conversations.
Entering tdm_main()
Exiting tdm_main()
Spawning entities
removed 2 degenerate triangles
removed 3 degenerate triangles
removed 32 degenerate triangles
removed 13 degenerate triangles
removed 2 degenerate triangles
removed 2 degenerate triangles
WARNING:Image name "-" is too short
removed 72 degenerate triangles
removed 72 degenerate triangles
removed 84 degenerate triangles
removed 90 degenerate triangles
removed 90 degenerate triangles
removed 36 degenerate triangles
removed 72 degenerate triangles
removed 72 degenerate triangles
removed 6 degenerate triangles
removed 168 degenerate triangles
removed 2 degenerate triangles
removed 2 degenerate triangles
removed 47 degenerate triangles
removed 16 degenerate triangles
glprogs/heatHazeWithMaskAndDepth.vfp
glprogs/heatHazeWithMaskAndDepth.vfp
removed 16 degenerate triangles
removed 16 degenerate triangles
removed 12 degenerate triangles
glprogs/heatHazeWithDepth.vfp
glprogs/heatHazeWithDepth.vfp
removed 8 degenerate triangles
... 1274 entities spawned, 18 inhibited

==== Processing events ====
Objective 1: Parsing success and failure logic
Objective 2: Parsing success and failure logic
Objective 3: Parsing success and failure logic
Objective 4: Parsing success and failure logic
Objective 5: Parsing success and failure logic
Objective 6: Parsing success and failure logic
Objective 7: Parsing success and failure logic
Applied 0 objective conditions.
[aas32]: Assigned 0 multistatemover positions to AAS areas and ignored 0.
WARNING:Couldn't load gui: 'guis/scoreboard.gui'
WARNING:Couldn't load gui: 'guis/spectate.gui'
WARNING:Couldn't load gui: 'guis/chat.gui'
WARNING:Couldn't load gui: 'guis/mpmsgmode.gui'
--------------------------------------
SpawnPlayer: 0
WARNING:Couldn't load sound 'player_sounds_doublevision.wav' using default
WARNING:Couldn't load sound 'player_sounds_skipcinematic.wav' using default
WARNING:Couldn't load sound 'player_sounds_guienter.wav' using default
WARNING:Couldn't load sound 'player_sounds_guiexit.wav' using default
WARNING:Couldn't load sound 'player_sounds_hitarmor.wav' using default
WARNING:Couldn't load sound 'player_sounds_hitflesh.wav' using default
WARNING:Couldn't load sound 'player_sounds_teleportexit.wav' using default
WARNING:Couldn't load sound 'player_sounds_teleportstart.wav' using default
removed 16 degenerate triangles
removed 16 degenerate triangles
removed 48 degenerate triangles
removed 8 degenerate triangles
removed 48 degenerate triangles
removed 8 degenerate triangles
glprogs/cookMath_pass1.vfp
glprogs/cookMath_pass1.vfp
glprogs/cookMath_pass2.vfp
glprogs/cookMath_pass2.vfp
glprogs/brightPass_opt.vfp
glprogs/brightPass_opt.vfp
glprogs/blurx.vfp
glprogs/blurx.vfp
glprogs/blury.vfp
glprogs/blury.vfp
glprogs/finalScenePass_opt.vfp
glprogs/finalScenePass_opt.vfp
----- idRenderModelManagerLocal::EndLevelLoad -----
0 models purged from previous level, 393 models kept.
---------------------------------------------------
----- idImageManager::EndLevelLoad -----
WARNING:Couldn't load image: -
WARNING:Couldn't load image: extinguishable/buoy_light01
WARNING:Couldn't load image: alembic_grey
WARNING:Couldn't load image: tdm_tongue
WARNING:Couldn't load image: arms_legs
WARNING:Couldn't load image: rope_belt
WARNING:Couldn't load image: belt
WARNING:Couldn't load image: layer3s
WARNING:Couldn't load image: sleeve_frill
WARNING:Couldn't load image: sleeve
WARNING:Couldn't load image: textures/darkmod/metal/grate/iron_grate_square_var
iants_seethru
WARNING:Couldn't load image: _bloomimage
WARNING:Couldn't load image: _cookedmath
0 purged from previous
195 kept from previous
780 new loaded
all images loaded in 6.0 seconds
----------------------------------------
----------------------------------------
----- idSoundCache::EndLevelLoad -----
142727k referenced
6338k purged
----------------------------------------
sound: missing efxs/speedbuild7.efx
-----------------------------------
21815 msec to load speedbuild7
interactionTable generated of size: 134217728 bytes
------------- Warnings ---------------
during speedbuild7...
WARNING:Couldn't load gui: 'guis/chat.gui'
WARNING:Couldn't load gui: 'guis/mpmsgmode.gui'
WARNING:Couldn't load gui: 'guis/scoreboard.gui'
WARNING:Couldn't load gui: 'guis/spectate.gui'
WARNING:Couldn't load image: -
WARNING:Couldn't load image: _bloomimage
WARNING:Couldn't load image: _cookedmath
WARNING:Couldn't load image: alembic_grey
WARNING:Couldn't load image: arms_legs
WARNING:Couldn't load image: belt
WARNING:Couldn't load image: extinguishable/buoy_light01
WARNING:Couldn't load image: layer3s
WARNING:Couldn't load image: rope_belt
WARNING:Couldn't load image: sleeve
WARNING:Couldn't load image: sleeve_frill
WARNING:Couldn't load image: tdm_tongue
WARNING:Couldn't load image: textures/darkmod/metal/grate/iron_grate_square_var
iants_seethru
WARNING:Couldn't load sound 'player_sounds_doublevision.wav' using default
WARNING:Couldn't load sound 'player_sounds_guienter.wav' using default
WARNING:Couldn't load sound 'player_sounds_guiexit.wav' using default
WARNING:Couldn't load sound 'player_sounds_hitarmor.wav' using default
WARNING:Couldn't load sound 'player_sounds_hitflesh.wav' using default
WARNING:Couldn't load sound 'player_sounds_skipcinematic.wav' using default
WARNING:Couldn't load sound 'player_sounds_teleportexit.wav' using default
WARNING:Couldn't load sound 'player_sounds_teleportstart.wav' using default
WARNING:Image name "-" is too short
26 warnings
Bloom Kernel size is set to: Small
Using default interaction.vfp
Forcing an update on cooked math data.
Cooking math data please wait...
Cooking complete.
WARNING:FrobMover handle_curved1 will not move, translation and rotation not se
t.
WARNING:FrobMover func_static_521 will not move, translation and rotation not s
et.
WARNING:FrobMover func_static_522 will not move, translation and rotation not s
et.
]condump hours2.txt
Dumped console text to hours2.txt.

 

 

 

Even weirder, he must have the actual texture files, because otherwise he wouldn't see the other non-seethru grates properly, and he does.

:huh:

Share this post


Link to post
Share on other sites

Strange. Is that a core asset?

Maybe delete the pk4 where it lives and let tdm_update grab it again?

 

Any add-on \ texture pack pk4's (or folders) in the base folder?

Maybe Xarg has leftover campaign assets (etc)?


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

-ambient rendering simple

-interaction shader default

Just a hunch, but has he tried with those two settings set to highest..? I say this because some decals are borked on the lowest of the above settings.

Share this post


Link to post
Share on other sites

The condump shows that the material shader is missing.

Share this post


Link to post
Share on other sites

The behaviour 'could not load image ...' looks like the bug about weird timestamps nbohr1more was pointing to.

Is Xarg running on Linux? The original fix probably only covered Windows.

There was a later discussion on that issue on Linux here:
http://forums.thedarkmod.com/topic/18582-bogus-timestamps-in-tdm-update-files-cause-tdm-crashes-under-linux/?do=findComment&comment=399637

Maybe there are still some cases where the updater could not fix it?

 

Seeing the timestamps in the pk4 of the files involved (texture/shader) should shed some light on this and maybe help to fix this issue for good.

(any unusual date far in the past like 1980 or far in the future?)

Otherwise, I think deleting tdm_textures_metal01.pk4 and then updating should help.

(Keeping a backup for reference would be nice, in case someone wants to look into why the issue would still be there!)

Share this post


Link to post
Share on other sites

This isn't a linux issue. I've given him the pk4 where the required material file is, so I'll wait to hear back.

Share this post


Link to post
Share on other sites

U'm does he have any unpacked asset folders in the core directory that could be interfering with the ones contained in the PK4? That's honestly the only time I've seen that kind of thing happen.


You need a model? Epi does you a model.



Toss me a PM I promise I don't bite.



Share this post


Link to post
Share on other sites

Does Xarg's TDM Updater show version 0.66 ?

If not, he might have told it to 'not update itself' in the advanced options.

Since a fix got added in 0.66 he should make sure to have the latest one and retry to update TDM.

Share this post


Link to post
Share on other sites

U'm does he have any unpacked asset folders in the core directory that could be interfering with the ones contained in the PK4?

Good point, a rogue material def will do this also.

Share this post


Link to post
Share on other sites

Just a hunch, but has he tried with those two settings set to highest..? I say this because some decals are borked on the lowest of the above settings.

 

Have set them to max again (where they should have been), no change in behaviour.

 

The behaviour 'could not load image ...' looks like the bug about weird timestamps nbohr1more was pointing to.

Is Xarg running on Linux? The original fix probably only covered Windows.

There was a later discussion on that issue on Linux here:

http://forums.thedarkmod.com/topic/18582-bogus-timestamps-in-tdm-update-files-cause-tdm-crashes-under-linux/?do=findComment&comment=399637

Maybe there are still some cases where the updater could not fix it?

 

Seeing the timestamps in the pk4 of the files involved (texture/shader) should shed some light on this and maybe help to fix this issue for good.

(any unusual date far in the past like 1980 or far in the future?)

Otherwise, I think deleting tdm_textures_metal01.pk4 and then updating should help.

(Keeping a backup for reference would be nice, in case someone wants to look into why the issue would still be there!)

 

Running Win7 SP1, not linux

 

U'm does he have any unpacked asset folders in the core directory that could be interfering with the ones contained in the PK4? That's honestly the only time I've seen that kind of thing happen.

 

A few material definitions, but no fully unpacked pk4's

 

Does Xarg's TDM Updater show version 0.66 ?

If not, he might have told it to 'not update itself' in the advanced options.

Since a fix got added in 0.66 he should make sure to have the latest one and retry to update TDM.

 

Yes, 0.66

 


Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Share this post


Link to post
Share on other sites

Ok seem to have fixed it, I deleted the .mtr downloaded from 2014 and it fixed it.


Intel Sandy Bridge i7 2600K @ 3.4ghz stock clocks
8gb Kingston 1600mhz CL8 XMP RAM stock frequency
Sapphire Radeon HD7870 2GB FLeX GHz Edition @ stock @ 1920x1080

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...