Jump to content
The Dark Mod Forums

Beta Testing 2.06


grayman
 Share

Recommended Posts

leather_chair_001 is defined in tdm_epi_shader.mtr, the leather chair was in 2.05 and I've used it in my WIPs. I don't know why AC1 might have a problem.

 

I've now done an update to the second release version from 2.05 rather than updating in my beta test folder, saw no problems. I can also confirm the checkmarks show, albeit they clip a bit into the black stroke of the selection.

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

Alright, I don't get it then. It's all like you said, but it's missing the material anyway (the model is black in-game, naturally). If I add the 2.05 .mtr to the fm folder it works again. What am I not seeing?

Fresh 2.06 install, freshly downloaded Accountant1 btw.

 

edit: ok, the reason seems to be that Acc1 has its own tdm_epi_shader.mtr (w/o leather_chair_001) that takes priority over TDM's. So it's not really an issue with 2.06.

Edited by chedap
Link to comment
Share on other sites

Finally could get around to betatesting some.

I understand the code is closed and only crashes really count, but I'll report this for the record.

 

I'm on intel graphics circa 2016, played both the 32 and 64 bit versions. Long story short, soft shadows was working for my computer on a test release about two months ago or so (actually I forget how long ago now; could have been earlier), but I don't see them now. The shadows just completely disappear using any level of softshadow although, interestingly, the visual artifacts for them are still there, the black dots on things like readables and decals, and the performance still takes the hit. And to be clear, I could see them in that earlier test build, so something is different, whether the build or my config... (I wasn't really following the discussion to know what that might be.)

 

That's the only real major finding after playing through a few FMs.

That and I confirm the sluggishness of the cursor arrow on the main menu.

 

Not too big a deal. Because of the performance slow down, I would be largely playing without soft shadows anyway. It's just nice to turn them on and take a pretty screenshot occasionally.

What do you see when you turn out the light? I can't tell you but I know that it's mine.

Link to comment
Share on other sites

Yes also on restart, they're still missing.

 

Try disabling the anti-halo patch:

 

1) Extract your tdm_base01.pk4

2) Edit the glprogs/interaction.fs file to: #define ENABLE_ANTI_HALO_PATCH 0

3) Repackage the contents of the tdm_base01 folder from step 1 as tdm_bask01.pk4

4) Overwrite the tdm_base01.pk4 in your darkmod directory

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

I've been getting consistent crashing when dmapping in 2.06, 32/64, experimental features on or off. No problem when testmapping.

 

Let's try this:

 

https://www.dropbox.com/s/8v548ep2jkc0lp1/206beta_active_contacts.zip?dl=0

 

If that doesn't work, try setting tdm_lg_weak 1.

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Neither have worked. I should also mention this is straight out of the menu, I don't need to be in-game. Also tested switching EFX, GLSL and FBO on/off, no difference.

 

e: short of any other ideas, whoever is willing to investigate can PM me within the next couple of hours and I'll give them the map to test.

Edited by Spooks

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

No dice.

 

Edit: I've been able to dmap in 32bit now. It's why I was hesitant to report this yesterday, it's very inconsistent and I can't figure out what's causing it. Hold on till I run some more testing.

Edited by Spooks

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

Hmm.

 

One last try:

 

https://www.dropbox.com/s/6g4wg1eaglgtzje/206beta_active_contacts.zip?dl=0

 

(uploaded to the same link)

 

OK, it's the very last thing I expected, which is ReShade. Short story: it's an external app, so warning sirens off, it's not a TDM problem.

 

Long story: this is very weird, because this bug only affects x64 versions of TDM + ReShade. 32bit+ReShade is not affected. Not as embarrassing a mistake to make, I think, since this is an extremely fringe case to encounter. I don't know what it is that causes this, perhaps it's because ReShade only uses an Opengl32.dll, but not a 64, but it still works, it only crashes on dmap... Oh well.

 

e: it seems updating the injector fixes the issue for x64 as well, so sorry for raising a ruckus -_- For the record, I have, like, half a dozen bugs like this in TDM/DR that I hold off reporting because the reproducibility is very inconsistent; I just got over-eager since I didn't want the final release to ship with a potentially big crash like that.

Edited by Spooks
  • Like 3

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

I have an incredibly strange, easy to reproduce and specific bug in Volta and the Stone.

Not where I can record it, but can later.

 

When you are in the tower, next to the fire arrows mantle onto the plate holding them.

You'll see a bright white shadow rendering in the window opposite the door, mimicking the player's movements.

 

Edit: It just occurred to me that I haven't updated in a while, let me verify this is still relevant.

 

Edit edit: It is not still relevant.

As of updating this is no longer an issue.

Feel free to delete this post.

Edited by V-Man339

I like to record difficult stealth games, and right now you wonderful people are the only ones delivering on that front.

Click here for the crappy channel where that happens.

Link to comment
Share on other sites

When I just tried to update to 2.06 the updater itself got stuck in an neverending loop until I disabled this. Any fixes for that?

Yes, go into options and turn off the installer updating self. Unless you're talking about a fix so you don't have to do that. It happened to me too, so I don't know.

  • Like 1

What do you see when you turn out the light? I can't tell you but I know that it's mine.

Link to comment
Share on other sites

Just updated with the tdm_updater. The update worked fine. I started the Training Mission then, and activated soft shadows, and the multicore option, but then realized that the soft shadows have quite a severe performance impact. I tried to lower some settings then, anti-aliasing level and anisotropy, which led to a white screen, when i went back in the mission. I restarted TDM then, and reloaded the quicksave i made with the white screen, but, the white screen didn't show up again. Instead, i had a weird bug when i took a dive:

 

training_mission_2018qmrtt.jpg

 

If it is not apparent: The screen somehow got divided in 4 parts, when i went under water. When i emerged again, the picture was fine again, but, every time i went under water, it divided the screen into 4 parts again, with one part in the lower left showing the actual game picture, while the others seemed to show fragments of the screen before i went under water.

 

Also, the multicore option didn't seem to have an effect here, or, at least not apparently. I didn't think soft shadows were so CPU taxing, a bit disappointed that it really cuts into the framerate here. I don't have the newest computer, i posted the specs here: http://forums.thedarkmod.com/topic/9970-post-your-system-configuration-here/?p=342668

 

Still thought it'd be good enough to run with soft shadows.

Link to comment
Share on other sites

I had it on 8x first, but, i lowered it to 4x.

No.

 

In game AA is really "resolution scaling" use FXAA in your Nvidia driver.

 

See here:

 

http://wiki.thedarkmod.com/index.php?title=What%27s_new_in_TDM_2.06#Experimental_Soft_Shadows.2C_Anti-Aliasing.2C_FBO_and_You.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Yes, go into options and turn off the installer updating self. Unless you're talking about a fix so you don't have to do that. It happened to me too, so I don't know.

I already did that and was talking about a real fix ;).

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


  • Recent Status Updates

    • jaxa

      Embracer Group is Buying Square Enix Montréal, Eidos, and Crystal Dynamics for “Only” 300 Million USD: https://wccftech.com/embracer-group-square-enix-montreal-eidos-crystal-dynamics/
      · 1 reply
    • duzenko

      Do we want fur in TDM? Like https://duzenko.github.io/webgl/
      · 6 replies
    • Epifire

      Sometimes life throws a curveball - other times it straight up tries to take you outta the game. Been one thing after another lately but I ain't goin without a fight!
      · 2 replies
    • duzenko

      My Uber rating (as a passenger) is 4.71. Is there still hope or should I just kill myself? What's yours?
      · 3 replies
    • kano

      Did I mention how absolutely grateful I am that TDM didn't get (and can never be) assimilated by a huge company like Microsoft, as is what happened to Minecraft?
      · 3 replies
×
×
  • Create New...