Jump to content
The Dark Mod Forums

Requiem Question


Recommended Posts

At the beginning, I'm only getting the snake lockpick.It is on the table in the basement, but the Triangle lockpick is not and I can't find it anywhere. I tried a video walkthrough and it had BOTH lockpicks on the table. I uninstalled / reinstalled the mission but that didn't help. Without the Triangle lockpick, I can't progress :(

Link to comment
Share on other sites

Tap the "P" key?

Tried that


But I finally got the Triangle Lockpick even though I couldn't see it. I frantically right clicked all over the table until it suddenly showed up in my inventory. Could this "invisibility" have something to do with the version of Dark Mod (2.06/64) and the version of the mission (ver 1) ?

Edited by CountMorillonite
Link to comment
Share on other sites

Does that mean I can look forward to more cases of Invisible Lock Picks ? Has this issue arisen elsewhere ? I've only just now returned to the game and this is my first time playing Dark Mod ver 2.06


First time we've heard about it, and 2.06 was beta tested for 6 months

Just checked latest SVN version, they're missing there too.

I always assumed I'd taste like boot leather.


Link to comment
Share on other sites

Yipes...there's no special scripts or anything associated with those lockpicks. Is this just specific to Requiem?

This is my first mission playing with DM ver 2.06. I Think the mission ver is 1. I specifically scoured the floor for the lockpick thinking it may have fallen to the floor and my brightness level was such that it wasn't super dark. In any event, nothing "lit up" designating a frobbable object. So the word "invisible" seemed appropriate I'm still playing this mission and haven't had the opportunity to see if other missions have similar issues.


It would be very easy for others to confirm whether the issue is with the mission or something to do with my setup specifically. It's right at the beginning where you climb down to the basement to retrieve your stuff. The table is supposed to contain 2 lockpicks among other items. For me the Triangle Lockpick wasn't there. Eventually, I picked it up by constantly clicking on the table, under the table and the immediate surroundings, until it registered. Never did see it.

Link to comment
Share on other sites

The lockpick could have fallen inside the table, then lying on the lower face of the table's top. As picks are rather thin, it would be fully contained in the table's top while still beeing easily frobable.

This would be a new bug class or at least a change in the old behaviour though. Stuff falling through the first face of an object/brush also fell through the back-facing (for the falling thing) face down to the floor before. Maybe, the back-facing face now counts as a barrier. But i see stuff just sink a bit lower on moving it or bumping into it in missions from time to time (not sure if it started before or after 2.06 though).


You would be able to see the pick inside the table with enabled wireframe mode (type "r_showtris 3" into the console).

Edited by Abusimplea
Link to comment
Share on other sites

They're inside the table looks like:

I don't see the wires of the lower face of the table top in the shot (looks like all backfacing faces' wires are hidden). The pick could be the thing right below the scroll. In that case it looks like it is floating inside the table top instead of lying on the lower face of it. Like if it had been displaced somehow. Could it be the "math is sometimes absurdly bad when far away from the origin" bug that led to tons of player sticking issues in Cauldron of the Gods?

Link to comment
Share on other sites

Good to know, I'll make sure the player gets them rather than having to find them.

I have an eclectic YouTube channel making videos on a variety of games. Come and have look here:



Dark Mod Missions: Briarwood Manor - available here or in game




Link to comment
Share on other sites

Hey NeonStyle,


Not sure if you're talking about your own map or making a change to Requiem, but if you give the players the lockpicks at the start of Requiem it will break the flow of the game.


TDM team: I do not have DarkRadiant on my current computer - should I reach out to a team member to officially fix the map? I would think disabling physics on the picks and moving them up slightly is all that would need to be done.

  • Like 1

But you should walk having internal dignity. Be a wonderful person who can dance pleasantly to the rhythm of the universe.

-Sun Myung Moon


My work blog: gfleisher.blogspot.com

Link to comment
Share on other sites

I looked at the map file already, the picks are a bit above the table already, somehow they end up in the middle of the table at map start.

Is it just me or does dmap take ages to run on requiem for you too?


Here is how the picks are fixed:

The table itself is nonsolid. But there is a solid wood brush wich ends slightly below its top, so the picks can hide between the top face of that solid wood and the top face of the table's top.

Just move that solid wood up some fractions of a unit until it is flush with the table's top and move every item, that now intersects it, up some fractions too. Save and dmap.


Still wondering, why it did not occur last time i played the mission, wich was in 2015 (now i have to wait another year with the replay to forget what i saw in DR)...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

  • Create New...