Jump to content
The Dark Mod Forums

No fullscreen on Fedora 31 w/ AMD video


Recommended Posts

I haven't run tdm for some time so I can't say for certain that's it's the video card change but I upgraded from a a Nvidia 1050 to a Radeon RX480 and now the game always starts in windowed mode.

The only REAL difference is the Nvidia drivers forced running in X while the open source Radeon drivers happily run in Wayland. 

What can I do?

Link to post
Share on other sites

I guess current code integrates only with X system. Most likely there is no code to cooperate with Wayland.

I'm not familiar with this side of Linux, but is it possible to somehow force using X system just like NVIDIA drivers did?

Link to post
Share on other sites
On 3/21/2020 at 12:42 AM, hobbes1069 said:

I haven't run tdm for some time so I can't say for certain that's it's the video card change but I upgraded from a a Nvidia 1050 to a Radeon RX480 and now the game always starts in windowed mode.

The only REAL difference is the Nvidia drivers forced running in X while the open source Radeon drivers happily run in Wayland. 

What can I do?

Is there something similar to borderless gaming app but for Linux? In that way you can workround the problem. 

Edited by HMart
Link to post
Share on other sites
  • 1 month later...
On 3/20/2020 at 6:42 PM, hobbes1069 said:

I haven't run tdm for some time so I can't say for certain that's it's the video card change but I upgraded from a a Nvidia 1050 to a Radeon RX480 and now the game always starts in windowed mode.

The only REAL difference is the Nvidia drivers forced running in X while the open source Radeon drivers happily run in Wayland. 

What can I do?

I've run TDM successfully in fullscreen under Fedora 30, 31, and now 32 with an AMD Radeon RX 580 using X11.

I suspect TDM doesn't totally work under Wayland; personally I'm using X because of some other programs that got very angry when running under Wayland, so I had to switch back to X to get things working. It should be easy to toggle over to using X; you can just switch it on the login page with the little gear icon.

Do you happen to have a multi-monitor setup?  For me, I had to go into the system display settings and disable my second monitor when playing TDM fullscreen. Otherwise it goes into a weird windowed mode. Doesn't necessarily sound like the case here, but just in case that tidbit helps someone else...

 

Edited by krrg
Link to post
Share on other sites

Here was my workaround:

 

Basically, set it up as a windowed app sized to your native resolution and then tell your window manager to make it borderless.  I would expect this to work on Wayland as well, unless there's another issue preventing it from running even in windowed mode there.

I started working on modernizing the fullscreen code but have been busy with real work lately.  Since we have a workaround I wasn't going to push for a change in 2.08 and instead was planning to take the time to make sure the reworked code works out-of-the-box in both Wayland and X.

 

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...