Jump to content
The Dark Mod Forums
Sign in to follow this  
Dracula

Version 2.08 blackscreen

Recommended Posts

Please download this archive.
It contains single directory with name starting with "apitrace".
Unpack this directory and rename it to C:\apitrace  (path C:\apitrace\bin\apitrace.exe should point to executable).

Then download the attached script apitrace_record.cmd into the directory where TDM is installed.

Run the script. It should start TDM. When TDM window appears, wait 5 seconds, then close it (e.g. with Alt+F4).

Now find file name myw64.trace in the same directory, archive it and share it somewhere (google drive or something similar).

 

apitrace_record.cmd

Share this post


Link to post
Share on other sites

okay, I've downloaded apitrace and also the script. while running the script tdm opens and after some seconds it shut's down on it's on. is that normal?

the file myw64.trace has been added in the tdm folder and I've archived it in another folder.

Share this post


Link to post
Share on other sites
1 hour ago, Dracula said:

okay, I've downloaded apitrace and also the script. while running the script tdm opens and after some seconds it shut's down on it's on. is that normal?

I think not.
It stays forever without script, and I think it should do the same with it.

Try this one, maybe it would be better.

apitrace_record.cmd

Share this post


Link to post
Share on other sites

I've tried the other script, it worked. I don't know, why the other didn't.

should I sent you the myw64.trace file here?

Edited by Dracula

Share this post


Link to post
Share on other sites
9 hours ago, Dracula said:

should I sent you the myw64.trace file here?

Yes, zip it, put it somewhere, and post a link here.

Share this post


Link to post
Share on other sites
4 hours ago, Dracula said:

okay that's the file

This one is almost empty, it did not even get to the main menu.
Was it the run which quickly closed by itself?

Could you please try the way when TDM did not close automatically.
The file in question should be about 20-40 MB in size. Everything under 1 MB is not going to work.

Share this post


Link to post
Share on other sites

Here is the riddle for fellow coders ( @duzenko @cabalistic).

According to the log posted here, the driver does not support GL_KHR_debug.

I have attached the end of the trace.
According to it, execution has got to the end of OpenGL initialization, queried all features, then started executing debug commands.
I am absolutely sure that the call to GLimp_CheckRequiredFeatures has just ended, and the following code has executed:

    if( glConfig.debugGroupsAvailable ) {
        qglDebugMessageCallback( R_OpenGLDebugMessageCallback, nullptr );
        if( r_glDebugOutput.GetBool() ) {
            qglEnable( GL_DEBUG_OUTPUT );
        } else {
            qglDisable( GL_DEBUG_OUTPUT );
        }
        if( r_glDebugOutput.GetInteger() == 2) {
            qglEnable( GL_DEBUG_OUTPUT_SYNCHRONOUS );
        } else {
            qglDisable( GL_DEBUG_OUTPUT_SYNCHRONOUS );
        }
    }

How the hell is it possible?
Extension is not available, but the if is executed?! 🥴

 

apitrace_khr_debug.png

Share this post


Link to post
Share on other sites

Uuhh... okay yeah, that is puzzling. I would suggest replacing the if condition with GLAD_GL_KHR_DEBUG, although if you are sure that CheckRequiredFeatures already finished prior to the call, it really shouldn't make any difference.

Even more confusing: if the extension isn't available, shouldn't that call just crash hard due to a null function pointer, or is GLAD redirecting missing functions to a noop?

Share this post


Link to post
Share on other sites
1 hour ago, cabalistic said:

Even more confusing: if the extension isn't available, shouldn't that call just crash hard due to a null function pointer, or is GLAD redirecting missing functions to a noop?

I think when debug cvars are enabled, then TDM actually crashes here. Or stops working in some other way.
I might be that debug functions are sometimes supported (maybe drivers update since then).
Maybe it is recording issue.

Anyway, this debugging puzzle is not the main problem.

@Dracula: When you record a better trace, please make a condump too and post console log here again.

Share this post


Link to post
Share on other sites
20 hours ago, stgatilov said:

Here is the riddle for fellow coders ( @duzenko @cabalistic).

According to the log posted here, the driver does not support GL_KHR_debug.

I have attached the end of the trace.
According to it, execution has got to the end of OpenGL initialization, queried all features, then started executing debug commands.
I am absolutely sure that the call to GLimp_CheckRequiredFeatures has just ended, and the following code has executed:


    if( glConfig.debugGroupsAvailable ) {
        qglDebugMessageCallback( R_OpenGLDebugMessageCallback, nullptr );
        if( r_glDebugOutput.GetBool() ) {
            qglEnable( GL_DEBUG_OUTPUT );
        } else {
            qglDisable( GL_DEBUG_OUTPUT );
        }
        if( r_glDebugOutput.GetInteger() == 2) {
            qglEnable( GL_DEBUG_OUTPUT_SYNCHRONOUS );
        } else {
            qglDisable( GL_DEBUG_OUTPUT_SYNCHRONOUS );
        }
    }

How the hell is it possible?
Extension is not available, but the if is executed?! 🥴

 

apitrace_khr_debug.png

Not much to suggest

  • the console log and the GL trace are from different runs (x86\x64, different drivers, different game folders, core/compat profile)
  • memory corruption
  • api tracing somehow affects the driver to return different states

Share this post


Link to post
Share on other sites
On 7/5/2020 at 8:07 PM, stgatilov said:

This one is almost empty, it did not even get to the main menu.
Was it the run which quickly closed by itself?

Could you please try the way when TDM did not close automatically.
The file in question should be about 20-40 MB in size. Everything under 1 MB is not going to work.

@Dracula, did you manage to get complete trace?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...