Jump to content
The Dark Mod Forums

TDM 2.08: no sound when starting thedarkmod.x64 under linux


Recommended Posts

Hi there,

congratulations to the team for releasing version 2.08. Having watched this mod from the very beginning I am really amazed about the commitment this community still shows after all these years!

I realized that there is now a 64 bit version of the game.  Unfortunately when I try to run thedarkmod.x64 in my installation of Linux Mint 19.3 I get no sound. Any idea what might be the reason for this? The 32 bit version of the game works without a problem.

When starting the game from a terminal I get some warning about  "Couldn't load sound 'sound' using default".

Here is the (slightly shortened) Terminal output:

Spoiler

TDM 2.08/64 #8771 (1435:8771) linux-x86_64 Jun 17 2020 12:09:59
found interface lo - loopback
found interface enp4s0 - 192.168.178.39/255.255.255.0
Found Generic CPU, features: SSE SSE2 SSE3
TDM using SSE3 for SIMD processing.
------ Initializing File System ------

    [...]

File System Initialized.
--------------------------------------
Couldn't open journal files
/proc/cpuinfo CPU processors: 6
/proc/cpuinfo CPU logical cores: 12
----- Initializing Decls -----
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
WARNING:file skins/tdm_epi_skins.skin, line 86: skin 'steam_engine_003_off' previously defined at skins/steam_engine_003.skin:1
WARNING:file skins/tdm_epi_skins.skin, line 97: skin 'steam_engine_003_on' previously defined at skins/steam_engine_003.skin:18
WARNING:file sound/tdm_ai_maiden.sndshd, line 1709: sound 'tdm_ai_maiden_request_help' previously defined at sound/tdm_ai_maiden.sndshd:1561
------------------------------
/proc/cpuinfo CPU frequency: 2861.94 MHz
I18N: SetLanguage: 'english'.
I18N: Found no character remapping for english.
I18N: 1274 strings read from strings/english.lang
I18N: 'strings/fm/english.lang' not found.
Couldn't exec editor.cfg - file does not exist.
execing default.cfg
execing Darkmod.cfg
Reloading normal maps. Please wait...
Reload complete.
execing DarkmodKeybinds.cfg
Couldn't exec autoexec.cfg - file does not exist.
I18N: SetLanguage: 'german'.
I18N: Found no character remapping for german.
I18N: 1273 strings read from strings/german.lang
I18N: 'strings/fm/german.lang' not found.
I18NLocal: 'strings/fm/english.lang' not found, skipping it.
----- Initializing OpenAL -----
Setup OpenAL device and context
OpenAL: found device 'ALSA Default'
OpenAL: found device 'HDA ATI HDMI, HDMI 0 (CARD=HDMI,DEV=3)'
OpenAL: found device 'HDA ATI HDMI, HDMI 1 (CARD=HDMI,DEV=7)'
OpenAL: found device 'HDA ATI HDMI, HDMI 2 (CARD=HDMI,DEV=8)'
OpenAL: found device 'HDA ATI HDMI, HDMI 3 (CARD=HDMI,DEV=9)'
OpenAL: found device 'HDA ATI HDMI, HDMI 4 (CARD=HDMI,DEV=10)'
OpenAL: found device 'HDA ATI HDMI, HDMI 5 (CARD=HDMI,DEV=11)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=0)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=1)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Digital (CARD=Generic,DEV=1)'
OpenAL: using 'OpenAL Soft'
OpenAL: HRTF is available
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
OpenAL vendor: OpenAL Community
OpenAL renderer: OpenAL Soft
OpenAL version: 1.1 ALSOFT 1.19.1
OpenAL: found EFX extension
OpenAL: HRTF is enabled (reason: 1 = ALC_HRTF_ENABLED_SOFT)
OpenAL: found 256 hardware voices
----- Initializing OpenGL -----
Setup X display connection
Using screen 0 of 0x565b280 display
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
Free86-VidModeExtension Activated at 1920x1200
Chosen visual: 0x021
...creating GL context: core-fc 
...initializing QGL

------- Input Initialization -------
XKB extension: compile time 0x1:0x0, runtime 0x1:0x0: OK
XKB extension present on server ( 0x1:0x0 )
------------------------------------
OpenGL vendor: X.Org
OpenGL renderer: Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 5.4.0-40-lowlatency, LLVM 9.0.0)
OpenGL version: 4.5 (Core Profile) Mesa 19.2.8 core
Checking required OpenGL features...
v - using GL_VERSION_3_1
v - using GL_EXT_texture_compression_s3tc
v - using GLX_VERSION_1_4
Checking optional OpenGL extensions...
Max texture units: 32
Max active textures: 192
Max geometry output vertices: 256
Max geometry output components: 4095
Max vertex attribs: 16
v - using GL_EXT_texture_filter_anisotropic
    maxTextureAnisotropy: 16.000000
X - GL_ARB_vertex_program not found
v - using GL_ARB_stencil_texturing
v - using GL_EXT_depth_bounds_test
X - GL_ARB_geometry_shader4 not found
v - using GL_ARB_timer_query
v - using GL_KHR_debug
v - using GL_ARB_sync
v - using GL_ARB_draw_elements_base_vertex
v - using GL_ARB_texture_swizzle
v - using GL_ARB_buffer_storage
No ARB programs loaded
---------- R_ReloadGLSLPrograms_f -----------
Linking GLSL program cubeMap ...
Linking GLSL program bumpyEnvironment ...
Linking GLSL program depthAlpha ...
Linking GLSL program fog ...
Linking GLSL program oldStage ...
Linking GLSL program blend ...
Linking GLSL program stencilshadow ...
Linking GLSL program shadowMapA ...
Linking GLSL program shadowMapN ...
Linking GLSL program ambientInteraction ...
Linking GLSL program interactionStencil ...
Linking GLSL program interactionShadowMaps ...
Linking GLSL program interactionMultiLight ...
Linking GLSL program frob ...
Linking GLSL program soft_particle ...
Linking GLSL program tonemap ...
---------------------------------
New buffer size: 49152 kb
New buffer size: 49152 kb
Font fonts/english/stone in size 12 not found, using size 24 instead.
--------- Initializing Game ----------
The Dark Mod 2.08/64, linux-x86_64, code revision 8771
Build date: Jun 17 2020
WARNING:file def/tdm_ai_undead_zombie.def, line 1084: entityDef 'atdm:ai_undead_zombie_alt_animations' previously defined at def/tdm_ai_undead_zombie.def:292
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
Initializing event system
...841 event definitions
Initializing class hierarchy
...172 classes, 1668544 bytes for event callbacks
Initializing scripts
Compiled '�': 152.1 ms
---------- Compile stats ----------

Memory usage:
     Strings: 45, 7520 bytes
  Statements: 20325, 813000 bytes
   Functions: 1268, 169880 bytes
   Variables: 92036 bytes
    Mem used: 2098520 bytes
 Static data: 4014424 bytes
   Allocated: 5131200 bytes
 Thread size: 7912 bytes

Maximum object size: 884
Largest object type name: weapon_arrow
...6 aas types
game initialized.
--------------------------------------
Parsing material files
Found 0 new mission packages.
Found 21 mods in the FM folder.
Parsed 24 mission declarations.
-------- Initializing Session --------
Font fonts/english/mason_glow in size 12 not found, using size 48 instead.
Font fonts/english/mason_glow in size 24 not found, using size 48 instead.
Font fonts/english/mason in size 12 not found, using size 48 instead.
Font fonts/english/mason in size 24 not found, using size 48 instead.
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'QuitGameDialogAskEverytimeOption' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'AspectRatio' has value count unequal to choices count
WARNING:Unknown string id #str_07331
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'Screensize21to9' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'VertSync' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'OpenDoorsOnUnlock' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'InvPickupMessages' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'HideLightgem' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'BowAimer' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'FrobHelper' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertAttack' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertParry' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'SCGeneralBind5' has value count unequal to choices count
WARNING:Couldn't load sound 'sound' using default
session initialized
--------------------------------------
--- Common Initialization Complete ---
------------- Warnings ---------------
during The Dark Mod initialization...
WARNING:Couldn't load sound 'sound' using default
WARNING:file def/tdm_ai_undead_zombie.def, line 1084: entityDef 'atdm:ai_undead_zombie_alt_animations' previously defined at def/tdm_ai_undead_zombie.def:292
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
WARNING:file skins/tdm_epi_skins.skin, line 86: skin 'steam_engine_003_off' previously defined at skins/steam_engine_003.skin:1
WARNING:file skins/tdm_epi_skins.skin, line 97: skin 'steam_engine_003_on' previously defined at skins/steam_engine_003.skin:18
WARNING:file sound/tdm_ai_maiden.sndshd, line 1709: sound 'tdm_ai_maiden_request_help' previously defined at sound/tdm_ai_maiden.sndshd:1561
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'AspectRatio' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'BowAimer' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'FrobHelper' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'HideLightgem' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'InvPickupMessages' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertAttack' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertParry' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'OpenDoorsOnUnlock' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'QuitGameDialogAskEverytimeOption' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'SCGeneralBind5' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'Screensize21to9' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'VertSync' has value count unequal to choices count
WARNING:Unknown string id #str_07331
20 warnings
WARNING: terminal type 'xterm-256color' is unknown. terminal support may not work correctly
terminal support enabled ( use +set in_tty 0 to disabled )
pid: 25443
Async thread started
Couldn't exec autocommands.cfg - file does not exist.
Linking GLSL program cubeMap ...
Linking GLSL program bumpyEnvironment ...
Linking GLSL program depthAlpha ...
Linking GLSL program fog ...
Linking GLSL program oldStage ...
Linking GLSL program blend ...
Linking GLSL program stencilshadow ...
Linking GLSL program shadowMapA ...
Linking GLSL program shadowMapN ...
Linking GLSL program ambientInteraction ...
Linking GLSL program interactionStencil ...
Linking GLSL program interactionShadowMaps ...
Linking GLSL program interactionMultiLight ...
Linking GLSL program frob ...
Linking GLSL program soft_particle ...
Linking GLSL program tonemap ...
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
--------------------------------------
shutdown terminal support
About to exit with code 0
 

 

Link to post
Share on other sites

Yes, of course.

It seems to print the same warning...? But I can hear the menu music playing.

Spoiler

TDM 2.08/32 #8771 (1435:8771) linux-x86 Jun 17 2020 12:20:01
found interface lo - loopback
found interface enp4s0 - 192.168.178.39/255.255.255.0
Found Generic CPU, features: SSE SSE2 SSE3
TDM using SSE3 for SIMD processing.
------ Initializing File System ------

    [...]

File System Initialized.
--------------------------------------
Couldn't open journal files
/proc/cpuinfo CPU processors: 6
/proc/cpuinfo CPU logical cores: 12
----- Initializing Decls -----
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
WARNING:file skins/tdm_epi_skins.skin, line 86: skin 'steam_engine_003_off' previously defined at skins/steam_engine_003.skin:1
WARNING:file skins/tdm_epi_skins.skin, line 97: skin 'steam_engine_003_on' previously defined at skins/steam_engine_003.skin:18
WARNING:file sound/tdm_ai_maiden.sndshd, line 1709: sound 'tdm_ai_maiden_request_help' previously defined at sound/tdm_ai_maiden.sndshd:1561
------------------------------
/proc/cpuinfo CPU frequency: 3195.63 MHz
I18N: SetLanguage: 'english'.
I18N: Found no character remapping for english.
I18N: 1274 strings read from strings/english.lang
I18N: 'strings/fm/english.lang' not found.
Couldn't exec editor.cfg - file does not exist.
execing default.cfg
execing Darkmod.cfg
Reloading normal maps. Please wait...
Reload complete.
execing DarkmodKeybinds.cfg
Couldn't exec autoexec.cfg - file does not exist.
I18N: SetLanguage: 'german'.
I18N: Found no character remapping for german.
I18N: 1273 strings read from strings/german.lang
I18N: 'strings/fm/german.lang' not found.
I18NLocal: 'strings/fm/english.lang' not found, skipping it.
----- Initializing OpenAL -----
Setup OpenAL device and context
OpenAL: found device 'ALSA Default'
OpenAL: found device 'HDA ATI HDMI, HDMI 0 (CARD=HDMI,DEV=3)'
OpenAL: found device 'HDA ATI HDMI, HDMI 1 (CARD=HDMI,DEV=7)'
OpenAL: found device 'HDA ATI HDMI, HDMI 2 (CARD=HDMI,DEV=8)'
OpenAL: found device 'HDA ATI HDMI, HDMI 3 (CARD=HDMI,DEV=9)'
OpenAL: found device 'HDA ATI HDMI, HDMI 4 (CARD=HDMI,DEV=10)'
OpenAL: found device 'HDA ATI HDMI, HDMI 5 (CARD=HDMI,DEV=11)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=0)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=1)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Digital (CARD=Generic,DEV=1)'
OpenAL: using 'OpenAL Soft'
OpenAL: HRTF is available
OpenAL vendor: OpenAL Community
OpenAL renderer: OpenAL Soft
OpenAL version: 1.1 ALSOFT 1.19.1
OpenAL: found EFX extension
OpenAL: HRTF is enabled (reason: 1 = ALC_HRTF_ENABLED_SOFT)
OpenAL: found 256 hardware voices
----- Initializing OpenGL -----
Setup X display connection
Using screen 0 of 0xdf88880 display
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Initializing OpenGL display
Using XFree86-VidModeExtension Version 2.2
Free86-VidModeExtension Activated at 1920x1200
Chosen visual: 0x021
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
...creating GL context: core-fc 
...initializing QGL

------- Input Initialization -------
XKB extension: compile time 0x1:0x0, runtime 0x1:0x0: OK
XKB extension present on server ( 0x1:0x0 )
------------------------------------
OpenGL vendor: X.Org
OpenGL renderer: Radeon RX 580 Series (POLARIS10, DRM 3.35.0, 5.4.0-40-lowlatency, LLVM 9.0.0)
OpenGL version: 4.5 (Core Profile) Mesa 19.2.8 core
Checking required OpenGL features...
v - using GL_VERSION_3_1
v - using GL_EXT_texture_compression_s3tc
v - using GLX_VERSION_1_4
Checking optional OpenGL extensions...
Max texture units: 32
Max active textures: 192
Max geometry output vertices: 256
Max geometry output components: 4095
Max vertex attribs: 16
v - using GL_EXT_texture_filter_anisotropic
    maxTextureAnisotropy: 16.000000
X - GL_ARB_vertex_program not found
v - using GL_ARB_stencil_texturing
v - using GL_EXT_depth_bounds_test
X - GL_ARB_geometry_shader4 not found
v - using GL_ARB_timer_query
v - using GL_KHR_debug
v - using GL_ARB_sync
v - using GL_ARB_draw_elements_base_vertex
v - using GL_ARB_texture_swizzle
v - using GL_ARB_buffer_storage
No ARB programs loaded
---------- R_ReloadGLSLPrograms_f -----------
Linking GLSL program cubeMap ...
Linking GLSL program bumpyEnvironment ...
Linking GLSL program depthAlpha ...
Linking GLSL program fog ...
Linking GLSL program oldStage ...
Linking GLSL program blend ...
Linking GLSL program stencilshadow ...
Linking GLSL program shadowMapA ...
Linking GLSL program shadowMapN ...
Linking GLSL program ambientInteraction ...
Linking GLSL program interactionStencil ...
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Linking GLSL program interactionShadowMaps ...
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Linking GLSL program interactionMultiLight ...
Linking GLSL program frob ...
Linking GLSL program soft_particle ...
Linking GLSL program tonemap ...
---------------------------------
New buffer size: 49152 kb
New buffer size: 49152 kb
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Font fonts/english/stone in size 12 not found, using size 24 instead.
--------- Initializing Game ----------
The Dark Mod 2.08/32, linux-x86, code revision 8771
Build date: Jun 17 2020
WARNING:file def/tdm_ai_undead_zombie.def, line 1084: entityDef 'atdm:ai_undead_zombie_alt_animations' previously defined at def/tdm_ai_undead_zombie.def:292
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
Initializing event system
...841 event definitions
Initializing class hierarchy
...172 classes, 834272 bytes for event callbacks
Initializing scripts
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Compiled ': 133.9 ms
---------- Compile stats ----------

Memory usage:
     Strings: 45, 7152 bytes
  Statements: 20325, 406500 bytes
   Functions: 1268, 129304 bytes
   Variables: 92036 bytes
    Mem used: 1346584 bytes
 Static data: 2277600 bytes
   Allocated: 3048940 bytes
 Thread size: 7068 bytes

...6 aas types
game initialized.
--------------------------------------
Parsing material files
Found 0 new mission packages.
Found 21 mods in the FM folder.
Parsed 24 mission declarations.
-------- Initializing Session --------
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
AL lib: (EE) ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe
Font fonts/english/mason_glow in size 12 not found, using size 48 instead.
Font fonts/english/mason_glow in size 24 not found, using size 48 instead.
Font fonts/english/mason in size 12 not found, using size 48 instead.
Font fonts/english/mason in size 24 not found, using size 48 instead.
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'QuitGameDialogAskEverytimeOption' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'AspectRatio' has value count unequal to choices count
WARNING:Unknown string id #str_07331
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'Screensize21to9' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'VertSync' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'OpenDoorsOnUnlock' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'InvPickupMessages' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'HideLightgem' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'BowAimer' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'FrobHelper' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertAttack' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertParry' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'SCGeneralBind5' has value count unequal to choices count
WARNING:Couldn't load sound 'sound' using default
session initialized
--------------------------------------
--- Common Initialization Complete ---
------------- Warnings ---------------
during The Dark Mod initialization...
WARNING:Couldn't load sound 'sound' using default
WARNING:file def/tdm_ai_undead_zombie.def, line 1084: entityDef 'atdm:ai_undead_zombie_alt_animations' previously defined at def/tdm_ai_undead_zombie.def:292
WARNING:file materials/tdm_epi_shader_2.mtr, line 485: material 'wizard_cloth_001' previously defined at materials/tdm_epi_shader_2.mtr:389
WARNING:file materials/tdm_water.mtr, line 1189: material 'textures/particles/ripple_1' previously defined at materials/tdm_particles_ripple.mtr:1
WARNING:file skins/tdm_epi_skins.skin, line 86: skin 'steam_engine_003_off' previously defined at skins/steam_engine_003.skin:1
WARNING:file skins/tdm_epi_skins.skin, line 97: skin 'steam_engine_003_on' previously defined at skins/steam_engine_003.skin:18
WARNING:file sound/tdm_ai_maiden.sndshd, line 1709: sound 'tdm_ai_maiden_request_help' previously defined at sound/tdm_ai_maiden.sndshd:1561
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'AspectRatio' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'BowAimer' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'FrobHelper' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'HideLightgem' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'InvPickupMessages' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertAttack' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'MeleeInvertParry' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'OpenDoorsOnUnlock' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'QuitGameDialogAskEverytimeOption' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'SCGeneralBind5' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'Screensize21to9' has value count unequal to choices count
WARNING:idChoiceWindow:: gui 'guis/mainmenu.gui' window 'VertSync' has value count unequal to choices count
WARNING:Unknown string id #str_07331
20 warnings
WARNING: terminal type 'xterm-256color' is unknown. terminal support may not work correctly
terminal support enabled ( use +set in_tty 0 to disabled )
pid: 936
Async thread started
Couldn't exec autocommands.cfg - file does not exist.
Linking GLSL program cubeMap ...
Linking GLSL program bumpyEnvironment ...
Linking GLSL program depthAlpha ...
Linking GLSL program fog ...
Linking GLSL program oldStage ...
Linking GLSL program blend ...
Linking GLSL program stencilshadow ...
Linking GLSL program shadowMapA ...
Linking GLSL program shadowMapN ...
Linking GLSL program ambientInteraction ...
Linking GLSL program interactionStencil ...
Linking GLSL program interactionShadowMaps ...
Linking GLSL program interactionMultiLight ...
Linking GLSL program frob ...
Linking GLSL program soft_particle ...
Linking GLSL program tonemap ...
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
 

Is there any other log I can fetch that would be of help?

Link to post
Share on other sites

I think the main problem could be:

ALCplaybackAlsa_mixerNoMMapProc: available update failed: Broken pipe

It occurs randomly in both logs.

 

Does sound work well in 32-bit? Did you try playing something for 5 minutes to check if it is buggy?

 

You can enable OpenAL logs by settings environment variables:

export ALSOFT_LOGLEVEL=3
export ALSOFT_LOGFILE=openal_log.txt

Make sure the TDM executable is run with them enabled. After run you can inspect the logs in openal_log.txt. You might want to generate the log both for 32-bit and 64-bit, and check the diff between them. And just look for anything suspicious there.

 

Also, you can change OpenAL backend in alsoft.ini.

Uncomment line which assign drivers. You can try setting oss, port, jack, alsa  (I guess alsa is default).

 

The last thing is to build TDM including all dependencies from sources. If you want to try it, ask me: I'll explain how to build third-party libs.

Link to post
Share on other sites

Thank you for your hints!

Yes, sound is okay in the 32-bit version of the game. I played the Snowed Inn for a couple of minutes without trouble. When starting the 64-bit version, the game runs without any sound, neither in the menu, nor in the mission.

I captured the two log files and attached a comparison picture of them (32-bit on the left, 64-bit on the right. The differences are highlighted).

openAL_Comparison01.png

  • Thanks 1
Link to post
Share on other sites

This is really interesting.

Did you look when exactly these errors happen? Right when TDM starts?
Do these trailing errors "Value out of range" happen in constant number, or they continue spamming as long as your main menu stays idle?

Of course, it makes sense only if these logfile is flushed after every message, which is how I would do it myself...

UPDATE: Try to disable HRTF in main menu and restart TDM. See if 64-bit version starts working this way.

Link to post
Share on other sites
  • 2 weeks later...

Dear stgatilov,

thanks again for looking into this and sorry for the delay - I was absent for a week.

I stayed in the main menu (32-bit) for a couple of minutes but the "Value out of range" error does not seem to happen while in the menu, only after starting a mission. The longer I stayed in the mission, the more of them accumulated.

The "Broken pipe" messages started to appear and got more and more when I clicked on the Credits.

Disabling HRTF sadly had no effect on the sound not being audible in the 64-bit version.

openal_test_64bit.txt openal_test_32bit_menu and credits.txt

Link to post
Share on other sites

No luck - still no sound with both of them, unfortunately.

My user experience with sound on Linux in general seems to be much more complicated than on Windows. At least TDM works in 32-bit...

openal_log_sysalsa_dynstd-FMtest.txt openal_log_sysalsa-test.txt Terminal output_sysalsa_dynstd-FMtest.txt Terminal output_sysalsa-test.txt

  • Like 1
Link to post
Share on other sites

Have you tried setting this in darkmod.cfg in place of 'seta s_device "default"'? I have the same named audio device and had to set the following manually:

seta s_device "HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)"

If that gives you audio, it's through ALSA and will not share with pulseaudio but for one active output.

In other words (especially for those mapping with DR), while running TDM audio output will be only from TDM. So you can't test speakers in DR if TDM was run first. Also, if DR is run first and audio is played there, then TDM will have no audio output until after DR has been closed.

Edited by PranQster
  • Like 1

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites
4 hours ago, Narrator said:

My user experience with sound on Linux in general seems to be much more complicated than on Windows.

Throughout the years I have had both the absolute best and absolute worst experiences with audio in Linux. Making sure the user has been added to the proper user groups ('audio' and 'realtime') is important for some audio software to work properly.

Right now my biggest complaints are with the problem this thread is about (our devices not being seen as 'default'), and with various programs requiring different audio systems. Audio production can be a challenge, with some software requiring JACK, others want ALSA, others PulseAudio, portaudio, oss, etc..  Fortunately, most of this software uses JACK and that has gotten much better over the years. I used to have to restart the machine to get pulseaudio working again after having used JACK, also to get JACK running again. Now things tend to switch back to pulse properly and have no troubles re-starting JACK.

But it's still a pain sometimes.

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites
Setup OpenAL device and context
OpenAL: found device 'ALSA Default'
OpenAL: found device 'HDA ATI HDMI, HDMI 0 (CARD=HDMI,DEV=3)'
OpenAL: found device 'HDA ATI HDMI, HDMI 1 (CARD=HDMI,DEV=7)'
OpenAL: found device 'HDA ATI HDMI, HDMI 2 (CARD=HDMI,DEV=8)'
OpenAL: found device 'HDA ATI HDMI, HDMI 3 (CARD=HDMI,DEV=9)'
OpenAL: found device 'HDA ATI HDMI, HDMI 4 (CARD=HDMI,DEV=10)'
OpenAL: found device 'HDA ATI HDMI, HDMI 5 (CARD=HDMI,DEV=11)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=0)'
OpenAL: found device 'Loopback, Loopback PCM (CARD=Loopback,DEV=1)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Digital (CARD=Generic,DEV=1)'
OpenAL: using 'OpenAL Soft'

Hmm... it lists many devices, but then chooses device with name OpenAL Soft, which does not even exist in its list 😥

Could you please find the line in darkmod.cfg:

seta s_device "default"

And replace it with:

seta s_device "ALSA Default"

Also try all the other names listed in console excerpt.

P.S. Actually, PranQster suggest the same.

  • Like 1
Link to post
Share on other sites
5 hours ago, stgatilov said:

Also try all the other names listed in console excerpt.

P.S. Actually, PranQster suggest the same.

I had tried "ALSA Default", with no luck, when I was trying to fix the same issue. I'm pretty sure the device listed as DEV=0 is what is needed, but not the one listed as Loopback. I'm 99% positive that using the following will fix this issue. If not, then try the loopback device.:

seta s_device "HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)"

Here's what my condump looks like for openal. Notice the addition of "(ACTIVE)" once the device is working:

----- Initializing OpenAL -----
Setup OpenAL device and context
OpenAL: found device 'ALSA Default'
OpenAL: found device 'HDA NVidia, HDMI 0 (CARD=NVidia,DEV=3)'
OpenAL: found device 'HDA NVidia, HDMI 1 (CARD=NVidia,DEV=7)'
OpenAL: found device 'HDA NVidia, HDMI 2 (CARD=NVidia,DEV=8)'
OpenAL: found device 'HDA NVidia, HDMI 3 (CARD=NVidia,DEV=9)'
OpenAL: found device 'HDA NVidia, HDMI 4 (CARD=NVidia,DEV=10)'
OpenAL: found device 'HDA NVidia, HDMI 5 (CARD=NVidia,DEV=11)'
OpenAL: found device 'HDA NVidia, HDMI 6 (CARD=NVidia,DEV=12)'
OpenAL: found device 'HD-Audio Generic, ALC1220 Analog (CARD=Generic,DEV=0)' (A
CTIVE)
OpenAL: found device 'HD-Audio Generic, ALC1220 Digital (CARD=Generic,DEV=1)'
OpenAL: using 'OpenAL Soft'
OpenAL: HRTF is available
OpenAL vendor: OpenAL Community
OpenAL renderer: OpenAL Soft
OpenAL version: 1.1 ALSOFT 1.19.1
OpenAL: found EFX extension
OpenAL: HRTF is enabled (reason: 1 = ALC_HRTF_ENABLED_SOFT)
OpenAL: found 256 hardware voices
----- Initializing OpenGL -----

And, yes, it is normal for it to say it is using OpenAL Soft.

Edited by PranQster
more info and clarity
  • Like 1

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites

This is magic - you did it: Specifying the ALC1220 audio chip in the darmod.cfg file gives me sound in the 64-bit version!

Thank you so much for your help and insights, both of you.

I just changed to Linux less than two years ago and still feel I have a lot to learn (never managed to get JACK running, and Ardour is unusable for me and can't even play a simple wav-file without stuttering due to xruns - well, maybe Pipewire will one day simplify things for us poor users...?)

But at least this problem seems to be solved. Thanks again!

  • Like 2
Link to post
Share on other sites
1 hour ago, PranQster said:

I had tried "ALSA Default", with no luck, when I was trying to fix the same issue. I'm pretty sure the device listed as DEV=0 is what is needed, but not the one listed as Loopback. I'm 99% positive that using the following will fix this issue. If not, then try the loopback device.:

Could you please install some 32-bit trash and check whether 32-bit build works properly without setting device explicitly?
I find it amusing that it works properly in 32-bit build.

 

Quote

And, yes, it is normal for it to say it is using OpenAL Soft.

It seems to be normal, but completely pointless. It is entirely precise and completely useless information, just like in an anecdote about programmers.
Here is discussion about this, which says this weirdness exists for compatibility with old Creative's implementation.

Look at the code:

//gets list of all available devices --- their names are printed to console as "found device ..."
const char *devs = alcGetString(NULL, ALC_ALL_DEVICES_SPECIFIER);

//opens default device in OpenAL --- that's what happens if you don't set s_device
openalDevice = alcOpenDevice(NULL);

//gets the name of device --- that's what is printed to console as "using ..."
alcGetString(openalDevice, ALC_DEVICE_SPECIFIER);

It sounds obvious that querying the name of particular device and getting the names of all devices should return the same names. But it does not 😫, because the function which queries the name of the device was in core OpenAL and was useless, and the function to get the list of all devices was added later as OpenAL extension specifically to cope with this problem.

As far as I see, I cannot get the detailed name of an opened OpenAL device. But it looks like I can query ALC_DEFAULT_ALL_DEVICES_SPECIFIER to get the name of default device (i.e. the one which gets opened by alcOpenDevice(NULL)). This way I can probably print the proper name to TDM console 🤔

 

  • Like 2
Link to post
Share on other sites

Is it possible that when s_device "default" is set, that it is looking for 'CARD=0,DEV=0'? I'm asking because I'm not a programmer and have no idea how a lot of this works.

If that is the case, then maybe when s_device "default" is set it doesn't look for 'CARD=Generic,DEV=0'?

  • Like 1

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites
3 minutes ago, PranQster said:

Is it possible that when s_device "default" is set, that it is looking for 'CARD=0,DEV=0'?

I think it should choose "ALSA default": it looks like the best default and comes first in the list.
Why it doesn't work --- that' probably question to ALSA configuration.

  • Like 1
Link to post
Share on other sites
17 hours ago, Narrator said:

This is magic - you did it: Specifying the ALC1220 audio chip in the darmod.cfg file gives me sound in the 64-bit version!

Thank you so much for your help and insights, both of you.

I just changed to Linux less than two years ago and still feel I have a lot to learn (never managed to get JACK running, and Ardour is unusable for me and can't even play a simple wav-file without stuttering due to xruns - well, maybe Pipewire will one day simplify things for us poor users...?)

But at least this problem seems to be solved. Thanks again!

Good to hear.

My very limited experience with ardour was with ALSA and I did not have a good time trying to set up my inputs and outputs. I have yet to link ardour with jack, but hope for a better experience. As for jack itself, I've used it to link qsynth and some guitar software and in that regard it has gotten much better in recent years.

Also, if getting jack running with qjackctl does not work, then try with 'cadence', and it's tools 'catia' or 'claudia'. Sometimes cadence can do a better job of initial jack configuration, and then either cadence or qjackctl can be used. I prefer Cadence because it's graphical tools for linking the audio devices is much more intuitive than what qjackctl has.

Edited by PranQster
more info
  • Like 1

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...