Jump to content
The Dark Mod Forums

Beta Testing 2.09


stgatilov
 Share

Recommended Posts

On 12/17/2020 at 3:38 PM, lowenz said:

Can you check the framerate after a savegame loading with AND without the freesync? Not moving around or rotating the camera, just standing there.

IMO the com_showFPS  display is buggy, it is not clearing the old displayed values, so it was overlapping the fps numbers very fast, was almost impossible to see clearly a single value during the game, but I could see more or less that it was showing values between 50 and 68 fps.

The screenshot bellow shows a single value thou, but I'm not sure I believe those fps numbers, even thou it shows 61 and 58 the game felt very smooth in both versions to me! 

Even with freesync disabled, I saw no screen tearing, perhaps because I have the screen set to 120hz. 

https://drive.google.com/file/d/10dAOzYynkH2aor-2pVNcygzRgPDQl6nR/view?usp=sharing

Btw was the savegame required for what you wanted? I asked because this is me starting the mission, taking the shot, quitting the game, disabling freesync and starting the mission again from the start, so no savegame was used.   

Edited by HMart
Link to comment
Share on other sites

I'm using RTSS (MSI Afterburner monitoring companion), not (only) internal values.

And I use 64 samples to smooth the (moving) average value: seta com_showFPSavg "64"

And you can clearly see the difference between 30 and 50 FPS moving around a bit, I mean simply walking around a bit. After the first movements + camera rotations the framerate goes up to the "right" value.

 

Savegame is required.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

11 hours ago, duzenko said:

Do we want to fix the timestamps in the installer zip?

I guess not...

This date is hardcoded in the "zipsync hashzip" command. I hope it is present in all calendars, regardless or DST and local changes, which is not guaranteed if I try to put real date to there. By the way, you always see build time when you start the installer.

Quote

 

The svn builds quite often crash with this, want to try the beta builds next.
Do we have debug symbols for beta 1 or how do we do this now?

 

Here they are: https://yadi.sk/d/0KKFiwpXNjvVrg?w=1

  • Like 1
Link to comment
Share on other sites

On 12/17/2020 at 9:28 PM, Araneidae said:

Yep, r_tonemap 0 seems to fix beta209-1.  Guess I'll run with this until beta-2!

Could you please try a few more things with r_tonemap 1 and see if it helps:

  1. Set all r_postprocess_XXX cvars to defaults (they should be after config reset).
  2. Set r_postprocess_gamma to 1 (its default value is 1.2).
  3. Set r_postprocess_sharpen to 0 (its default value is 1).

By the way, how does the erratic picture changes when you change r_postprocess_gamma and r_postprocess_brightness (you can do it in console or by moving sliders in menu) ?

Also, please try putting the attached file into glprogs directory, i.e. if your executable is at /home/tdm/thedarkmod.x64, then it should be at /home/tdm/glprogs/tonemap.fs. Restart TDM and check how if the erratic picture changes or is gone.
This hacked shader file simply passes the input color to output.
Be sure to restart TDM for it to have effect. Also, be sure to delete it when experiment is over.

tonemap.fs

  • Like 1
Link to comment
Share on other sites

I think I may have found my first bug. And I don't remember noticing it before this beta so it might be specific to it.

When you interact with some doors (trying to open, trying to lockpick, clicking noises while lockpicking, etc) the sound is heard at a very low volume, I'd say twice as low as it normally should be. Something tells me this has to do with the door entity being seen as sitting on the other side of the vis portal it's closing, thus the engine is likely culling the sound coming from that door due to forgetting doors should make an exception to this rule.

Link to comment
Share on other sites

4 hours ago, MirceaKitsune said:

When you interact with some doors (trying to open, trying to lockpick, clicking noises while lockpicking, etc) the sound is heard at a very low volume, I'd say twice as low as it normally should be.

Could you provide some examples of "good" and "bad" doors?

  • Like 1
Link to comment
Share on other sites

25 minutes ago, stgatilov said:

Could you provide some examples of "good" and "bad" doors?

I remember seeing it a few times but forgot exactly where. The only example I remember now is from today while playing an old FM called The Creeps: You should hear it with the double doors on the floor leading downwards when trying to open or pick them from outside (tiny FM so easy to find).

Edited by MirceaKitsune
Link to comment
Share on other sites

Wait, hol' up...

Quote

3) The additional color correction that got included into 2.08 has been disabled.
  Also gamma/brightness settings now affect everything, including: underwater, GUIs, menu, etc.
  As the result, the gamma/brightness behavior of TDM 2.07 is fully restored.

I spend an embarrassing amount of time trying to get 2.08 to have the same brightness/gamma as 2.07, since the defaults were much too dark. I even used @nbohr1more's settings here as a basis, and even then it still wasn't quite enough until r_ambientGamma was bumped up a bit more.

So are you saying that if I run the 2.09 beta with a fresh config, it won't need the tweaking anymore? What settings are disabled now?

 

Edited by Xolvix

A word of warning, Agent Denton. This was a simulated experience; real LAMs will not be so forgiving.

Link to comment
Share on other sites

9 hours ago, Xolvix said:

I spend an embarrassing amount of time trying to get 2.08 to have the same brightness/gamma as 2.07, since the defaults were much too dark.

I'm really sorry for that.

Quote

So are you saying that if I run the 2.09 beta with a fresh config, it won't need the tweaking anymore?

Yes.

Quote

What settings are disabled now? To get something similar to default 2.07 I had to use these settings in 2.08:

These are the new defaults:

  • seta r_postprocess_desaturation "0"
  • seta r_postprocess_colorCorrectBias "0.0"
  • seta r_postprocess_colorCorrection "5"
  • seta r_postprocess_colorCurveBias "0.0"
  • seta r_postprocess_brightness "1"
  • seta r_postprocess_gamma "1.2"
  • seta r_ambientGamma "1"
  • seta r_ambientMinLevel "0"

These values disable all the color correction that was "added" in 2.08. If you also set gamma to 1.0, then you should get exactly the default look of 2.07.

By the way, you can copy/paste your old values and use them it you don't like the new defaults.

  • Like 2
Link to comment
Share on other sites

Even r_postprocess_desaturation was turned off? That one sucks since it helps with the rustic effect and 0.05 was a very reasonable default. At this point I think I'm going to create my own cfg aiming for more hyper-realistic graphics, where I'll play and try to come up with nicer looking values for those settings: I wanted to tweak the bloom and such to make it more realistic anyway.

Link to comment
Share on other sites

38 minutes ago, MirceaKitsune said:

New bug found. 2.09 seems to break mirrors... quite literally 😄 Screenshots taken from two different rooms, the map is freshly dmapped with no errors or leaks or other geometric issues visible directly.

  1. Please write exact FM and location (getviewpos).
  2. Did you check it on 2.08?
  • Like 1
Link to comment
Share on other sites

1 hour ago, stgatilov said:
  1. Please write exact FM and location (getviewpos).
  2. Did you check it on 2.08?

It's a FM I'm working on and unfortunately not public yet nor anywhere near being ready for it. Luckily I developed most of it on 2.08 and can say for sure I didn't notice this issue a few weeks ago: I only did again today and wondered what might have happened, then realized I was on the 2.09 beta and it's likely that.

Link to comment
Share on other sites

It's been done to death, but seems like it has to be repeated time and time again: don't test engine beta versions with WIPs. Too many variables at play, and quite likely mapper's fault. Find a released mission with a mirror that exhibits the same symptoms, to be on the safe side.

Link to comment
Share on other sites

8 minutes ago, peter_spy said:

It's been done to death, but seems like it has to be repeated time and time again: don't test engine beta versions with WIPs. Too many variables at play, and quite likely mapper's fault. Find a released mission with a mirror that exhibits the same symptoms, to be on the safe side.

I don't see how this can be a mapper fault since everything else works fine and my map has no leaks, only mirrors are broken and not rendering the ceiling of the room. I wasn't using my WIP map for testing purposes either: I permanently switched to the 2.09 Beta, both to have the the latest version as well as help test it... incidentally I chose to take a look at my FM today for other reasons when I noticed this. If I see the issue in another FM I'll be playing I will submit its data.

I'd recommend looking at any FM that uses the mirror shader and seeing if the same issue occurs. I remember there are quite a few FM's that have mirrors in bathrooms, sadly no name by memory but I'm sure one can be found.

Edited by MirceaKitsune
Link to comment
Share on other sites

The next beta build will have my furniture pack (originally posted here and here)(rev 16045), and a fix for the new blue flame elementals.

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

I also found another issue, super minor one this time: The default citywatch AI (atdm:ai_citywatch_lesser) periodically spam console warnings about pickup_eat_righthand and AIUSE_EAT. It's also from my FM but I'm using a default entity which seems to be erroring out on a builtin animation. As far as anything relevant that's map specific could be involved, I can share the spawnargs I customize the two AI with in case one may be relevant:

pos_attach5 hand_l
def_attach5 atdm:prop_winebottle
def_head atdm:ai_head_citywatch_clothcoif
def_vocal_set atdm:ai_vocal_set_drunk_citywatch_01
drunk 1
sitting 1
team 2

def_head atdm:ai_head_citywatch_poor
def_vocal_set atdm:ai_vocal_set_cynic_citywatch
team 2
target0 name_of_a_path_corner

dividing_2020-12-24_18_25_03.thumb.png.367fa6810fc47586b1a7102c51ebe86d.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • STiFU

      We are taking our son on his very first holiday trip to see the sea for the first time. 🙂 Will be back in a week.
      · 0 replies
    • Gilkar

      When I was a young man my father was so ignorant I could hardly stand to have him around. As I grew older I was amazed at how much the old man had learned in such a short time.
      · 1 reply
    • jaxa

      RTX 3090 Super, RTX 3070 Ti 16 GB, RTX 2060 12 GB
      https://wccftech.com/nvidia-launching-rtx-3090-super-rtx-3070-ti-16gb-and-rtx-2060-12gb-by-january-2022/
      · 0 replies
    • duzenko

      CPU benchmark time - compiling DarkRadiant (2nd run)
      i5 8600K 6C/6T@4.4GHz DDR4 2x2133MHz 9MB cache
      Parallel builds: 1. 3:57 Parallel builds: 6 (default). 2:28 r5 1600AF 6C/12T@3.3GHz DDR4 1x2666MHz 16 MB cache, temp folder on HDD
      Parallel builds: 1. 5:05 Parallel builds: 4. 2:47 Parallel builds: 6. 2:55 Parallel builds: 12 (default). 2:57
      · 6 replies
    • nbohr1more

      Status updates are back so it is also a good time to return to contests!
      https://forums.thedarkmod.com/index.php?/topic/21095-christmas-connections-contest-2021
       
      · 0 replies
×
×
  • Create New...