Jump to content
The Dark Mod Forums

Public access to development versions


stgatilov
 Share

Recommended Posts

13 minutes ago, AluminumHaste said:

What performance do you get in the menu just after game load?

That's weird. I just updated SVN and built binaries from source. Now performance dropped 100+ FPS

WIHA8aT.png

No problem in the menu!

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

  • 2 weeks later...

Hmm.  Just starting a new map (inplainsight) and I get the following crash to desktop:

Spoiler
Switching to EFX 'location_inn_area' (#2)

Changed location from 'location_start' to 'location_inn_area'.
Trying to load image guis/assets/mainmenu/buttons_start/arrow_up from frontend, deferring...
Trying to load image guis/assets/mainmenu/buttons_start/arrow_down from frontend, deferring...
Trying to load image guis/assets/mainmenu/black_swirl from frontend, deferring...
Trying to load image guis/assets/hud/inventory_icons/loot_icon_ruby from frontend, deferring...
Trying to load image guis/assets/mainmenu/buttons_start/arrow_up_hover from frontend, deferring...
Trying to load image guis/assets/mainmenu/buttons_start/arrow_down_hover from frontend, deferring...
*** longjmp causes uninitialized stack frame ***: terminated
signal caught: Aborted
si_code -6
Trying to exit gracefully..
--------- Game Map Shutdown ----------
ModelGenerator memory: 44 LOD entries with 0 users using 704 bytes.
--------- Game Map Shutdown done -----
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
--------------------------------------
shutdown terminal support
About to exit with code 0

 

This is after switching to the latest beta (dev16599-10071), have been playing CoSD1 faultlessly with the previous beta (dev16574-10036).

Link to comment
Share on other sites

Just tested myself, same build, same mission. No problems on my end.

FM's: Builder Roads, Old Habits, Old Habits Rebuild

Mapping and Scripting: Apples and Peaches

Sculptris Models and Tutorials: Obsttortes Models

My wiki articles: Obstipedia

Texture Blending in DR: DR ASE Blend Exporter

Link to comment
Share on other sites

12 hours ago, Araneidae said:

Yeah, and it's not happening again.  Ho hum.  Was hoping the limited logs contained a clue.  Will see what happens...

Perhaps better enable automatic saving of crashdumps for this particular executable?

Link to comment
Share on other sites

  • 2 weeks later...

Still having the same problem, RX 570 with 22.9.1 (yesterday) drivers, REALLY low framerate (15 FPS).

No problem in the menus

The-Dark-Modx64-2022-09-22-01-54-43-802.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

6 hours ago, lowenz said:

Still having the same problem, RX 570 with 22.9.1 (yesterday) drivers, REALLY low framerate (15 FPS).

No problem in the menus

The-Dark-Modx64-2022-09-22-01-54-43-802.

Darkmod.cfg ?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

1 hour ago, lowenz said:

Pretty standard: https://pastebin.com/24PcxhFe

Thanks!

 

Do either:

seta r_shadowMapSinglePass "1"

or

setting Stencil Shadows in the GUI

improve performance at all ?

 

How about toggling:

r_softShadowsMipmaps "0"

?

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

@lowenz

I think we need to fix the visibility of this since the CVAR's don't print to darkmod.cfg but also try disable the BVH optimizations:

  • r_modelBvhLightTris 0
  • r_modelBvhShadows 0

 

 

  • Like 1

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Of course stencil improves, from 15 to 19 as expected 😛

And single pass doesn't make any difference.

 

No, the problem is somewhere else (related to the new OpenGL Radeon drivers)

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

41 minutes ago, nbohr1more said:

@lowenz

I think we need to fix the visibility of this since the CVAR's don't print to darkmod.cfg but also try disable the BVH optimizations:

  • r_modelBvhLightTris 0
  • r_modelBvhShadows 0

No difference, but I see they reset to their default values (3 / 1) every restart.

Edited by lowenz

Task is not so much to see what no one has yet seen but to think what nobody has yet thought about that which everybody see. - E.S.

Link to comment
Share on other sites

Also not getting the greatest FPS here:

 

BtF5LfF.png

 

Like, what in the world is in this scene that requires 100% GPU usage at 2.2Ghz and only gets 173FPS???

 

Looking at this corner can't even max to 300 fps.

q0hYWiD.png

Intel 12700K

Radeon 6800XT

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

Am I missing updated scripts and other files that are included with the official dev build?

I wanted to check, but I couldn't find a link to download dev builds. They aren't linked in the first post and each dev build announcement does not have a link. Dev build links aren't at https://www.thedarkmod.com/download-sourcecode/ either.

Where can I download them?

Cheers

Link to comment
Share on other sites

1 minute ago, Daft Mugi said:

Am I missing updated scripts and other files that are included with the official dev build?

I wanted to check, but I couldn't find a link to download dev builds. They aren't linked in the first post and each dev build announcement does not have a link. Dev build links aren't at https://www.thedarkmod.com/download-sourcecode/ either.

Where can I download them?

Cheers

You need the assets.

These would be acquired by using tdm_installer.

That said, the latest SVN release has assets that are not yet available in the installer so a team member would need to send you copies unless you can wait until the next Dev Build release

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 9 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...