Jump to content
The Dark Mod Forums

DarkRadiant 2.13.0 released


Recommended Posts

One suggestion on Material Editor: by default it uses orange pulsing light_torchflame, which is probably the least useful choice when prototyping materials. It also reverts to it every time you close the window. I suggest either switching to atdm:light_base as a default, or making the editor remember the last used light type and color.

Link to comment
Share on other sites

I figured most materials in TDM maps will be lit by sources that have a flame-like colour, so this resembles the final appearance best. But of course it doesn't offer a neutral view on the material which might be desirable too. I think remembering the value would be best, please feel free to open a tracker entry for that.

  • Thanks 1
Link to comment
Share on other sites

23 minutes ago, greebo said:

I figured most materials in TDM maps will be lit by sources that have a flame-like colour, so this resembles the final appearance best. But of course it doesn't offer a neutral view on the material which might be desirable too. I think remembering the value would be best, please feel free to open a tracker entry for that.

Thanks for the update man. Yeah I second going with something more neutral just a good ole 50-75 percent bright white light. I appreciate being able to see them in context though.

Link to comment
Share on other sites

Yup. A torch-like light might be good for a final preview, but for prototyping materials it's better to have neutral lighting without intensity changes. This way you can adjust things like specularity to avoid overblown highlights, etc. It's kinda like with photo studio lights, if it looks good there, it will look good in any lighting conditions. Thanks :)

Link to comment
Share on other sites

On 8/10/2021 at 2:22 PM, IZaRTaX said:

Very nice thank you 👍 but in the "edit colour shemes" the brushes color doesn't save anymore when you quit DarkRadiant 😪

On 8/10/2021 at 6:20 PM, greebo said:

If it's reproducible, off to the tracker it goes! :)

Possibly related, I'm seeing this in the console on Linux:

XMLRegistry: Failed to save path /darkradiant/user/ui/colourschemes

More seriously, I'm getting a segfault on startup which so far only affects the package build, which makes it fun to debug. Unfortunately I only noticed this after uploading the build to Launchpad, which I then had to delete, leaving the 2.12 build missing as well (since it seems Launchpad only stores the latest release for each Ubuntu series).

EDIT: The failure to save colourschemes message looks like a red herring. I can change the colour scheme and the result is saved to the next session. Setting the brush colour does save, but for some reason brushes appear black in the next session until you open the Colour Schemes dialog, at which point they suddenly change to the correct colour.

EDIT2: Hopefully the segfault is fixed now. It seems that I did not have libgit2-dev installed, and for reason this caused the main application to crash rather than silently drop Git features. This still needs to be investigated since Git is optional, but at least I should be able to get a working package out.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

There's definitely something weird going on the with colour schemes. I see the following:

  • On first load of a map, brushes are black and light volumes are green (using the Super Mal colour scheme).
  • When I enter the Colour Schemes editor, brushes and light volumes suddenly change to the correct (possibly customised) colour.
  • At the point where the colours change, this appears in the console:
    Applying colour 0.988235 0.913725 0.309804 to eclass worldspawn
    Applying colour 0.678431 0.498039 0.658824 to eclass light

My guess is something has changed with respect to initialising the colour scheme system, maybe it has switched to lazy initialisation so the colour schemes are not applied until the dialog is first entered? Although I don't see any obvious relevant changes in the code; the last change to EClassColourManager was by me, six months ago.

  • Like 1
Link to comment
Share on other sites

Yeah, I've been noticing this also, but I just go to View->Colors and it corrects itself until next time I open DR.

No errors in my console though:

 

Auto-saving registry to user settings path.
ColourSchemeManager: Loading colour schemes...
ColourSchemeManager: Loading colour schemes...
Auto-saving registry to user settings path.
Auto-saving registry to user settings path.

 

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

  • 4 weeks later...

The changelog is generated from the bugtracker, so only issues which have bugs logged will be in the changelog. Sometimes for really trivial changes like a single colour or icon tweak, I don't bother making a bugtracker entry (although really I should, it's just laziness on my part).

Link to comment
Share on other sites

Yes, tracking all the things you work on into online forms is a tedious task that nobody likes, if not outright hates, myself included. Feels like needless bureaucracy invented by control freaks, and as such it feels like my natural enemy... but the only thing more tedious is to skim through dozens or hundreds of git commit messages to gather everything that's been changed in between releases, that's why I do it. And it's admittedly a nice feeling when you get to scratch something off a list when you're done.

  • Like 2
  • Thanks 1
  • Haha 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...