Jump to content
The Dark Mod Forums

Beta testing 2.10


stgatilov
 Share

Recommended Posts

3 hours ago, stgatilov said:

As far as I remember, the wording was changed because "install" usually means downloading something, or doing some nontrivial os-dependent work. Nothing like that is done, you just select the mission, and restart engine in order to e.g. update main menu GUI.

For me it felt like I already selected that mission in the list above and wanted to start.. Or let's say apply it. I think writing select mission is not wrong though - but at least the button must be more prominent to indicate the user that the mission he or she selected from that list is gonna need another action to install / select / apply / start. Problem's not the wording, more the visibility and clarity. I can do a visual proposal if anyone is interested. However remember that this is just my point of view and I don't want to force anything to the team.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to comment
Share on other sites

9 hours ago, stgatilov said:

As far as I remember, the wording was changed because "install" usually means downloading something, or doing some nontrivial os-dependent work. Nothing like that is done, you just select the mission, and restart engine in order to e.g. update main menu GUI.

I get, why the engine has to restart and that this requires a full restart of the application. But couldn't the install/select button just do both: Install/select the mission if not already installed/selected and restart the application (and therefore the engine) and start the mission by giving a command line argument to the new application instance?

When wanting to load an old save of a non-selected/installed mission, aborting the briefing to the menu would still be possible.

Link to comment
Share on other sites

This may be a stupid idea but why not do the following when you select a new mission to play:

 

Select mission from downloaded missions list -> restart game if necessary -> mission loading/splash screen -> menu with "start mission", "load mission" etc.

 

 

edit: my brain had a derp

Edited by thebigh

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

Sorry, I mean the loading screen for the individual mission, with progress bar and such.

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

Not sure if reported yet, but in the latest beta I get windows that flicker blue, especially when leaning.

7n4f42F.png

 

Does not happen in 2.09b with same graphics settings. Not all windows, seems to be in relation to the fog moving around.

Darkmod.cfg

Radeon 5700XT latest drivers.

  • Like 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

On 1/6/2022 at 12:10 AM, MayheM said:

Not sure if it is a bug or not, if you walk left (pressing A) , it produces a creeping footsteps sound rather than the normal walking sound. I am using 2.10-3 beta

I reported this bug already. https://bugs.thedarkmod.com/view.php?id=5554

Also present in 2.09 so not particular to this release

  • Like 2

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

26 minutes ago, AluminumHaste said:

Not sure if reported yet, but in the latest beta I get windows that flicker blue, especially when leaning.

7n4f42F.png

 

Does not happen in 2.09b with same graphics settings. Not all windows, seems to be in relation to the fog moving around.

Darkmod.cfg 14.39 kB · 0 downloads

Radeon 5700XT latest drivers.

Hmm... for some reason your darkmod.cfg doesn't have the r_newFog cvar ? Make sure that is set to 0

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

I have two AIs that conduct a conversation in an area of my map. 
 

In a nearby area I also have a camera. When the camera detects me and the alarm goes off it breaks the two AI and they no longer have their conversation. 

 

Is there a way to get specific AI to ignore the alarm sounded by the camera?

Link to comment
Share on other sites

2 hours ago, Goldwell said:

I have two AIs that conduct a conversation in an area of my map. 
 

In a nearby area I also have a camera. When the camera detects me and the alarm goes off it breaks the two AI and they no longer have their conversation. 

 

Is there a way to get specific AI to ignore the alarm sounded by the camera?

Only way I know of to make AIs ignore an alert-causing event is to give them 0 acuity. Could start them at 0 auditory acuity, then set this to 1 via a script that's called by the same trigger that starts the conversation.

  • Thanks 1
Link to comment
Share on other sites

21 hours ago, nbohr1more said:

Hmm... for some reason your darkmod.cfg doesn't have the r_newFog cvar ? Make sure that is set to 0

Also, r_newFog is not defined as a CVAR in the code.

It only shows up in draw_common.cpp

Code    File    Line    Column
    static idCVarBool r_newFog( "r_newFog", "0", CVAR_RENDERER || CVAR_ARCHIVE, "alternative fog implementation" );    F:\Games\darkmod_src\renderer\draw_common.cpp    975    20

Code    File    Line    Column
    if ( r_newFog.GetBool() ) {    F:\Games\darkmod_src\renderer\draw_common.cpp    976    7

That's it for the entire solution. So it sounds like it will always be 0 looking at that code.

 

EDIT: I just cleaned and recursively undid all local changes, let me see if anything is broken with my source.

EDIT 2: Nope, still the same, there is no CVAR defined as r_newFog.

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

Sorry, I guess r_newFog never made it out of SVN. I could have sword I saw it in 2.09 (etc)? I suggested the cvar because the blue windows remind me of the remaining bug with it ( color inversion at a distance ).

I wasn't able to reproduce your window bug in 2.10 beta 4 so I guess you are onto something with driver bug thoughts.

There was a recent AMD fix applied to trunk, does the bug still manifest there too?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

Just rebuilt from src, yeah still happening

If I add "seta r_newFog" "1" to the darkmod.cfg it does show up in the console as 1, not sure if it's actually doing anything though.

Thought maybe this was because of the activated driver optimizations from renaming exe to Doom3BFG.exe, but I changed it back to TheDarkModX64.exe and the problem remains.

Probabaly AMD bug then, when I see the blue windows, if I go to the main menu, it's showing up there also.

TA171KA.png

VqVTRqi.png

  • Like 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

r_newFog was in 2.09 and it persists in 2.10 beta 4. It comes up in the console when I search for it. I find it weird that you don't have it, AluminumHaste, but regardless that looks like a material problem from looking at the screenshot more closely. They're rendering in front of the fog for sure, maybe if you posted the material def it would be of help.

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

Defining cvar as a static local variable is bad practice.
Because a static variable does not exist until the function which contains it gets executed.

So if you have this function executed at least once, you should have this cvar.
If the function was never executed in the current run, then cvar does not exist.

Link to comment
Share on other sites

That would be @duzenko

Revision: 8334
Author: duzenko
Date: September 21, 2019 6:10:35 AM
Message:
Alternative fog implementation
----
Modified : /trunk/renderer/draw_common.cpp

Maybe he did it that way for a reason?

  • Like 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

19 minutes ago, Spooks said:

r_newFog was in 2.09 and it persists in 2.10 beta 4. It comes up in the console when I search for it. I find it weird that you don't have it, AluminumHaste, but regardless that looks like a material problem from looking at the screenshot more closely. They're rendering in front of the fog for sure, maybe if you posted the material def it would be of help.

So try this. Remove "seta r_newFog" "1" from your Darkmod.cfg. Then go back in the game and see if you can still find it in the console.

Also, check to see if it's present in autocomands.cfg or autoexec.cfg files if you have them.

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

I'm using the new Secrets mechanism for my WIP. It works fine for frobbing objects with "secrets" "1" spawnarg. But I have a button that targets a atdm:secret. Every time I click the button it increments the secret count. The wiki says "By default, each of these atdm:secret entities can only be triggered once" but that doesn't seem to be the case. Unless I'm doing something wrong?

Link to comment
Share on other sites

1 hour ago, joebarnin said:

I'm using the new Secrets mechanism for my WIP. It works fine for frobbing objects with "secrets" "1" spawnarg. But I have a button that targets a atdm:secret. Every time I click the button it increments the secret count. The wiki says "By default, each of these atdm:secret entities can only be triggered once" but that doesn't seem to be the case. Unless I'm doing something wrong?

Oh no, I am experiencing this same issue but with a door instead of a button. The door targets the secret, but every time the door opens, the secret is triggered again, upping the count.

On the topic of secrets, is there a way for one secret entity to bypass the "gui_found" and "text_found" spawnargs from on the secret_messages entity? Let's say I want the text_found message for only 1 secret in the map to say "You have found a secret area" instead of the usual "You have found X out of Y secrets," how could I do that? 

Edited by Amadeus
Link to comment
Share on other sites

21 hours ago, AluminumHaste said:

So try this. Remove "seta r_newFog" "1" from your Darkmod.cfg. Then go back in the game and see if you can still find it in the console.

Also, check to see if it's present in autocomands.cfg or autoexec.cfg files if you have them.

Sorry, I don't have it in Darkmod.cfg! I don't have autoexec/commands cfgs either. I've kept a darkmod.cfg backup from 2.09 but it's not there either. Stgatilov may just be right, because I saw this mentioned at some point on the forums and played around with it, a couple of years ago.

I have a second, fresh install of 2.03, let me update it to 2.09 then and see if there's the command in there...

Well okay, that's weird. In both 2.09b and 2.10 beta4 r_newfog doesn't show up in the main menu but it does show up once you have loaded and are inside a map. Whatever that means, I don't know, but there it is.

 

  • Like 1

My FMs: The King of Diamonds (2016) | Visit my Mapbook thread sometimes! | Read my tutorial on Image-Based Lighting Workflows for TDM!

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • jaxa

      Embracer Group is Buying Square Enix Montréal, Eidos, and Crystal Dynamics for “Only” 300 Million USD: https://wccftech.com/embracer-group-square-enix-montreal-eidos-crystal-dynamics/
      · 1 reply
    • duzenko

      Do we want fur in TDM? Like https://duzenko.github.io/webgl/
      · 6 replies
    • Epifire

      Sometimes life throws a curveball - other times it straight up tries to take you outta the game. Been one thing after another lately but I ain't goin without a fight!
      · 2 replies
    • duzenko

      My Uber rating (as a passenger) is 4.71. Is there still hope or should I just kill myself? What's yours?
      · 3 replies
    • kano

      Did I mention how absolutely grateful I am that TDM didn't get (and can never be) assimilated by a huge company like Microsoft, as is what happened to Minecraft?
      · 3 replies
×
×
  • Create New...