Jump to content
The Dark Mod Forums

TDM_Installer does not allow to download the version of the game


Gadavre
 Share

Recommended Posts

An error has occurred in this program.   I tried to download the stable version 2.07, but I couldn't (screenshot below).   Аnd I'm now  sure that if players download the latest version 2.09b, it may be missing some files due to a bug. Can the developers check this program and fix it?

It would be very convenient, if all versions were uploaded to some cloud  and players could download any version without this  program.

 

error.jpg

 

 

Edited by Gadavre
  • Like 1
Link to comment
Share on other sites

13 hours ago, Gadavre said:

An error has occurred in this program.   I tried to download the stable version 2.07, but I couldn't (screenshot below).   Аnd I'm now  sure that if players download the latest version 2.09b, it may be missing some files due to a bug. Can the developers check this program and fix it?

I can reproduce this issue when updating from 2.09b to 2.07.
It look very worrisome to me. I'll investigate.

Quote

It would be very convenient, if all versions were uploaded to some cloud  and players could download any version without this  program.

There are a lot of simpler distribution approaches as long as players don't want differential updates.

Quote

and another suggestion... specify a checksum (md5) for each version of the game. So players can see if they've downloaded all the game files...

The installer does that internally.
Also, checksum works perfectly for single file, but for many files it would be a headache.

Link to comment
Share on other sites

3 minutes ago, stgatilov said:

I can reproduce this issue when updating from 2.09b to 2.07.
It look very worrisome to me. I'll investigate.

I didn't update the game, I downloaded the full version. In the program, I choosed "Get custom version"

mirror: аuto

Edited by Gadavre
Link to comment
Share on other sites

3 hours ago, Gadavre said:

I didn't update the game, I downloaded the full version. In the program, I choosed "Get custom version"

Yes, I guess it can be reproduce in several ways.

I have fixed the bug and pushed update to the server.
Could you please try again and report if the problem still happens?

I booted up local mirror and did something like 15 random hops between TDM versions, no fails.

Link to comment
Share on other sites

5 hours ago, freyk said:

As an alternative solution, you can download the full 2.07 package from moddb.

Thank you. However, the Source Revision there is old. Latest Source Revision 8079

You can view the Source Revision in the console by entering the command si_version

Edited by Gadavre
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • snatcher

      TDM Modpack v2.6 released!
      · 0 replies
    • peter_spy

      Perhaps an unpopular opinion: TDM team might benefit from someone with actual QA experience; someone with naturally and professionally developed curiosity, who is interested in how and why things work, how they break At least to me it's kind of mind-boggling how untested some rather important features are (first the absence alert feature for items, now the rope +body carry behavior).
      · 4 replies
    • nbohr1more

      The Dark Mod is hosting an Ask Me Anything thread on the PC Gaming reddit forum:  https://www.reddit.com/r/pcgaming/comments/10nfcwj/hello_we_are_the_international_development_team/
      Feel free to join the discussion there
      · 2 replies
    • stgatilov

      Bumped into an interesting piece of wisdom called Hyrum's Law:
      With a sufficient number of users of an API, it does not matter what you promise in the contract: all observable behaviors of your system will be depended on by somebody.
      · 5 replies
    • The Black Arrow

      I love playing The Dark Mod when it's cold in my place. Bonus points when it's a bit (or even very) dark and it's raining, too.
      · 2 replies
×
×
  • Create New...