Jump to content
The Dark Mod Forums

DarkRadiant 3.0.0 pre-release test


Recommended Posts

1 hour ago, greebo said:

I have to test this on another machine some time, one that doesn't have credentials saved at all, to have any chance of seeing what's going on.

Obviously there is something saved in the credstore, DR is retrieving non-empty strings for username/password, otherwise the message wouldn't be there.

You're right, I just re-tested with my other account and there was something in the credential store.  I had to close/re-open the credential manager to show the new credentials.

Also, I just created a Gitlab account and tried with that - exact same problem.

I'm happy to test further if you can share a setup that you know works?

Link to comment
Share on other sites

God damn this is impressive!

The render view is WAY faster. I'm getting 180fps in a scene that would get me 20-40fps before.

Even with render in lighting preview mode with lightmaps, I'm getting over 60 fps in the cathedral map. That used to tank to 10fps.

  • Like 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

I'm having quite pronounced RAM issues with my WIP in DR 3.0 compared to 2.14:

  • after loading my map in DR 2.14, according to task manager RAM usage is 1.85 GB and stays constant as I drag objects and the orthoview camera around
  • after loading my map in DR 3.0pre4, according to task manager RAM usage is 2.40 GB and rapidly climbs over 5 GB when I move the orthoview camera around, causing my PC to lock up as DR's memory usage keeps resetting and climbing up again. This PC has a total RAM of 8 GB, so it's probably hitting the limit.

If it helps I could send the WIP?

  • Like 1
Link to comment
Share on other sites

Yes it use more RAM memory less than 8gb, about 7gb+.

The other issue is the cpu It'll consume your entire memory example below I have a map with 30k brushes even if you hide and work on a part (CTRL+SHIFT+H) your cpu will go crazy like you are playing a game.

vertice_2.thumb.jpg.aa503aeb12b0595bb14c8f20d7d787ac.jpg

(my spec)

-NVIDIA GeForce GTX 1080 Ti

-i7 3930k

-Ram 32 GB DDR3

-SSD SamsungSSD870EVO2TB of 1.82 TB SATA III 

Here's the 2.14 version you can see the difference

dif_2_14.thumb.jpg.9ac9467fc621924eedf73d3049be7cc5.jpg

Same work with the 3.0.0 version, it'll use all cpu memory when you hide your entire map and work on your part (CTRL+SHIFT+H) shortcut

https://imgur.com/Pn4wOukhttps://imgur.com/Pn4wOukhttps://imgur.com/Pn4wOukPn4wOuk.png

 

 

Edited by IZaRTaX
Link to comment
Share on other sites

Great news, it's not crashing on me now!

I can also confirm the material stages aren't z-fighting themselves anymore.  Detail-mapping and additives now work properly.  Reflections, alpha-blends, GUIs, flares and some other things are still broken.

Reflections show blue/black checkerboard missing texture, despite that not being the case.  Alpha-blends are showing up as white, sometimes harsh black/white, fullbright and opaque.  And there's still some "rogue geometry", see the shot below.  Some things are showing up as black and I'm not sure why.  Some things are working only on certain viewpoints and appear/disappear depending on the view angle, see the shot below.  I can't tell if this is the shadows or the lights, such as in the shot of the intro, the light is affected but I don't know if that's because there is some alphatest material blocking it outside somewhere.

Anyhow, despite all of this it's a impressive progress and keep up the great work!

 

DRD3pre4test1.gif

DRD3pre4test2.gif

DRD3pre4test3.gif

Link to comment
Share on other sites

7 hours ago, LDAsh said:

Some things are working only on certain viewpoints and appear/disappear depending on the view angle, see the shot below.  I can't tell if this is the shadows or the lights, such as in the shot of the intro, the light is affected but I don't know if that's because there is some alphatest material blocking it outside somewhere.

I think this must be DR's current limitation to 6 shadowcasting lights. If more than 6 lights are shadowcasting in a view, DR will choose the 6 nearest lights. I assume when changing the camera angle, a nearer light comes into the view and another one stops casting shadows.

I can either try to get more lights to cast shadows, with some rearrangement of the shadow map texture, or try to choose the 6 lights in a better way.

Can you maybe share the map and camera position of those screens? I'd like to check these out.

7 hours ago, LDAsh said:

Reflections, alpha-blends, GUIs, flares and some other things are still broken.

Not broken, just not supported yet. There are quite a few renderer features that haven't made it into DR yet. Maybe next release, it all comes down to free time and motivation.

Link to comment
Share on other sites

10 hours ago, Dragofer said:

I'm having quite pronounced RAM issues with my WIP in DR 3.0 compared to 2.14:

DR is using triple frame buffers, and this is indeed quite expensive. I'll try to see if this can be reduced without compromising performance. It was set up this way to be able to support threaded rendering, but as there's no threading yet in the renderer, I might as well get rid of the triple buffer, and reduce it to one. This should save a few GB of system memory in large maps.

Link to comment
Share on other sites

On 4/3/2022 at 11:51 AM, greebo said:

Most time since 2.14 has been spent on the renderer, which should now be faster in regular (non-lit) render mode. Lit render mode is probably not going to be faster, but at least more accurate.
 

Understatement of the year.

2.14: 36 fps

RC3dxYV.png

2.14 renderview: 5 fps

xpA4sSN.png

 

 

3.00 flat shaded: 180 fps

fEZwon3.png

3.00 renderview WITH shadow maps: 60 fps

enuWaf9.png

 

 

 

That's such a huge increase, like bonkers mad, it's actually useable now

  • Like 1
  • Thanks 1

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

Indeed, like Greebo more or less said, some render effects are still missing or incomplete, so performance will very probably, come down even more, but even so the bump on performance and quality, compared to the former render is fantastic, no one can deny that.

Link to comment
Share on other sites

Next build (pre5) is available in the first post.

On 4/29/2022 at 11:09 PM, Dragofer said:

I'm having quite pronounced RAM issues with my WIP in DR 3.0 compared to 2.14:

This should be better now, I reduced the frame buffer count from 3 to 1. I'll get back to this in case the front end render pass is ever going to be multi-threaded, but for now it's safe.

This new build has reduced map loading times (by 10-20%) and front-end render times (by another 10%).

I still haven't been able to track down the geometry issues (stray diagonal lines messing up the view). They can appear right after map loading as well as in the middle of editing - I'm grateful for any insight on how this can be reproduced. I had it happen on me, but I couldn't find the reason so far.

  • Thanks 1
Link to comment
Share on other sites

3 hours ago, greebo said:

Next build (pre5) is available in the first post.

This should be better now, I reduced the frame buffer count from 3 to 1. I'll get back to this in case the front end render pass is ever going to be multi-threaded, but for now it's safe.

This new build has reduced map loading times (by 10-20%) and front-end render times (by another 10%).

I still haven't been able to track down the geometry issues (stray diagonal lines messing up the view). They can appear right after map loading as well as in the middle of editing - I'm grateful for any insight on how this can be reproduced. I had it happen on me, but I couldn't find the reason so far.

Thanks, I can confirm that RAM usage has gone way down, in fact even lower than in 2.14 since the map loads in at 1 GB and only increases if selecting everything, in that case climbing to 1.8 GB. Map loading does feel quite speedy too, now.

By the way, I noticed when drag-selecting large numbers of entities the console tends to get spammed with quite a lot of warnings like "EntityInspector: warning: removed key 'origin' not found in map." It also happens when I try DR 2.14, and so far I haven't discerned any pattern or cause for why DR would complain about these spawnargs.

Link to comment
Share on other sites

3 minutes ago, Dragofer said:

By the way, I noticed when drag-selecting large numbers of entities the console tends to get spammed with quite a lot of warnings like "EntityInspector: warning: removed key 'origin' not found in map." It also happens when I try DR 2.14, and so far I haven't discerned any pattern or cause for why DR would complain about these spawnargs.

Yes, I've noticed those too, but couldn't pinpoint it yet. Information about reproduction would be appreciated, I'd like to fix that as well. There must be one sequence of entity selection operations that triggers this, and which I obviously haven't covered in the unit tests.

Link to comment
Share on other sites

anyone seeing anything weird happening with the player start entity in the pre5 version?  In my map, it's invisible and only appears if it's selected.  If I add it to a new map, it's red but disappears if not selected.

Happy to raise a bug report, but just want to make sure it's nothing to do with my settings or anything.  I thought it might be due to filters, but it occurs even when all filters are turned off.

 

image.png.1b1619935d1ef95ff9448d7aeb1318e1.png

Link to comment
Share on other sites

On 5/2/2022 at 11:37 AM, Frost_Salamander said:

anyone seeing anything weird happening with the player start entity in the pre5 version?  In my map, it's invisible and only appears if it's selected.  If I add it to a new map, it's red but disappears if not selected.

I can't reproduce this. I'm using the portable version linked in the first post to make sure my local build is not different than the uploads, but the player start is not disappearing. I run DarkRadiant.exe, right-click to create a player start, and it's there. Pointfiles are working too for me.

Can anyone try this and provide more feedback, please?

@Frost_Salamander Is this something that is only happening in pre5, or are earlier pre-release builds affected too?

Link to pre4 portable, just in case: https://drive.google.com/file/d/11WJIyLq8LOB2RqF0daH8HidBpytYJtcs/view?usp=sharing

Link to comment
Share on other sites

5 hours ago, greebo said:

I can't reproduce this. I'm using the portable version linked in the first post to make sure my local build is not different than the uploads, but the player start is not disappearing. I run DarkRadiant.exe, right-click to create a player start, and it's there. Pointfiles are working too for me.

Can anyone try this and provide more feedback, please?

@Frost_Salamander Is this something that is only happening in pre5, or are earlier pre-release builds affected too?

Link to pre4 portable, just in case: https://drive.google.com/file/d/11WJIyLq8LOB2RqF0daH8HidBpytYJtcs/view?usp=sharing

I backed up and deleted my entire AppData/Roaming/DarkRadiant folder and restarted pre5, and the problem went away. Just trying to pin down exactly what setting it was - not sure I'll be able to but will update if I find it.  Will also update the bug tracker.

Edited by Frost_Salamander
delete inaccurate statement
  • Like 1
Link to comment
Share on other sites

I have the same problem now. Player start goes invisible, fresh install of portable version pre5

 

I have an AMD Radeon 6800XT if that matters

I always assumed I'd taste like boot leather.

 

Link to comment
Share on other sites

New pre6 release is available in the first post.

The playerstart visibility is fixed, and I could finally resolve that bug causing the weirdly stretched geometry in the render views.

  • Like 2
  • Thanks 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


  • Recent Status Updates

    • Nort

      I did it! I finally did it! After 48 hours of frustration and confusion, I managed to finally sort out how to attach equipment to NPC:s properly, and write down coherent instructions on how to do it, both in my manual, and in this forum.
      I can finally rest. I can finally eat breakfast.
      · 0 replies
    • Nort

      Spent most of the day learning and writing about AI navigation. It's stuff I already know, but the magic about writing something down as clearly formulated as possible, is that you then see things that much more clearly. You also find what's unclear to you, and then you figure out exactly how things work. I was hoping to get through it all within just a day, but it looks like this will take tomorrow as well, at this rate. There's also plenty of other nonsense I have to get through as well. Everything's a chore.
      · 0 replies
    • Nort

      I want to be a fish, but I'm not a fish. My mom wants to be a fish too, and so she's killing herself eating plankton and sh***ng blood, and tells me to stop nagging her about taking her medication. I spent several hours today, just lying in bed, having anxiety over just existing, and not being a fish. You fish, you don't know how lucky you are. You can eat all the plankton you want. I tried eating plankton again yesterday, and I just got sick. I hate being a shark.
      · 0 replies
    • Nort

      I just gave myself vertigo. A pleasant kind of vertigo, like the world has been lifted off my shoulders. I'll explain:
      Yesterday I saw to my dismay, that I had made my entire map two - two - units too short on every level - that every set01 piece was sticking 2 units into the ceiling. That's basically 402 brushes that needs to be realigned (minus the ground floor brushes).
      I knew enough about selections to do all of that in a very tense five minutes, and it compiled without leaks. (Thank you so much, Dark Radiant devs, for making an editor with such care for precision that you can align hundreds of brushes perfectly at once (which is not something I can say for Valve's Hammer editor, which has some serious issues on that front, which actually made me just quit it in disgust).) However, the result is that the entire level has now been stretched a barely noticable 2 units, and it will take some getting used to psychologically.
      · 0 replies
    • Nort

      My workflow is basically running from a chain of disasters, eventually trying to seek shelter in former disasters. It's not ideal - it's just my life.
      When I abandoned my first map, it was out of a typical mental breakdown, and so I returned to find a skybox void where the kitchen door should have been (due to a misplaced visportal) and two overlapping brushes Z-fighting on the kitchen floor.
      I've now cleaned up the last bit of mess, by cleanly separating every floor into its own layer. Now I can finally work on each floor in peace.
      ...not that I really needed to. Once you get skilled enough, the orthographic messes, well, I'll let this video speak for itself:
       
      · 1 reply
×
×
  • Create New...