Jump to content
The Dark Mod Forums

Windows XP machine doesn't handle x64 Dark Mod


Recommended Posts

33 minutes ago, nbohr1more said:

As previously mentioned, TDM 2.10 does not work on Windows XP.

You will need to install TDM 2.07 or older unless you are a developer and know how to compile from source and get 2.10 to compile with Windows XP flags.

Thanks, I've downloaded it and copied to "My Documents" folder and created TheDarkMod.exe and TheDarkModx64.exe as shortcuts on desktop and tried to open the game on Windows XP, but neither did this help.

Capture.PNG

Link to comment
Share on other sites

Your VM needs to have an OpenGL 2.x compliant video device ( with associated drivers installed ) or you need to enable pass-through hardware support in your VM ( also with drivers installed ).

I think @lowenz had a special compile working that could run the video entirely on the CPU but was VERY slow.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

11 minutes ago, nbohr1more said:

Your VM needs to have an OpenGL 2.x compliant video device ( with associated drivers installed ) or you need to enable pass-through hardware support in your VM ( also with drivers installed ).

I think @lowenz had a special compile working that could run the video entirely on the CPU but was VERY slow.

I've downloaded the file "nvidiaopenglrdp.exe" and tried to open it, but neither still did this help.

Capture2.PNG

Link to comment
Share on other sites

5 minutes ago, nbohr1more said:

I think you are trying to apply a driver that isn't XP compatible in your VM.

Yes, I have The Dark Mod 2.07 installed on my Windows XP Professional x64 Edition virtual machine, I've tried to launch the 32-bit executable, but it gives me the same error message.

Link to comment
Share on other sites

6 hours ago, nbohr1more said:

Your VM needs to have an OpenGL 2.x compliant video device

Hey, we require OpenGL 3.3 today!

And I know only one VM which can deliver that version with hardware acceleration, and that's not Windows XP mode 🤣

  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...
On 8/29/2022 at 11:17 PM, stgatilov said:

Hey, we require OpenGL 3.3 today!

Still no one was able to fix the problem?

I'd like to state, that I'm using the same files in game folder, like on a secondary computer, where The Dark Mod 2.10 runs fine. Therefore I guess the issue is in some missing program or Windows. However on my main computer, there's also Windows XP Professional x64 Edition, like on the virtual machine where I can't make The Dark Mod 2.07 running.

Any suggestions please?

Edited by PastMarioOfBeingAliveClu
Link to comment
Share on other sites

So if you're intent on staying with Windows 7, you're going to eventually find a lot of productivity software that won't run anymore besides TDM. Windows 7 extended support ended almost 3 years ago from the same company that made it, Microsoft. If you called them with support questions about Windows 7, they'll just laugh at you.

Here's a question, why not upgrade your VM to Windows 10? You can actually do it for free still with your Windows 7 digital license. And Windows 10 will automatically do tablet mode.

 

  • Like 1
  • Confused 1
  • Sad 1
Link to comment
Share on other sites

1 hour ago, Shadow said:

So if you're intent on staying with Windows 7, you're going to eventually find a lot of productivity software that won't run anymore besides TDM. Windows 7 extended support ended almost 3 years ago from the same company that made it, Microsoft. If you called them with support questions about Windows 7, they'll just laugh at you.

Here's a question, why not upgrade your VM to Windows 10? You can actually do it for free still with your Windows 7 digital license. And Windows 10 will automatically do tablet mode.

Hey, don't muddle the water more than necessary 🤔

TDM still perfectly supports 64-bit Windows 7, but it has dropped support for Windows XP.
It is surely possible to run old version of TDM under Windows XP, or maybe even backport the recent version. It is possible to run on 32-bit Windows too.

But what surely won't work is running TDM inside a virtual machine 😁

Except for VMWare.
It is yet possible to run TDM inside VMWare guest, but you won't get any pleasure from playing this way.
And GPU passthrough should indeed work, but that's a very advanced (and I guess Linux-only) setup.

 

  • Like 1
  • Confused 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 4 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...