Jump to content
The Dark Mod Forums

Zooming in with mouse scroll in freelook mode not possble


 Share

Recommended Posts

I have this issue since 3.0, still present in 3.2 . When I am in free camera mode (right mouse button in Camera view), I can't zoom in and out with mouse wheel scroll, keyboard arrows do still work.

Somebody else (Nort) mentioned he/she couldn't reproduce the issue under Windows, so maybe it's just my (Linux) system and therefore I decided I don't add it to the bugtracker yet.

Link to comment
Share on other sites

I tried it with Linux mint xfce from usb stick. Same issue. Also by using a different mouse. So weird, but I guess it must be my pc then..

19 minutes ago, greebo said:

That's in a virtual machine, it is compiled against wxWidgets 3.2.0.

Is that the flatpak install? because that uses wxWitgets 3.05 (in the sandbox).

Edited by datiswous
Link to comment
Share on other sites

Hello, I have the same problem on Ubuntu 20.04 with xwWidgets 3.0.4, in my case even the arrow keys aren't working, it seems that focus is kept on the window below when pressing keys, and zooming with mouse wheel only works while not in freelook.

EDIT: arrow keys are working only if the tab "Favourites" is left selected, maybe becouse there is nothing to select there and the window focus goes to freelook camera.

EDIT2: after tricking with tab favourites now keys are working even if other tabs are selected, but mouse wheel still doesn't. ctrl and shift for zooming and panning are working fine so we can live with that.

Edited by desma
Link to comment
Share on other sites

With the latest Ubuntu package I see the same behaviour: mouse scroll works when not in freelook mode, but in freelook mode it does nothing (arrow keys still work).

To be honest I think it's been like that for ages but I never realised that the scroll wheel was supposed to work in freelook mode.

Link to comment
Share on other sites

@datiswoustry upgrading your flatpak to the new 3.3.0 release.  The 3.2.0 flatpak was indeed compiled against wx 3.0.5, but since a blocking bug got fixed the new one is using wx 3.2.1.

I've got both flatpaks installed, and for me the old one has the scrollwheel issue and the new one does not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • nbohr1more

      Anyone have any luck with light.setShader( string ) ? It seems to make whichever light you apply it to full-bright on the initial invoke?
      · 0 replies
    • thebigh

      I'm starting to think we need another mapping contest.
      · 4 replies
    • kano

      Don't you hate it when there's a quality discussion on a forum somewhere online about something, but then two disagreeing users derail and transform it into a back-and-forth poo slinging competition at one another?
      · 9 replies
    • Diego

      Oh look the status updates are back! 
      · 2 replies
    • JackFarmer

      After watching the first three and a half episodes of "The Sandman" last night, I realize once again that overly imaginative narratives are not for me. Also, the main actor looks like he has a toothache.
      Which makes me wonder, is there a Dark Mod mission with a medieval dentist?
      · 4 replies
×
×
  • Create New...