Jump to content
The Dark Mod Forums

The Dark Mod 2.11 feedback thread


nbohr1more

Recommended Posts

34 minutes ago, Wallace said:

Haven't tried the update yet... but can anyone give me a ballpark figure as to how much their FPS and/or load times has improved? (if at all)

The big improvement to load times was in 2.10. About a quarter of the time to load missions ( or lower ) compared to 2.09 ( which also had a few load time improvements).

FPS improvement might be around 2x with Anti-Aliasing at 4x or higher.

There were beta missions that saw a massive 150 to 200% improvement in performance but in both cases the authors fixed their performance issues through changes in map design or scripting. The project is now more resilient against some pathological performance issues if the map authors don't address them but no in-the-field map has any dramatic issues like these. We are future-proofed for bigger missions though.

One mission "Scroll of Remembrance" still has very poor performance and the optimizations between 2.10 and 2.11 have had no effect. Likely the only way to address it is having the author or another team member examine visportals and other options to close off rendering.

  • Like 4

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

I think you should consider to have a setting in the GUI for 'toggle run' instead of just 'always run'. I added it myself after a bit of googling since i'm one of those weird people that prefers to not keep a button pressed to stay quiet but like to just crawl everywhere 'running' anyway (also added a key for highlighting loot, keys and frobs, since life is short).

The incantation is "toggle in_alwaysRun 0 1;"

Strangely this isn't in the wiki page for 'useful console commands'.

My other request is a way to 'modulate' the distance of highlighting loot or -especially- frobs because it's overwhelming.

Also wondering why weapons and arrows are often not counted as frobs or loot. Oh well. Edited by i30817
Link to comment
Share on other sites

What's the plan for the def/tdm_shopitems.def file in TDM 2.11?

Will each affected mission get updated, or will TDM core assets get updated?

So far, "William Steele 1: In the North" and "Full Moon Fever" have been reported.
Which other missions are affected?

Edited by Daft Mugi
  • Like 2
Link to comment
Share on other sites

27 minutes ago, wesp5 said:

I already fixed this in the Unofficial Patch thanks to your feedback. Or are there more of these issues? It looked to me like only one name was accidentally cut short...

Perhaps the change in TDM 2.11 provides more flexibility for mission authors? I'm not sure. But missions made for TDM 2.10 and prior will need to be updated if they rely on "map_of_icon.tga". That's my understanding anyway.

I imagine a mod that reverts that change might break future missions made for TDM 2.11 that take advantage of the change. So, it's probably better to target each affected mission individually.

I asked what the plan was, because I haven't seen a clear way to resolve this yet.

Link to comment
Share on other sites

Re map_of.tga vs map_of_icon.tga ?

The whole thing started because of an attempt to clear-up errors caused by a core file referencing a missing image. Some mission authors must have used this same path correctly so the attempt to fix this must have broken that and then the revert also broke something?

@Dragofer  ?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

10 hours ago, nbohr1more said:

Re map_of.tga vs map_of_icon.tga ?

The whole thing started because of an attempt to clear-up errors caused by a core file referencing a missing image. Some mission authors must have used this same path correctly so the attempt to fix this must have broken that and then the revert also broke something?

@Dragofer  ?

An easy way to fix this should be providing the tga under both names. Right now I can't even find it, because it's not in the gui archive where it should be, or is this not really part of the core game? In that case maybe it should be added...

Edited by wesp5
Link to comment
Share on other sites

7 hours ago, wesp5 said:

An easy way to fix this should be providing the tga under both names. Right now I can't even find it, because it's not in the gui archive where it should be, or is this not really part of the core game? In that case maybe it should be added...

A FM has the "map_of_icon.tga" file, not core.

If you look at the file contents of FM pk4 files, you'll see that some missions have several different "map_ofX" files.

It looks like the default was "map_of_icon.tga" and if the FM author wanted to override that or have more maps, they would define it in their FM.

For example, "Behind Closed Doors" uses a "map_of_icon.tga" file. However, it is not affected by this, because it defines the "atdm:map_of" "inv_icon" as "guis/assets/game_maps/map_of_icon.tga" in its "def/custom.def" file.

TDM 2.10 defines "atdm:map_of" as:

entityDef atdm:map_of
{
        "inherit"                       "atdm:map_base"

        "editor_usage"          "game map of terrain for player" // THIS ONLY SHOWS IN ENTITY INSPECTOR

        "inv_name"                      "#str_02203"    // Map - SHOWS IN PLAYER'S INVENTORY.
        "inv_icon"                      "guis/assets/game_maps/map_of_icon.tga"
        "gui"                           "guis/map_of.gui"
}

TDM 2.11 defines "atdm:map_of" as:

entityDef atdm:map_of
{
	"inherit"			"atdm:map_base"

	"editor_usage"		"game map of terrain for player" // THIS ONLY SHOWS IN ENTITY INSPECTOR

	"inv_name"			"#str_02203"	// Map - SHOWS IN PLAYER'S INVENTORY.
	"inv_icon"			"guis/assets/game_maps/map_of"
	"gui"				"guis/map_of.gui"
}

As another example, Iris has two "map_of" maps that are not affected, because it overrode "atdm:map_of" and defined "atdm:map_ofhollowbrook".

entityDef atdm:map_of
{
	"inherit"			"atdm:map_base"

	"editor_usage"		"game map of terrain for player" // THIS ONLY SHOWS IN ENTITY INSPECTOR
	"inv_name"			"Map" // SHOWS IN PLAYER'S INVENTORY.
	"inv_icon"			"guis/assets/game_maps/map_of_icon.tga"
	"gui"					"guis/map_of.gui"
}

entityDef atdm:map_ofhollowbrook
{
	"inherit"			"atdm:map_base"

	"editor_usage"		"game map of terrain for player" // THIS ONLY SHOWS IN ENTITY INSPECTOR
	"inv_name"			"Map" // SHOWS IN PLAYER'S INVENTORY.
	"inv_icon"			"guis/assets/game_maps/map_ofhollowbrook_icon.tga"
	"gui"					"guis/map_ofhollowbrook.gui"
}

So, it looks like any FM that has not overridden the default "atdm:map_of" will show a black square as its map when using TDM 2.11.

Hope that helps with understanding this!

  • Like 2
Link to comment
Share on other sites

I think I have the same issue with map icon on AT1: Lucy mission.
Just took the map on the table in starting room, and its inventory icon is black.

I have a feeling this is major breakage and we'll have to release a hotfix at some moment 😭
Anyway, I think @Dragofer should look into this, since he was the one to mess with these two files during 2.11 development, and then doing the last tweak to them during beta 😰

  • Like 4
Link to comment
Share on other sites

On 2/14/2023 at 8:37 AM, stgatilov said:

I think I have the same issue with map icon on AT1: Lucy mission.
Just took the map on the table in starting room, and its inventory icon is black.

I have a feeling this is major breakage and we'll have to release a hotfix at some moment 😭
Anyway, I think @Dragofer should look into this, since he was the one to mess with these two files during 2.11 development, and then doing the last tweak to them during beta 😰

Wow, I literally started playing this mission for the first time only a few days ago and can confirm the black inventory icon. Since I hadn't played it before updating to TDM 2.11, I just assumed it was a problem with the FM. A hotfix sounds like a good idea.

Edited by Xolvix

A word of warning, Agent Denton. This was a simulated experience; real LAMs will not be so forgiving.

Link to comment
Share on other sites

I don't know if this has been reported before but: in my options menu I can choose between a 16 bit and a 32 bit renderer. However the context help says that I should choose between a 32 and 64 bit renderer. 64 to make bloom work. And no matter if I select 16 or 32 the bloom settings never become greyed out anyway.

"Einen giftigen Trank aus Kräutern und Wurzeln für die närrischen Städter wollen wir brauen." - Text aus einem verlassenen Heidenlager

Link to comment
Share on other sites

  • 2 weeks later...

A crash playing mission wwtw (Who watches the watcher?) 2.11 very early on:

Spoiler
...

STARTING CREAKING PIPES_3
Linking GLSL program tiled_mipmap_first ...
Linking GLSL program tiled_mipmap_subsequent ...
The ambient 'snd_inside_hum' (hum_subtle04_loop) for location 'old_apartments' is now playing.
WARNING:file /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui, line 203: wrong number of arguments for script command set: 4 instead of [2..2], maybe missing semicolon?
WARNING:unknown destination 'BriefingAnimation::visible' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:109
WARNING:resetTime target window 'BriefingAnimation' not found at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:110
WARNING:unknown destination 'BriefingAnimation::visible' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:134
WARNING:unknown destination 'BriefingAnimation::notime' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:135
Could not find item in player inventory: #str_02397
Could not find item in player inventory: #str_02397
WARNING:Already have an attachment at hand_r, skipping frame command.
Trying to load image models/darkmod/props/textures/compass/compass from frontend, deferring...
Trying to load image models/darkmod/props/textures/compass/compass from frontend, deferring...
Quicksave_0
*** longjmp causes uninitialized stack frame ***: terminated
signal caught: Aborted
si_code -6
Trying to exit gracefully..
--------- Game Map Shutdown ----------
ModelGenerator memory: 85 LOD entries with 0 users using 1360 bytes.
--------- Game Map Shutdown done -----
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
--------------------------------------
shutdown terminal support
About to exit with code 0

 

Went downstairs from the starting area, wondering how to get out, picked up a board ... and bang!  An invalid longjmp sounds pretty unhealthy.

Will try again, and update this post accordingly.

Edit: Sorry, could not repeat.

Edited by Araneidae
  • Like 1
Link to comment
Share on other sites

10 minutes ago, Araneidae said:

A crash playing mission wwtw (Who watches the watcher?) 2.11 very early on:

  Hide contents
...

STARTING CREAKING PIPES_3
Linking GLSL program tiled_mipmap_first ...
Linking GLSL program tiled_mipmap_subsequent ...
The ambient 'snd_inside_hum' (hum_subtle04_loop) for location 'old_apartments' is now playing.
WARNING:file /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui, line 203: wrong number of arguments for script command set: 4 instead of [2..2], maybe missing semicolon?
WARNING:unknown destination 'BriefingAnimation::visible' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:109
WARNING:resetTime target window 'BriefingAnimation' not found at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:110
WARNING:unknown destination 'BriefingAnimation::visible' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:134
WARNING:unknown destination 'BriefingAnimation::notime' of set command at /fms/wwtw/wwtw.pk4/guis/mainmenu_briefing.gui:135
Could not find item in player inventory: #str_02397
Could not find item in player inventory: #str_02397
WARNING:Already have an attachment at hand_r, skipping frame command.
Trying to load image models/darkmod/props/textures/compass/compass from frontend, deferring...
Trying to load image models/darkmod/props/textures/compass/compass from frontend, deferring...
Quicksave_0
*** longjmp causes uninitialized stack frame ***: terminated
signal caught: Aborted
si_code -6
Trying to exit gracefully..
--------- Game Map Shutdown ----------
ModelGenerator memory: 85 LOD entries with 0 users using 1360 bytes.
--------- Game Map Shutdown done -----
Shutting down sound hardware
idRenderSystem::Shutdown()
...shutting down QGL
I18NLocal: Shutdown.
------------ Game Shutdown -----------
ModelGenerator memory: No LOD entries.
Shutdown event system
--------------------------------------
shutdown terminal support
About to exit with code 0

 

Went downstairs from the starting area, wondering how to get out, picked up a board ... and bang!  An invalid longjmp sounds pretty unhealthy.

Will try again, and update this post accordingly.

Looks like the only place we use longjmp is for jpeg loading. @stgatilov I recall you updated Libjpg in SVN recently, perhaps a new Dev Build will resolve this one?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

  • 2 weeks later...

This might have been mentioned before but the auto-frobbing feature should only work for loot. Currently it also works for weapons laying next to each other (for example in map2 of A house of locked secrets), but if you do that then the hud items don't appear when you use them, making them impossible to use.

Example:

Sword does not appear when active:

ahouseoflockedsecrets(2023-03-1404-31-48)(1464.71057.94-11.75).thumb.jpg.4a9a2dfa216c526d04cd9be54b506dab.jpg

Edited by datiswous
  • Like 1
Link to comment
Share on other sites

1 hour ago, datiswous said:

This might have been mentioned before but the auto-frobbing feature should only work for loot. Currently it also works for weapons laying next to each other (for example in map2 of A house of locked secrets), but if you do that then the hud items don't appear when you use them, making them impossible to use.

Recently added to the bug tracker: https://bugs.thedarkmod.com/view.php?id=6270

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

I have a question regarding the "look through keyhole" feature in TDM 2.11.

I have almost finished "Seeking Lady Leicester" and tried out this feature on multiple keyholes.

What I get is darkness, sometimes outside architecture and sometimes a keyhole shaped look at the door around the keyhole.

Is it only working if the author(s) implement it in FM's?

Install is running on Linux Mint 21.1 Cinnamon

 

Link to comment
Share on other sites

26 minutes ago, Woodsie69 said:

I have a question regarding the "look through keyhole" feature in TDM 2.11.

I have almost finished "Seeking Lady Leicester" and tried out this feature on multiple keyholes.

What I get is darkness, sometimes outside architecture and sometimes a keyhole shaped look at the door around the keyhole.

Is it only working if the author(s) implement it in FM's?

Install is running on Linux Mint 21.1 Cinnamon

 

I believe the keyhole peek feature only works in Windows at the moment. The black screen is an improvement as previous versions would hard crash to desktop if you attempted to peek with Linux.

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to comment
Share on other sites

7 minutes ago, nbohr1more said:

I believe the keyhole peek feature only works in Windows at the moment. The black screen is an improvement as previous versions would hard crash to desktop if you attempted to peek with Linux.

@nbohr1more

Thank you for your reply.

Glad it's not a bug at my end then. 🙂

Link to comment
Share on other sites

3 hours ago, nbohr1more said:

I believe the keyhole peek feature only works in Windows at the moment. The black screen is an improvement as previous versions would hard crash to desktop if you attempted to peek with Linux.

I just filed one bugtracker related to the func_peek entity, should I file one for func_peek on Linux too, or is it already done?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recent Status Updates

    • nbohr1more

      The Black Parade is now in the Top 100 list for Mod of the Year! Please vote again: https://www.moddb.com/mods/thief-the-black-parade
      · 0 replies
    • demagogue

      You all ought to check out The Black Parade over on TTLG if you have any heart for our kind of game. It's a grand tribute for the 25th anniversary of Thief TDP.
      · 0 replies
    • stgatilov

      Sometimes when I try to post comment in bugtracker page that I opened days ago, bugtracker says my session is expired and my comment is lost.

      I have discovered plausible workaround. When I see expiration message, I open browser's dev tools, go to network tab and refresh page. Then I select POST request and copy my text from its content.
      · 0 replies
    • nbohr1more

      In addition to voting for TDM, let's help our friend Skacky garner some Moddb recognition for the momentous release of "The Black Parade" https://www.moddb.com/mods/thief-the-black-parade
      · 0 replies
    • peter_spy

      I don't think The Last of Us part I is a good game; it is something else in terms of pure audio-visual experience though. The attention to detail is insane, especially in sound and animation.
      · 6 replies
×
×
  • Create New...