Jump to content
Forum Login Changes ×
The Dark Mod Forums

Changes to map not showing in Dark Mod


Recommended Posts

I have been out of this for four years (cancer, diabetes,COVID) but am trying to RE-learn Dark Radiant, and going back to the mission I started to create back then. But no matter what I add, delete, change in DR it does not show when running the FM! I can see the map file in the map folder under the FM is updating. I have also tried loading it via console, but same problem. Another issue is the dang AAS files. No mater how many time I DMAP it still says out of date. No AAS files show up in the map folder either, which might be why.

Can someone help this old guy out? GRRRR

Link to comment
Share on other sites

That sounds a lot like your map is leaking. Are you getting .lin files being produced? If so, load them in DR and follow the red line to the gap in your geometry.

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

14 hours ago, BlackMagic said:

I have been out of this for four years (cancer, diabetes,COVID) but am trying to RE-learn Dark Radiant, and going back to the mission I started to create back then. But no matter what I add, delete, change in DR it does not show when running the FM! I can see the map file in the map folder under the FM is updating. I have also tried loading it via console, but same problem. Another issue is the dang AAS files. No mater how many time I DMAP it still says out of date. No AAS files show up in the map folder either, which might be why.

Can someone help this old guy out? GRRRR

If dmap doesn't show a leak and there's a leak into the void (a gap in the world into the void or a model origin in the void) that is really strange, too see if is a leak and dmap somehow fails to show it, try to start your map with "devmap mapname.map" instead of using "map mapname.map"  devmap afaik ignores leaks, if the map/mission opens then is a leak.

But the fact that you are having AAS out of date warnings after dmap, sounds like you are opening a old version of the map not the one you dmap a new, perhaps you have DR badly setup and it is saving the fresh maps and files into a different folder than you think? 

Edited by HMart
Link to comment
Share on other sites

Here is the update. HMart; I thought that was the problem, but I searched my drive and found nothing with the same name. But HOW it was loading an older version of the map remains a mystery. And no, there were no lin files being created, or AAS files. Since everything "important" is in it's own level I thought I might just export everything and pull it all into a new map. HOWEVER, after hiding all but default level I remembered this odd looking rectangle brush that went for the lowest to highest point. Had no why idea why I (?) put that there, but deleted it and a few rocks and saved the map. Then for S and grins I reloaded in DM and now every change shows up. YA! BUT, NOW I get dozens of lin files - all on my portals and location items. ALL internal leaks. Dang. Wasn't there a script/tool/method for testing for internal leaks? Anyway, thanks for the help guys! I am plucking away at fixing the >20 leaks (OUCH!) feeling like a numb skull. Still may export it all and restart once cleaned up. BTW I am trying for a mission in Dodge city, Gunsmoke like. Wish I hadn't tossed all my notes (on paper) when it looked like I wasn't going to make 66. (Now 68 and moving on). Thanks again. Oh hey new stuff to put in this dog!

  • Like 2
Link to comment
Share on other sites

Leaky geometry, particularly portal leaks, happen all the time to everyone. Annoying and time-consuming as they are, they're absolutely not a sign of being bad at mapping. I'm looking forward to seeing your mission- I don't think we have any with a Wild West feel yet.

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

My map is definitely loopy. Been exporting each level and cleaning up leaks - most by little holes around angles, some though had missing brushes. I looked at map file in text editor and saw some junk (bits of text,etc). Anyway, got a weird problem with one exported level. Look fine in DR but trying to load into DM it says "bad area model lookup". What does that mean? There was a missing (old style?) grandfather clock model but I removed that. Map file is clean when looking at text editor. Created a new empty map and did a cut and paste into it, still get same message. Any ideas?

Link to comment
Share on other sites

So I created a new bigbox (map) and put all my layers into that, including the "bad area model" one and everything is JUST FINE. No errors, no leaks, no missing bits, in both DR and DM! YAY twice over!! Can now continue working on it (and learning DR - so MUCH to learn). Back to building my faux Dodge.

  • Like 2
Link to comment
Share on other sites

Glad to see you got it working!

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

12 hours ago, BlackMagic said:

So I created a new bigbox (map)

You mean you created sealing geometry from brushes and then put the rest of your work into it? If so, then I am afraid this is no real solution to your problem as the internal leaks will remain resulting in a very slow map if you do not fix the leaks (and prevent future leaks) in your "inner" sealing geometry.

Edited by JackFarmer
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Yes, I started a new map, made my usual Large brush box (with default lighting/etc.) and saved it. Then loaded the box and imported the original layers. Things are fine with each layer, no internal leaks or external leaks. As I have been proceeding, and adding more structure/areas - each in it's own layer I am only having normal(?) blunders as I am trying to re-learn scripting, DEF's, etc. Can't seem to seal any building with transparent windows, and in one new area DM drops two portals but does not say why (no lin files) and throws another out as useless (inside a non leaky building but separating two rooms). Still have a long to-do list, finish town, visportals, add AI, yadda yadda. BTW I downloaded a free to use 3D cowboy hat but it is in obj format. Is there a way to import it in DR? Man, this stuff is time consuming! but loving it.

Link to comment
Share on other sites

5 minutes ago, BlackMagic said:

Yes, I started a new map, made my usual Large brush box (with default lighting/etc.) and saved it. Then loaded the box and imported the original layers. Things are fine with each layer, no internal leaks or external leaks. As I have been proceeding, and adding more structure/areas - each in it's own layer I am only having normal(?) blunders as I am trying to re-learn scripting, DEF's, etc. Can't seem to seal any building with transparent windows, and in one new area DM drops two portals but does not say why (no lin files) and throws another out as useless (inside a non leaky building but separating two rooms). Still have a long to-do list, finish town, visportals, add AI, yadda yadda. BTW I downloaded a free to use 3D cowboy hat but it is in obj format. Is there a way to import it in DR? Man, this stuff is time consuming! but loving it.

I don't think I've ever seen TDM drop a portal without a .lin file.  You sure?

Support for OBJ model format was just added in TDM 2.11.  You can import the model into DR (File -> Import/Convert Model...) or I think you should just be able to place the model in your FM folder (under models/) and DR should see it I think? If you have DR open you will need to use File -> Reload Models...

Link to comment
Share on other sites

If you're using transparent textures, remember they need to be visportaled. A worldspawn brush with transparent textures won't seal. Not sure if this is the cause of the issue you're having, but I remember having trouble with it once.

{ 0 | 🞵 } = funk_tastic

My missions:           Stand-alone                                                      Duncan Lynch series                              

                                      Down and Out on Newford Road              the Factory Heist

                                                                                                  A House Call

                              

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...