Jump to content
The Dark Mod Forums
Sign in to follow this  
Komag

main volume too low, can only change in cfg file

Recommended Posts

After starting using a new DoomConfig.cfg file, I found everything was extremely quiet and I could barely hear anything at all, even after turning up the ambient and sfx volumes to the max in the audio menu in game. So I found

 

seta s_volume_dB

 

in the DoomConfig.cfg, and saw it was set to something like "-29.2734987" or whatever decimal it was.

 

So I set it to "0" and now I can hear again!

 

What's going on here, why was it set so low? And why isn't it controllable via the in-game options menus?


shadowdark50.gif keep50.gif

Share this post


Link to post
Share on other sites

I dunno; my SVN version is set to 0, SL release build is set to 0, and my Thiefs den build is set to 0. It's controllable via Settings -> Audio -> SFX volume slider.


yay seuss crease touss dome in ouss nose tair

Share this post


Link to post
Share on other sites

I just tried it again to confirm.

 

- First, back up your main games\doom3\darkmod\DoomConfig.cfg file

- Then delete the original file.

- Start Dark Mod, if you only see the console, press Esc to see the main menu

- Look in Settings and see the volumes, and notice SFX nearly all the way down!

- Exit Dark Mod without changing the volume

- Look in the folder to see the newly created DoomConfig.cfg file

- Look inside and notice seta s_volume_dB "-29.84127". Why this setting?

- In the Dark Mod menus, turning the volumes all the way up sets it to "0"

 

Anyway, now that I better understand the settings and where they are controlled, this issue is no big deal, so no need to really "fix" anything I guess :)


shadowdark50.gif keep50.gif

Share this post


Link to post
Share on other sites

I haven't even run Doom 3 in years!

 

...checking...

 

Well what do you know, in my games\doom3\base\DoomConfig.cfg file I found:

seta s_volume_dB "-29.84127"

 

Aha! So that's the culprit! I guess I knew dark mod had to regenerate the cfg file starting with some base, but I didn't realize where.

 

That solves that mystery!


shadowdark50.gif keep50.gif

Share this post


Link to post
Share on other sites

Ah! Maybe the config in base is responsible for some other config problems when installing FMs. I need to examine that. When installing an FM, doom creates a new doomconfig in that 'sub-mod' folder. But it differs from the one in the darkmod folder and even from what is currently being used, eg, screen res. Maybe it takes some values from base.

Share this post


Link to post
Share on other sites

That's certainly a good bet, would explain a few things, and opens up a chance to solve some of those pesky problems


shadowdark50.gif keep50.gif

Share this post


Link to post
Share on other sites

Yeah, that could explain those other graphics settings problems people were having when installing SL, maybe it was being read from the base. Does this mean in our next installation instructions, you'll have to run base Doom3 first and set the settings there? Or maybe we could make a base config file as well?

Share this post


Link to post
Share on other sites

I'll put this on the tracker and assign it to me to test the theory when I get time as it is highly relevant to the next start pack.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...