Jump to content
The Dark Mod Forums

Newbie DarkRadiant Questions


Recommended Posts

Does anyone have a working link to any more scripting references please? Specifically I'm hoping to find a syntax description, and a reference list of methods that can be called on sys and any other global entities. Methods on map entities are well documented in the scriptevent wiki reference, but I have no clue how to find out whether it's possible to iterate through the entities in the map by calling a more global function, for example.

 

I've searched this forum for info but all the links I've found go to a defunct modwiki site.

 

Thanks all, Steve

Link to post
Share on other sites
  • Replies 10.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So I have this gigantic scorpion, it is made out of pendulums bound together. I had an idea about dragging whole thing through a piled up crates (pretending to be stone blocks in a wall), but it looks

I'm just going to make the lute player an undead immortal skeleton called Ralph who is eternally bound to play his lute in the tavern, the residents are used to him now so they just happily co-exist a

So I just did a little test because I was curious to know this as well.   So far i've figured out that the mesh we see in the mirror is located as "models\md5\chars\thief\tdm_ai_thief.md5mesh" and if

Posted Images

Does anyone have a working link to any more scripting references please? Specifically I'm hoping to find a syntax description, and a reference list of methods that can be called on sys and any other global entities. Methods on map entities are well documented in the scriptevent wiki reference, but I have no clue how to find out whether it's possible to iterate through the entities in the map by calling a more global function, for example.

 

I've searched this forum for info but all the links I've found go to a defunct modwiki site.

 

Thanks all, Steve

 

I don't know if this will help but have you tried here?

 

http://wiki.thedarkmod.com/index.php?title=Category:Scripting

Link to post
Share on other sites

To partly answer my own question, the defunct modwiki reference for Doom3 sys methods is on archive.org: http://web.archive.o...events_(Doom_3)

 

Not sure how many of the sys events are common to TDM, but I'll find out.

 

Open tdm_base01.pk4. Find script/tdm_events.script.

That contains all TDM script commands.

Clipper

-The mapper's best friend.

Link to post
Share on other sites

Open tdm_base01.pk4. Find script/tdm_events.script.

That contains all TDM script commands.

 

Great stuff, thanks Sotha. Just read it and I can see at least one way to simulate the iteration-through-entities behaviour that I wanted to test.

Link to post
Share on other sites

Some prop entities, like the prop steel, has declared in its entitydef:

"remove_delay" "10000" //destroy after 10 seconds

 

There is never a 10 s delay before the steel is removed. In fact, the steel is removed immediately if the AI carrying it is downed, because the prop has "remove" "1".

 

What does "remove_delay" do and when is it used?

Clipper

-The mapper's best friend.

Link to post
Share on other sites

What does "remove_delay" do and when is it used?

 

If an AI has the steel in his hand and is alerted, he'll drop the steel. The 'remove_delay' is how long it sticks around after being dropped.

 

And that should be "10", not "10000". The code wants seconds, not milliseconds.

  • Like 1
Link to post
Share on other sites

Thanks, g.

 

"remove" "1" removes the attachment when the AI is downed.

"unbind_on_alertindex" (or similar, can't remember exact name) unbinds the item when AI is alerted.

 

Do we have a command that removes item on alert? Sort of "remove_on_alertindex" or "remove_on_unbind?"

Clipper

-The mapper's best friend.

Link to post
Share on other sites

Anyone know how to alter the color and radius of the "playertools_lantern"?

 

Oh and when is forum registration opening again? My friend can't create a user =P

 

 

Edit: Never mind, got it working with the custom.def :)

Edited by Kvorning
Link to post
Share on other sites

Create in your "darkmod" folder, a folder and name it "def", inside that create a text document and rename it to "custom.def".

 

This file can help you control entities you wish to alter, in my case the "atdm:playertools_lantern". When you run "testmap" or "map" from the console, and don't have any FMs installed, TheDarkMod will include the custom.def's values into the standard settings. Same way as you use custom textures, sounds, etc.

 

Example of custom.def:

entityDef atdm:map_of
{
"inherit"   "atdm:map_base"
"editor_usage"  "Map of the area with a few hints."
"inv_name"   "Map of the slums"
"inv_icon"   "guis/assets/game_maps/map_of_slums_icon.tga"
"gui"	 "guis/map_of_slums.gui"
}

Link to post
Share on other sites

What is the best way to handle the following. I have had a playaround in DR for the past hour or so and I couldn't find a solution on my own so I guess I will hassle you poor souls again! (sorry)

 

Anyway I have Object A and Object B and a Door.. I want it so that when Object A (which is a moveable object) touches Object B (it can be a location as well doesn't really matter) it triggers the door to open.

 

Is there a good way to do this that anyone knows about?

 

Thanks in advance!

Link to post
Share on other sites

One way would be to create a new stim and place it on A, then place the corresponding response on B. When A stims B, B's response is to trigger the door.

 

If B is a location, you could create a hidden objective that says "When A is in location B, execute some script function".

 

Or if B is a stationary object, you could wrap B with a location brush entity C and create a hidden objective that says "When A is in location C, execute some script function".

Link to post
Share on other sites

edit: Ok so nevermind the stim/response thing was working it just seems that if I trigger a door that doesn't not.

 

Thanks Grayman!

Edited by Goldwell
Link to post
Share on other sites

Using the response part of the stim/response system how do you damage the player?

 

I have tried the effect damage aimed at "player" but it doesn't seem to work

Edited by Goldwell
Link to post
Share on other sites

Hi guys, a couple of questions on fps:

 

Does the console command showfps show game frame rate or video frame rate? Do we need to worry about both?

 

And if so is there any way to display the other when testing performance?

 

I use a gaming rig so thought I'd better check fps on an old laptop when adding detail.

Link to post
Share on other sites

Using the response part of the stim/response system how do you damage the player?

 

I have tried the effect damage aimed at "player" but it doesn't seem to work

 

I'd like to know this as well. I've been trying to set up a scenario where if the player frobs an item, he takes damage. I set up a model, made it frobable, and then put a frob stim on the model. Where do I put the response? Using the player start doesn't work.

Link to post
Share on other sites

I'd like to know this as well. I've been trying to set up a scenario where if the player frobs an item, he takes damage. I set up a model, made it frobable, and then put a frob stim on the model. Where do I put the response? Using the player start doesn't work.

Create a response to frob with the effect "damage". The target is player1, the damage definition to choose depends on how much damage you want the player to take. You can find the damage entities in the entity browser (under internal/weapon IIRC).

FM's: Builder Roads, Old Habits, Old Habits Rebuild

Mapping and Scripting: Apples and Peaches

Sculptris Models and Tutorials: Obsttortes Models

My wiki articles: Obstipedia

Texture Blending in DR: DR ASE Blend Exporter

Link to post
Share on other sites

How do you get the gas_cloud.prt to spawn correctly once you hit a trigger_once entity?

 

I have tried the func_emitter but it just does not seem to work because even if you use start_off or create a func static and then change the model to gas_cloud.prt the particle just doesn't play.

 

It seems to be that the particle will play out starting from the start of the map. I have tried resetting the func_emitter as well but it just does not work :/

 

Seems to only do this with the gas_cloud as well, other particles work just fine.

Edited by Goldwell
Link to post
Share on other sites

Apparently even trying to spawn a particle in the stim/response doesnt work for it either. Every other particle works except for gas_cloud!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...