Jump to content
The Dark Mod Forums
Sign in to follow this  
Farsead

Leak!

Recommended Posts

Hello. I've been doing Part 1 and 2 of the tutorial.

 

When I dmap, it says there is a leak. But I have made sure that there isn't any gap between the textures where the pointfile is pointing. I've even expanded all the textures into each other just to try.

 

Screenshots:

http://img14.imageshack.us/my.php?image=leak1.jpg

http://img24.imageshack.us/my.php?image=leak2.jpg

 

 

Also, there is a typo in the tutorial. It says that the light inspector is mapped to "J", when it's in fact "L".

Edited by Farsead

Share this post


Link to post
Share on other sites

It's likely that the brush is too thin. I forget the minimum but brushes next to the void have to be a certain minimum thickness. Another common problem is if one of the surfaces of the brush doesn't seal against the void. Even if the outer and inner surfaces are OK, if any of the hidden side surfaces don't seal, eg, nodraw, clip and others I think, decal textures etc. then change them to caulk.

 

The default light inspector key was changed since I did that tutorial. I'll fix it now. Thanks.

Share this post


Link to post
Share on other sites

Sorry, that nodraw, clip and decal textures thing I don't understand. Having just finished 1/3 of the tutorial.

How do I change them to caulk?

Share this post


Link to post
Share on other sites

Select a surface (Ctrl+Shift+LMB I think is default) then click the caulk texture in the Textures tab on the panel where Entity, Media, Console, Textures is. That should add it. If caulk is not there then Select media and look in textures > common. Here you right click it and select 'apply to selection'

 

If you have trouble seeing the hidden surfaces you can either:

 

Move the brush out temporarily and put it back or

hide some of the surrounding stuff by selecting a brush and pressing H or

With larger brushes you can move inside brushes in the camera view.

 

Another quicker alternative might be just select the entire brush (Shift + Alt + LMB I think) then texture it with your inner texture (the one you can see in the game.) In most cases that will do. It won't be rendered on the hidden surfaces. What texture is that BTW?

Share this post


Link to post
Share on other sites

OK, I was a bit rushed before but now I've looked again at your image it looks like the stone used in the tutorial. I think it is more likely that the brush is too thin. I'll see if can find the minimum thickness. Your wall looks like a thickness of 4 units. That might not be enough. Hang on...

Share this post


Link to post
Share on other sites

Thanks, will try what you said.

 

The texture is blocks_mixed_multicolour.

 

 

One other thing. I did the "curtain thing" with the wall where the door is, so that if I hide the door then I can see right through into the other room, in the camera view and grid view.

But when I load the map and open the door, the wall is still there, but I can walk right through it. Any idea what that can be?

Share this post


Link to post
Share on other sites

Funny, I dmapped right down to a wall thickness of 0.125. Yet I'm sure there is a limit.

 

Anyway, looking again at your image it doesn't look grid-snapped. If you select your left wall and then Ctrl+G to grid snap it you should see it snap tight to the grid lines. If do that the top wall then it will likely disappear because it is smaller than the grid. So first drag it from above to enlarge it upwards (in that view) and then Ctrl+G. I'll try to put up a diagram in a few minutes.

Share this post


Link to post
Share on other sites
Thanks, will try what you said.

 

The texture is blocks_mixed_multicolour.

 

 

One other thing. I did the "curtain thing" with the wall where the door is, so that if I hide the door then I can see right through into the other room, in the camera view and grid view.

But when I load the map and open the door, the wall is still there, but I can walk right through it. Any idea what that can be?

 

Yes, it is most likely because of the leak the dmap failed so you are still seeing the original wall. It will disappear when we fix the leak. :)

Share this post


Link to post
Share on other sites

Clumsily, I deleted the room to make a brand new one instead and see if it worked. I quicksaved though, and don't have any backup of the previous room.

 

The "leak" problem occurred when I moved each individual part of the old room from a position that was too far away from the small room.

 

But now when I've constructed a by-the-book room in the right place, there is still a leak. Screenshot asap.

Share this post


Link to post
Share on other sites

Yes, your grid size looks to be about 8 which is reasonable. Always aim for the largest (within reason) you can and then only go small where detail is essential. Basically you need to have one large grid size and make most of the brushes align to it and then they will align with each other nicely.

 

But it looks like you might have made the walls when the grid was smaller and then later changed it? So they don't align. So if you now grid snap while the grid is 8 it should look more like this, neatly on the grid lines...

 

post-400-1240223191_thumb.jpg

 

When you drag out a brush or move or resize it then it always automatically aligns to the current grid. But if that grid is small and then you later make it larger and make other brushes then they won't align well with each other. So try to remember, if you reduce the grid small, eg, to move a model about or make a very thin brush for some trim, then remember to enlarge the grid back for your main build. So if you are using 8 or 16 for your main terrain then stick to that and keep going back to it if you temporarily resize the grid for something special.

 

Let me know if that fixes the leak.

Share this post


Link to post
Share on other sites
Clumsily, I deleted the room to make a brand new one instead and see if it worked. I quicksaved though, and don't have any backup of the previous room.

 

The "leak" problem occurred when I moved each individual part of the old room from a position that was too far away from the small room.

 

But now when I've constructed a by-the-book room in the right place, there is still a leak. Screenshot asap.

 

OK, well it's a learning process.

Share this post


Link to post
Share on other sites

Indeed, I changed the grid size around. That must have been the problem.

 

Although, now I made a room entirely within 8 grid setting, and precisely according to the tutorial. But there is still a leak.

 

http://img4.imageshack.us/my.php?image=leak1.jpg

http://img4.imageshack.us/my.php?image=leak2.jpg

 

I also snapped the surfaces to the grid, just to be sure, but the pointfile is still there.

 

EDIT: Also retextured every brush, but that didn't solve it. And using "caulk" didn't show anything hidden. Just a plain color background and the word "caulk".

Edited by Farsead

Share this post


Link to post
Share on other sites

OK, that's much neater and reliable.

 

So now check the textures. First, as a test, change the texture of the entire brushes to say stone. That is, select the entire brush not just one surface, and set it to stone. Both those brushes. If that fixes it then just change the internal surface to what you want and dmap again.

Share this post


Link to post
Share on other sites

Changing the brushes entirely to another texture didn't solve it, I'm afraid. :-/

Edited by Farsead

Share this post


Link to post
Share on other sites

Thanks, that did it.

 

I never thought to look there either, as I thought that the red pointer showed the exact path of the leak.

Thanks for your patience.

Share this post


Link to post
Share on other sites
I thought that the red pointer showed the exact path of the leak.
It normally does. Did you reload the point file after dmapping again? Or maybe the old one wasn't overwritten for some reason.

Share this post


Link to post
Share on other sites

If you change brushwork you have to run dmap on the new map file (the pointfile is created by doom3 not the editor).

Share this post


Link to post
Share on other sites

I understand. Now it works flawlessly.

 

 

EDIT: Maybe should add it to the tutorial, since it isn't apparent, for a person with no background in level-making, that the pointfile is renewed after dmapping. I didn't think "pointfile" in "File" was a switch, but that it itself checked for leaks.

 

Just a thought.

Edited by Farsead

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...