Jump to content
The Dark Mod Forums

ced2011

Member
  • Content Count

    8
  • Joined

  • Last visited

Everything posted by ced2011

  1. I see! Thankfully I seem to have fixed the issue. It seemed to occur because I forgot to save private declarations defined in playerview header file. Again, I'm not finished with this file, but it's not crashing anymore since I fixed that, so I'm going to assume there's where the error originated. Next time I'm in trouble, I now know where to ask for some help Thank you all!
  2. OK guys so I managed to get the code "cleaned" by just getting it again to its original state (replacing all of my current c++ files and the header files by the originals) and then simply start re-replacing those again with my own code, file by file... It all went smoothly and with no errors and almost ALL of my code works perfect, however I left the most complex files for the end, which are the weapon.cpp, player.cpp and playerview.cpp, I don't think I even need to explain what those contain. Here's the thing, MOST of the changes and features I've added are located in those three files, mostl
  3. Hmm ok so the output showed this warning which got me even more confused Where should I look at? First-chance exception at 0x7755b4df in STAR1088.exe: 0xC0000005: Access violation reading location 0x00000000. Unhandled exception at 0x7755b4df in STAR1088.exe: 0xC0000005: Access violation reading location 0x00000000. Is that it? Is that actually telling me where the error is or it's only a tiny fraction of an entire whole lot of bad code? Edit: I'm getting this when stopping debug mode: The program '[6104] STAR1088.exe: Native' has exited with code -1073741819 (0xc0000005). I've checke
  4. Thanks man, no worries about being helpful or not, it's always nice to see people who likes your work @stgatilov My problem is, I don't know how to use the debugger. I seem to be doing it wrong For what I've seen you seem to have quite a lot more experience than I do, would building the project under "debug" settings help in any way? I'm asking this because I get fatal errors everywhere when trying to compile under debug settings. Some projects will build but the .exe and the .dll projects won't, which are the ones that are most important here. I've tried to debug the current ones under "De
  5. If I didn't do it wrong, apparently it's not showing any errors other than the execution codes and the files that were loaded during the execution. As you can tell all of this is pretty "new" for me since I've only been using visual studio to go straight to the point, adding features. I have to confess I do not know the VS C++ environment very well. If you could be a little bit more precise as of how I could get it to run under the debugger I would pretty much appreciate it! Freyk, I really have no idea when or where the issue started as I've been coding on and off for some time now, but I h
  6. Do you know how those dump files can be opened? I have VC 2010 which opened it by default, however there didn't seem to be any useful information. Trying to open it with text editors is simply useless. I'll try and upload a zip with the dump file in it, maybe somebody will go ahead and take a look at it. Thanks a lot man
  7. Thanks man, I've tried but nothing appears to be wrong in the dumped files. No warnings that could even hint an error, missing lines or unrecognized code. Using loadgame actually leads to a crash too. Thank you for your pointers and believe me I did try, but still no luck
  8. Hello guys. First off let me apologize for my post here, as you can tell I'm new to the forums. If this is not the correct section to post, feel free to move it to where it belongs. I'm the creator of the CED Assets pack for Doom 3, hopefully some of you here may know about it. I'm also currently developing the S.T.A.R. 1088 campaign for Doom 3. But the problem is as follows: I don't know why the game crashes (it simply becomes not responsive, no warnings or crash messages whatsoever) when I try to load a previously saved game. It seems to be caused by my mod's dll, since when using stock
×
×
  • Create New...