Jump to content


Photo

No Sound on Ubuntu 17.10


  • Please log in to reply
3 replies to this topic

#1 GilGiy

GilGiy

    Member

  • Member
  • PipPip
  • 18 posts

Posted 20 April 2018 - 03:28 PM

So I am running Ubuntu 17.10 (Pop!_OS) and the sound is not working. I've seen lots of discussions on this topic but none of the solutions have worked for me.

 

Here's a small section of the output when I run ./thedarkmod.x86

dlopen(libasound.so.2)
asoundlib version: 1.1.3
Alsa is available
------ Alsa Sound Initialization -----
ALSA lib conf.c:3523:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM sysdefault:CARD=0
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'sysdefault:CARD=0' failed: No such file or directory
dlclose
WARNING:sound subsystem disabled
--------------------------------------
----------- Alsa Shutdown ------------
--------------------------------------

Here's the output when I run aplay -l

gilbert@gilbertyoder:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And here is a few possibly relevant snippets from the Darkmod.cfg file

seta s_dsp "/dev/dsp"
seta s_driver "best"
seta s_alsa_underrun_extrafill "1024"
seta s_alsa_lib "libasound.so.2"
seta s_alsa_pcm "sysdefault:CARD=0"

Any help would be greatly appreciated!


Edited by GilGiy, 20 April 2018 - 03:30 PM.


#2 freyk

freyk

    Advanced Member

  • Member
  • PipPipPip
  • 701 posts

Posted 21 April 2018 - 03:56 AM

Any Help? ok. But I dont have any experience on this one.
Please let us know which sollution worked for you.
 
Error: "ALSA lib conf.c:3523:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so"
People say install package "libasound2-plugins:i386", but your running the x86 binary.

Some topics on tdm and wiki (if you havent read them)
tdm wiki: http://wiki.thedarkm...ind_the_picture
http://forums.thedar...system-on-linux
http://forums.thedar...u-1604/?hl=alsa
http://forums.thedar...-on-ubuntu-1404
tdm Search function with subject alsa: http://forums.thedar...arch_app=forums

Some sollutions to be found here:
https://www.google.c...h?q=doom 3 alsa
People say use the "oss" sound driver.
https://forums.gento...1a3f82935fe67c1
http://zerowing.idso...f54ac0ae8bafe17

Edited by freyk, 21 April 2018 - 04:34 AM.

  • GilGiy likes this

#3 GilGiy

GilGiy

    Member

  • Member
  • PipPip
  • 18 posts

Posted 21 April 2018 - 09:17 AM

Error: "ALSA lib conf.c:3523:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so"
People say install package "libasound2-plugins:i386", but your running the x86 binary.

 

Installing the package "libasound2-plugins:i386" and rebooting fixed the problem!

apt install libasound2-plugins:i386

Thanks a bunch!

 

Update:

 

So after I solved the problem above, I connected my Bluetooth headphones (Sony MDR-XB950BT) and started the game--and the sound played through my laptop speakers...

 

So I changed the line in Darkmod.cfg from:

seta s_alsa_pcm "sysdefault:CARD=PCH"

to:

seta s_alsa_pcm "default"

(it may be set that way by default I'm not sure since I had done quite a bit of messing around before I posted to the forum)

 

and now it plays through my bluetooth headphones...

 

 

Its kind of strange but I lack the ability to change the volume after I have started the game, If someone had a fix for that that would be awesome, but for now I'm good since I can control the volume of my headphones...


Edited by GilGiy, 21 April 2018 - 10:38 PM.


#4 OrbWeaver

OrbWeaver

    Mod hero

  • Active Developer
  • PipPipPipPipPip
  • 7516 posts

Posted 23 April 2018 - 04:29 AM

To give some background context on this (based on my own understanding, although I am not an expert by any means): the libasound_module_conf_pulse.so plugin is a compatibility tool that allows ALSA-only applications (like TDM/Doom 3) to interact with modern distributions which use PulseAudio as their audio server (which is pretty much all of them at this point, I believe). The ALSA application opens the ALSA device in the normal way, and this plugin then redirects the audio to the PulseAudio server which of course is using the "real" ALSA devices as its own backend.

 

If this plugin works on your system, it should in theory allow you to control the volume of the application via the normal PulseAudio control panels, as well as redirecting it to a particular sound device. If you can't get it to work, then configuring the game to directly use the low-level ALSA devices is an alternative, but you may in this case need to temporarily disable the PulseAudio server with a tool like pasuspender in order to make the low-level device available for use by another application.

 

The ideal 2018 solution would be to add PulseAudio support directly into the game so that it could work flawlessly on modern distributions, but that would require someone with sufficient expertise to work on implementing it.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users