Jump to content
The Dark Mod Forums
Sign in to follow this  
RamBurner

Solved audio lag Linux Mint 15 64bit

Recommended Posts

I found that when I made these changes to the Darkmod.cfg file my sound was fine in Linux Mint 15 64bit with MATE

 

seta s_driver "best"
seta s_alsa_lib "libasound.so.2"
seta s_alsa_pcm "sysdefault"

  • Like 2

Share this post


Link to post
Share on other sites

If I use "sysdefault" for the s_alsa_pcm instead of "default", I have no audio.

 

I'm with Ubuntu 13.04 32 bit LTS.

Share this post


Link to post
Share on other sites

Ladro, even though Linux Mint is Ubuntu based there are differences between the two, some of them are great differences.

This works for Linux Mint 15 64bit with MATE,

That is unfortunate that the audio lag problem continues while using Ubuntu 13.04 32bit LTS

You need to keep experimenting with different things until one works.

Share this post


Link to post
Share on other sites

Normally I killed Pulseaudio (you have to kill autospawn too), and I used Alsa instead.

But now I use an external sound card USB (soundblaster creative), and now Alsa in TDM it's not working unfortunately with this external device (i have no sound at all in TDM with pure Alsa). He works only with PulseAudio active, but I have random glichy or lag, that I can repair on fly only by exiting to the main menu, and change left with right option ("yes" or "not").

 

I'll do more tests, that's sure, I hope to find a solution :-D

Share this post


Link to post
Share on other sites

Here's mine, from Mageia 3

 

seta s_dsp "/dev/dsp0"
seta s_driver "best"
seta s_alsa_lib "libasound.so.2"
seta s_alsa_pcm "front:CARD=halo,DEV=0" ***This one may be the critical one for performance, I do not remember, maybe needs to be in combo with other settings.***
seta s_libOpenAL "openal32.dll"
seta s_numberOfSpeakers "2" ***This can be very important if you leave pulseaudio enabled.
It must match your enabled speaker configuration.
If you change your card to 5.1 output, then number of speakers needs to be 6 AND the part of 's_alsa_pcm' setting which says 'front: ' needs to change to something like 'Surround5.1: ', though I will have to verify that.***

 

When I changed that 's_alsa_pcm' from 'default' to my named audio device*, I was able to leave pulseaudio alone and still have proper sound in TDM. *Though I have since set 'pasuspender' in my TDM launch path. I did have it working well without killing pulseaudio though.

 

* Use 'aplay --list-devices' to get your list of audio devices.

Mine is listed as:

card 0: halo [HT-Omega Claro halo], device 0: Multichannel [Multichannel]
 Subdevices: 1/1
 Subdevice #0: subdevice #0

So, the name of the card is what follows the card #... 'halo' in this case. The DEV setting is obviously the 'device' number.

 

...and the rest of the sound related stuff in my config:

seta s_doorDistanceAdd "450"
seta s_globalFraction "0.8"
seta s_subFraction "0.75"
seta s_playDefaultSound "1"
seta s_volume_dB "0"
seta s_meterTopTime "2000"
seta s_reverse "0"
seta s_spatializationDecay "2"
seta s_maxSoundsPerShader "0"

Edited by PranQster

Linux pranqster 5.6.3-desktop-2.mga8 #1 SMP Sat Apr 11 14:38:22 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Share this post


Link to post
Share on other sites

I've tried with these (and other) settings, but nothing changed.

 

My card it's marked "dev=MP3,DEV=0", I tried also with "front", "hw:", etc etc, in the "s_alsa_pcm" var, and a lot of other combinations, but nothing.

 

Anyway, i'll try more and more to solve this, there must be a solution B)

Share this post


Link to post
Share on other sites

Just adding that it works exactly the same in Linux Mint 15 with Cinnamon. Thanks a bunch! I'm new to the game, and learning to lock pick is much, much easier with audio cues. =)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...