Jump to content
The Dark Mod Forums

wrong screen with multiple screens


Recommended Posts

I have two screens, one bigger and one smaller. Unfortunately my hardware selects the smaller one as the primary one, which seems to translate over into some full screen applications, which then always run on the smaller screen (which uses DVI, as opposed to the larger screnn which uses HDMI).

This is the case for TDM. I have taken a look through the Darkmod.cfg, but there seems to be no way to set a preferred screen or something like that.

Is there any way to specify which monitor I want to play TDM on?

 

I've got an NVidia GeForce GTS 250 and am playing on Debian testing.

Selecting a primary display in the NVidia X Server Settings doesn't help.

If my English is bad I am very sorry. It's not my mother tongue.

Link to post
Share on other sites

Sounds to me like you are having a general issue with Windows deteting your primary display.

First of all, go to the Windows control panel ('Display' -> 'Resolution') and swap primary and secondary display there.

That screen should show your 2 displays. Take note that this screen also allows you to drag the displays to the correct location (whether the primary is on the left or right)!

 

If that doesn't help, run TDM in windowed mode and move it manually to the correct screen.

Then maximize it again. Windows should now recall your preference whenever you are launching TDM or other stuff (assuming both displays are ON all the time).

Link to post
Share on other sites

I'm on Debian, not Windows. Setting the primary display doesn't accomplish anything.

TDM captures the mouse in windowed mode, so I cannot move the window. Starting TDM already windowed on the right display and then switching to fullscreen doesn't work either – the larger display is switched off as soon as TDM starts in fullscreen mode.

If my English is bad I am very sorry. It's not my mother tongue.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...