Jump to content
The Dark Mod Forums

Recommended Posts

Building current master on arch linux, I get this:

 

../../include/iscript.h:7:28: error: using typedef-name ‘using module = class pybind11::module_’ after ‘class’
    7 | namespace pybind11 { class module; class dict; }
      |                            ^~~~~~
In file included from ScriptingSystem.h:5,
                 from ScriptingSystem.cpp:1:
/usr/include/pybind11/pybind11.h:1017:7: note: ‘using module = class pybind11::module_’ has a previous declaration here
 1017 | using module = module_;
      |       ^~~~~~

 

Link to post
Share on other sites

Hm, you must be using a more recent version of pybind11, do you know which version this is?

edit: Nevermind, I can see it in their git commits from September 2020, they renamed the class pybind11::module to class pybind11::module_ and added the using alias, but this is of course breaking the forward declaration in the iscript.h header. That's affecting pybind11 version 2.6.0+.

Would it be possible for you to open an issue on the bugtracker, please?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...