Jump to content


Photo

RenderCrop?


5 replies to this topic

#1 Zinski

Zinski

    Member

  • Member
  • PipPip
  • 17 posts

Posted 10 March 2010 - 02:12 AM

Anyone know what the following means (it has been preventing me from testing my maps despite me deleting almost everything within the map):

ERROR: IdRenderSystemLocal ::UnCrop: current RenderCrop <1



#2 greebo

greebo

    Heroic Coder

  • Root
  • 16053 posts

Posted 10 March 2010 - 03:08 AM

Are you using the testmap console command or separate dmap+map commands?

#3 Zinski

Zinski

    Member

  • Member
  • PipPip
  • 17 posts

Posted 10 March 2010 - 04:27 AM

Happens on both

#4 greebo

greebo

    Heroic Coder

  • Root
  • 16053 posts

Posted 10 March 2010 - 04:28 AM

Any chance you're running a sunbelt/kerios firewall?

There have been other users reporting the same in the past, so using the forum search might give you some additional input.

#5 Zinski

Zinski

    Member

  • Member
  • PipPip
  • 17 posts

Posted 10 March 2010 - 10:25 AM

Okay, I'll have a look, cheers.



#6 J.C.Denton

J.C.Denton

    Member

  • Member
  • PipPip
  • 197 posts

Posted 11 March 2010 - 05:25 AM

Anyone know what the following means (it has been preventing me from testing my maps despite me deleting almost everything within the map):

ERROR: IdRenderSystemLocal ::UnCrop: current RenderCrop <1



This is usually due to wrong use of renderSystem->CropRenderSize function in the code itself. If in your code, you are using a renderSystem->CropRenderSize then there must be one renderSystem->uncrop called for every CropRenderSize used. It's like nesting brackets, e.g. for every opening bracket you need a closing bracket.

Have you compiled code on your own? If so, make sure the code is in complete sync with SVN.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users