Jump to content
The Dark Mod Forums
Sign in to follow this  
mips

[Solved]Bad performance?

Recommended Posts

Ok running this on a fresh manjaro 64-bit install, GPU=GTX960, CPU=i5-4690, RAM=8GB, nVidia Drivers=346.35-1, 1920x1080 native res, running game in fullscreen with everything set on minimum settings.

 

Getting 50-60fps but feels very jerky. I set the nividia control panel powemiser for maximum performance but I doubt my gpu is even working hard as the fans don't even switch on. I looked at the wiki for performance tweaks and I can't see anything wrong. I installed following this guide http://www.thedarkmod.com/download-the-mod/

 

Surely I should have smooth gfx & high fps? I've been playing tears of st lucia and I got so engrossed in the game I had not realised an hour had passed before a guard offed me :)

 

Please let me know whatever info I can supply that would be of help to you.

Edited by mips

Share this post


Link to post
Share on other sites

First I'd try to disable threaded optimization in the nvidia control panel. Enabling VSYNC and Triple Buffering also used to work wonders for me on my older card, so it might be worth a try.

Share this post


Link to post
Share on other sites

First I'd try to disable threaded optimization in the nvidia control panel.

 

I can find any reference to such an option anywhere. Same goes for triple buffering. Only option I can find is sync to vblank.

Edited by mips

Share this post


Link to post
Share on other sites

Here's an article about Thread Optimization. It may be off by default in your distro:

 

http://www.phoronix.com/scan.php?page=article&item=nvidia_threaded_opts


Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Share this post


Link to post
Share on other sites

Thanks, I'll look at those tomorrow, off to sleep now.

 

What I did was disable "Allow Flipping" in nvidia control centre, left Sync to VBlank on, left powermiser on max. Set everything in TDM to max but left post processing disabled, vsync enabled and now the game sticks to 58/59FPS (fps counter flashes between those to values), game is smooth and no jerkiness, so looking good!

 

The Allow Flipping stuffs things up if I enable it again dropping the fps and jerkiness is back. So people might wanna keep this in mind. From my understanding this feature swaps between buffers. So this will stay disabled for now.

 

I'll look at those other links tomorrow and see how it compares to my config.

 

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

If one enables "Allow Flipping" and enable Triple Buffering in the xorg.conf the game is also smooth ( with vsync on)

 

Trying to figure out how to see the current status of threaded optimisation, will carry on looking. It's probably off by default as it looks like it's still not ready for prime time.

Edited by mips

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...