Jump to content
The Dark Mod Forums

Mouse stuck in upper left corner


Recommended Posts

After a long hiatus, I decided to try Dark Mod again to check out any new missions, and installed the latest Linux 64-bit version into my home directory. Upon running the game, the menu shows up, but whenever I try to move the mouse, it moves into the upper left corner and stays there. Since I can't access any menu entries, I have to tab out and kill the process after I've managed to sort my display again (it defaults to 800x600 and makes that my desktop resolution as well). Any ideas what's causing this? It's a fresh install, so any old config files shouldn't affect it, unless something's buried deep in .local or .config...

  • Like 1
Link to post
Share on other sites

Pretty strange...

Are you using an accelerated Desktop? If so, are you able to test with a non-accelerated variant?

Are you using a non-standard DPI?

Did you try disabling mouse acceleration in Darkmod.cfg ?

Did you try setting the display to Windowed in Darkmod.cfg?

Please visit TDM's IndieDB site and help promote the mod:

 

http://www.indiedb.com/mods/the-dark-mod

 

(Yeah, shameless promotion... but traffic is traffic folks...)

Link to post
Share on other sites

Figured it out - my old mouse broke down some time ago, and my replacement mouse was too fast for my taste with the defaults, so I had put this in my .xinputrc to slow it down:

xinput --set-prop "Logitech USB-PS/2 Optical Mouse" "Coordinate Transformation Matrix" 1 0 0 0 1 0 0 0 1.5

Commenting this out fixed the menu, but it would leave the mouse too fast on the desktop. I can run it in Wine since I have it installed anyway, so maybe I'll use the Windows version until I figure out why TDM is the only program where this seems to happen.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...