Jump to content
The Dark Mod Forums
Sign in to follow this  

Recommended Posts

how do i add a property in the entity inspector

 

how do i make a regular Func_door ( I tried dragging out a brush then right clicking it and clicking "ADD ENTITY" nothing happened)then ( I tried, with no brushes or items selected, right click and click "ADD ENTITY" a warning popped up saying "cant make entity no brush selected"

 

I hope there are plans on a create button.

 

I just now found the “ALL PROPERTIES” button. So I guess I can add properties, but I would really love to have the USAGE that is available in doom edit. Not just the block that says usage but they have lots of in_entity documentation that would be nice to have while you are working with KEY-and-VALUE stuff…

 

And you already are planning on MEDIA button but what about a CREATE button.

 

I just tried to put KEY=delay VALUE 1 (second) on a trigger relay and as soon as I finished it said unrecognized property and locked up the program.

Share this post


Link to post
Share on other sites
how do i add a property in the entity inspector

 

The entity inspector works differently to the DoomEdit version, and more like the Thief/Dromed system. The idea is that all standard properties are available in the existing list, which allows a different GUI to be used for different types of property (text, vector, texture etc). You can add properties manually using All Properties but any standard properties that are missing (and there are plenty) should be posted in this forum so that they can be added to the list.

 

how do i make a regular Func_door ( I tried dragging out a brush then right clicking it and clicking "ADD ENTITY" nothing happened)then ( I tried, with no brushes or items selected, right click and click "ADD ENTITY" a warning popped up saying "cant make entity no brush selected"

 

You are correct, attempting to turn a brush into a func_door seems to have no effect (the entity is created, but the door is not generated from the brush). Investigating.

 

I hope there are plans on a create button.

 

A create button where, to do what? Please be more specific as to what you are requesting.

 

I just now found the “ALL PROPERTIES” button. So I guess I can add properties, but I would really love to have the USAGE that is available in doom edit. Not just the block that says usage but they have lots of in_entity documentation that would be nice to have while you are working with KEY-and-VALUE stuff…

 

Yes, adding the usage information is on the todo list.

 

I just tried to put KEY=delay VALUE 1 (second) on a trigger relay and as soon as I finished it said unrecognized property and locked up the program.

 

Is this using the All Properties dialog? I tried this and it works fine, the "unrecognised properties" line is a warning and does not crash the program. Did you do anything else before the program crashed?

Share this post


Link to post
Share on other sites

::common brown barn spider:::orb

 

actualy i was creating a trigger_relay just as i was typing so i could get myself strait. to see if i was typing something i should have looked harder to figure out myself

when i finished adding the property delay 1 it locked up the entire program. i had troubel closing it for a few minutes. getting xp to dump it ...

 

also when i refered to the CREAT button i meant the button on the enity inpector in doom3 edit. it allows a selected brush to be converted to whatever entity class that apears in the dropdown menu when you press it

 

clear yes or no

Share this post


Link to post
Share on other sites
also when i refered to the CREAT button i meant the button on the enity inpector in doom3 edit. it allows a selected brush to be converted to whatever entity class that apears in the dropdown menu when you press it

 

clear yes or no

 

I think our right click menu will do the same thing once it's working properly. It would be redundant to have both. We don't want to necessarily recreate doomedit here, but rather borrow some ideas from it and make them better.

Share this post


Link to post
Share on other sites
::common brown barn spider:::orb

 

Heh, there's more than one species, Argiope probably being the most interesting.

 

actualy i was creating a trigger_relay just as i was typing so i could get myself strait. to see if i was typing something i should have looked harder to figure out myself

when i finished adding the property delay 1 it locked up the entire program. i had troubel closing it for a few minutes. getting xp to dump it ...

 

I suspect what happened is that the All Properties dialog got hidden behind one of the other windows, giving the illusion that the program had crashed when in fact the application was just waiting for the dialog to close. I haven't yet found a solution to this problem which works reliably across both Linux and Windows.

 

also when i refered to the CREAT button i meant the button on the enity inpector in doom3 edit. it allows a selected brush to be converted to whatever entity class that apears in the dropdown menu when you press it

clear yes or no

 

I see what you mean. I don't actually remember such as function in DoomEdit, suggesting that I never found cause to use it. As New Horizon said, this function will be handled by the right-click Create Entity dialog rather than as a separate button on the Entity Inspector.

Share this post


Link to post
Share on other sites

ORB (the entity is created, but the door is not generated from the brush).

 

 

 

in my func_door nothing happened. the entity was not created

 

but what I figured out is that if i make a FUNC_STATIC and then change the class in the entity inspector to func_door i can make a func_door...

 

i think the original doom people must have done doors this way because I found on alphalabs1 ( i think it was that) the entrance door umbodoorbottom.lwo bottom part of the door team a1_entrance had a class of FUNC_DOOR and it had a name of FUNC_STATIC_4214. so i believe this door in doom must have started out as a static. while the rest of the door in team a1_entrance had names that were class appropriate

Share this post


Link to post
Share on other sites

i know you arent trying to copy doom edit but

 

but

 

I think you guys should totaly rewire the way entities are created just a little

They should ALWAYS replace the brush that is selected: not more than one brush.

because neither top, side, or front view can pinpoint a location by itself. The entity should appear at the center of where the selected brush was.

 

Also if you drag out a brush so you can make a func_door doomedit will automatically give it a model name that matches the entity name the entity name tells doomedit to use the brush as the model. Or something like that .

Your automated ADD_ENTITY button may (and I am guessing) may not have the bit about giving the entity a model that matches the brush. Of-course it doesn’t because it doesn’t call for a brush to be used so there is no brush model associated with your automated ADD_ENTITY Button thingy…

 

So why not have the thing call for a brush to be created and selected first. Then you get to know exactly where the model goes. And you get a automatic brush model and model name.

 

1 Drag out brush

2 Select ----brush

3 Right-Click orthographic view ------click MAKE_ ENTITY icon on the fly-out menu.

4 Chose entity class

5 If necessary change the model

 

What do you think?

Share this post


Link to post
Share on other sites
1 Drag out brush

2 Select ----brush

3 Right-Click orthographic view ------click MAKE_ ENTITY icon on the fly-out menu.

4 Chose entity class

5 If necessary change the model

 

What do you think?

 

That's what it's supposed to do, but there seems to be a problem. Orb is looking into it.

Share this post


Link to post
Share on other sites

Yep, it is a bug and it looks like it was introduced when I completely rewrote the entityDef parsing code to support our "atdm:" prefix. In vanilla GtkRadiant you can create a func_door with a brush as its child, whereas in DarkRadiant the brush remains a child of the worldspawn and the func_door entity has no children (making it useless and unselectable).

Share this post


Link to post
Share on other sites

All I meant was that because your automated entity placement doesn’t use the original brush there is no brush model for the func_door command to refer to. It needs a model. It would use the brush model but since there isn’t one ...how can it

 

Maybe I am totally wrong but I think if you tried to do any of the func_x that would normally use the brush as the model you will find that none of them work but do when there is a model

 

 

 

func door works if you start it out as a static model then change its entity class.

 

Func_penulum doesn’t work either ... ... unless...you start it out as a static.

 

deduction says there is a problem where it tries to find the model name or rename the brush or find the model name

 

maybe it expects a name there and you haven’t coded for the brush to get a model name normally what happens is the brush gets a entity name then it also gets a model name that the same as the entity name

 

1 makes a brush

2 change the brush to and entity

3 the brush gets an entity name

4 the brush gets a model if it is not chosen already it uses the entity name and uses the brush model for shape and texture.

 

Does your code call for the brush to become and entity to be assigned a name to put that name in the "MODEL" value?

 

if not I would guess where the problem is somewhere in the naming of the brush, entity, or model

 

But I don’t know anything about programming

 

I wonder is any of my guessing helpful or just annoying...sorry if it is annoying

Share this post


Link to post
Share on other sites
All I meant was that because your automated entity placement doesn’t use the original brush there is no brush model for the func_door command to refer to. It needs a model. It would use the brush model but since there isn’t one ...how can it

 

Maybe I am totally wrong but I think if you tried to do any of the func_x that would normally use the brush as the model you will find that none of them work but do when there is a model

 

You are more or less right, the selected brush should be added as a child of the func_door, but this is not happening. It is not just a problem with the naming, but with the child/parent relationship that is maintained by DarkRadiant (all brushes have to be children of an entity, usually this is worldspawn but it can be func_static, func_door and others).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...