Jump to content


Photo

Fan Missions stop loading and go back to menu [solved]


  • Please log in to reply
81 replies to this topic

#76 Anderson

Anderson

    Advanced Member

  • Member
  • PipPipPip
  • 1119 posts

Posted 02 June 2018 - 12:40 PM

Oh please, could I have a condump taken after mission load failed?

Attached Files


  • stgatilov likes this

 "I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

 

 

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

 


#77 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1119 posts

Posted 02 June 2018 - 12:55 PM

Great!

 

Here are your calls:

alBufferData: 261 2 7BAFC066 8820 22050
alBufferData: 262 1 27CBD3C2 10000 22050
alBufferData: 263 1 1B8C3CE4 13145 22050

Here are my calls:

alBufferData: 261 2 C4C3EC82 17640 44100
alBufferData: 262 1 D7C91279 20000 44100
alBufferData: 263 1 4313D51E 26290 44100

The last argument is frequency, the prelast is size of buffer in bytes, which must be even.

As you see, on my config all files have 44100 Hz frequency.

But on your config all files have 22050 Hz frequency, and all their lengths are halved.

As a result, the third wav file has 13145 bytes of data (which must be even) --- this is an error.

 

Now this gets much more clear.

Hardware and drivers are not culprit, this is a TDM bug I think.

We need some configuration guru to tell us why the samples are at 22Khz on your machine  :D

If we force back 44100 Hz frequenceyof wav sounds, the problem should disappear.

 

I'll go to sleep for now  <_<


  • Anderson likes this

#78 Anderson

Anderson

    Advanced Member

  • Member
  • PipPipPip
  • 1119 posts

Posted 02 June 2018 - 01:13 PM

No pressure. Time zones can't be changed. Health is more important.


 "I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

 

 

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

 


#79 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1119 posts

Posted 02 June 2018 - 10:20 PM

Ok, I think s_force22kHz is enabled somewhere, but strangely not in darkmod.cfg.

Check the autoexec.cfg file.

In fact, having autoexec.cfg is not a good idea at all, especially for setting cvars: all of them can be set in darkmod.cfg.

 

Anyway, find and remove seta s_force22kHz "1" line.

 

UPDATE: created issue 4814

Thank you very much for your patience!


  • Anderson likes this

#80 Anderson

Anderson

    Advanced Member

  • Member
  • PipPipPip
  • 1119 posts

Posted 03 June 2018 - 03:38 AM

Ok, I think s_force22kHz is enabled somewhere, but strangely not in darkmod.cfg.

Check the autoexec.cfg file.

In fact, having autoexec.cfg is not a good idea at all, especially for setting cvars: all of them can be set in darkmod.cfg.

 

Anyway, find and remove seta s_force22kHz "1" line.

 

UPDATE: created issue 4814

Thank you very much for your patience!

Wow, thank you very much. Now FM's work! Sorry that I disturbed you with this.

 

One last question if I may - how to bring back the light from torches and other light sources? I want to restore graphics to default TDM settings, because in the beginning we were tweaking everything related to display/graphics settings all over the place.


 "I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

 

 

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

 


#81 stgatilov

stgatilov

    Lead Programmer

  • Active Developer
  • PipPipPip
  • 1119 posts

Posted 03 June 2018 - 03:49 AM

For cleaning up, the best idea would be to delete everything which was hacked on and start from scratch  :D

I mean: remove both TheDarkMod executables, both ExtLibs dlls, the file alsoft.ini.

Then backup your darkmod.cfg and delete it too.

Run tdm_update and then the game itself --- after that you'll have fresh 2.06 installation.

Then open the backup-ed darkmod.cfg and copy whatever you want from, mainly key bindings (all the lines starting with "bind").

 

The less clean approach would be to review all the posts in this topic and check if the corresponding modification is still present.

If yes, then restore it to original state.

Most importantly, revert all changes to cvars starting with "r_".

 

BTW, you need the modified shaders for shadows to render properly.

The ready-to-use archive was provided in this post --- maybe you should start with this.


  • Anderson likes this

#82 Anderson

Anderson

    Advanced Member

  • Member
  • PipPipPip
  • 1119 posts

Posted 03 June 2018 - 04:26 AM

Hmm. Did all this and still I have no shadows in-game and no light sources. Weird.

 

Anyway I guess I might just do a clean install of TDM to be safe just in case.

 

Thank you all again for all the help.

 

 

Update: replacing tdm_base01 did the trick after more tries. Now light sources work properly. Thanks.


Edited by Anderson, 03 June 2018 - 05:34 AM.

  • Bikerdude likes this

 "I really perceive that vanity about which most men merely prate — the vanity of the human or temporal life. I live continually in a reverie of the future. I have no faith in human perfectibility. I think that human exertion will have no appreciable effect upon humanity. Man is now only more active — not more happy — nor more wise, than he was 6000 years ago. The result will never vary — and to suppose that it will, is to suppose that the foregone man has lived in vain — that the foregone time is but the rudiment of the future — that the myriads who have perished have not been upon equal footing with ourselves — nor are we with our posterity. I cannot agree to lose sight of man the individual, in man the mass."...

 

 

- 2 July 1844 letter to James Russell Lowell from Edgar Allan Poe.

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users