Jump to content
The Dark Mod Forums

Blank screen on extended monitors (Linux)


Recommended Posts

Hi guys,

 

Sorry if this has been asked before; I couldn't find anything when I searched.

 

I have two 19" monitors connected to my Linux laptop which has a nVidia card. When the secondary monitor is a duplicate of the primary, TDM runs fine at the native resolution (1280x1024), and I can see the game running duplicated on both monitors. But when the secondary monitor is set to be the extended desktop (at the right of the primary), TDM starts with blank screen, both monitors reporting "no signal". I can hear the music and mouse sound effects. Hitting the console key and tying exit shuts down the game, but the monitors don't recover. The only way is killing xserver or force-fully shutting the machine. Simply turning off the second monitor before starting the game doesn't help, same behaviour happens.

 

This is quite inconvenient as I basically have to keep my second monitor disabled in order to be able to play TDM. Is there any way to have extended desktop and have TDM run on the primary monitor?

 

Spec:

 

TDM 2.03 (already made sure all the files validate and are up to date)

Linux Mint 17.3 (64 bit), Cinnamon desktop

Dell Precision M4500, 2 x Intel® Core i7 CPU Q 740 @ 1.73GHz, 4GB RAM

NVIDIA Corporation GT215GLM [Quadro FX 1800M] (rev a2), running driver 340.96

 

 

Thanks in advance.

 

 

Link to post
Share on other sites

Found the cause of the problem, but still no solution.

 

When the two external monitors are active (DP-0 and DP-1) in extended mode, TDM starts on the laptop screen (DP-3, which had been off until that moment), makes it the primary display and turns the other two off. Even after quitting TDM this configuration stays.

I hadn't noticed that before because my laptop was docked with the lid closed.

 

Is there any way to tell the engine to start on the current primary display and not change the configuration?

Link to post
Share on other sites

I have never run any games from cinnamon, so I am not familiar with whichever utility it uses to configure the screens in Mint. But...

You might want to give kscreen a shot. You would need to install KDE or Plasma and run that desktop instead of cinnamon. If KDE(4), you will then need to install 'kscreen', replacing kde's default screen config utility. Plasma(5) uses kscreen by default.

In kscreen, you can easily set the screens up, with DP-3 disabled and DP-0 as primary (left) and DP-1 secondary.

I do not know if this would solve the issue with TDM, but kscreen might force the laptop screen to stay disabled and DP-0 to remain primary.

Just an experiment you might want to try.

System: Mageia Linux Cauldron, aka Mageia 8

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...