Jump to content
The Dark Mod Forums

Skins as Textures


killhour
 Share

Recommended Posts

I want to use the chest model skin as a texture for a brush. Is this possible?

Yes, you just need to look for the shader in the "Other Materials" tree in DarkRadiant's Media Browser. The shader name is mentioned in the lower left of the Model Selector when the corresponding model is selected.

 

Whether this will look good is a different matter, of course.

Link to comment
Share on other sites

Yes, you just need to look for the shader in the "Other Materials" tree in DarkRadiant's Media Browser. The shader name is mentioned in the lower left of the Model Selector when the corresponding model is selected.

 

Whether this will look good is a different matter, of course.

 

I tried this origionally. It looks fine in the editor, but when I compile and go in game, it shows up black.

Link to comment
Share on other sites

So you're applying the shader "bc_chest2" to an arbitrary brush? I'll have to try that, maybe there's something wrong (either with the shader or DarkRadiant).

 

I figured there was probably an error in the shader. Too bad, it looked pretty bad ass :(

Link to comment
Share on other sites

Ok, this is really weird. I tried using a different texture for something else. When I saved and loaded, one of the brushes I had applied the shader to had the "missing shader" texture, but the other one didn't.

 

I deleted the brush with the missing shader tex, and copied the other one. When I saved and reloaded, BOTH the textures were missing.

Link to comment
Share on other sites

Ok, this is really weird. I tried using a different texture for something else. When I saved and loaded, one of the brushes I had applied the shader to had the "missing shader" texture, but the other one didn't.

 

I deleted the brush with the missing shader tex, and copied the other one. When I saved and reloaded, BOTH the textures were missing.

Hm. Maybe you could post these steps in a new entry on the bugtracker, and attach the map in question? Sounds like a weird bug, but this has to be confirmed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recent Status Updates

    • nbohr1more

      The Dark Mod is hosting an Ask Me Anything thread on the PC Gaming reddit forum:  https://www.reddit.com/r/pcgaming/comments/10nfcwj/hello_we_are_the_international_development_team/
      Feel free to join the discussion there
      · 0 replies
    • stgatilov

      Bumped into an interesting piece of wisdom called Hyrum's Law:
      With a sufficient number of users of an API, it does not matter what you promise in the contract: all observable behaviors of your system will be depended on by somebody.
      · 5 replies
    • The Black Arrow

      I love playing The Dark Mod when it's cold in my place. Bonus points when it's a bit (or even very) dark and it's raining, too.
      · 1 reply
    • The Black Arrow

      I've been having stutters in Vulkan, apparently it's Nvidia Drivers' fault, so I reverted to 512 according to this: https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/505679/regular-microstutter-in-vulkan-applications-after-/?topicPage=40

      And no, that did NOT fix it. What's going on? My GPU is an RTX 2070, by the way.
      · 4 replies
    • datiswous

      I just figured out how to make subtitles work in TDM (srt) for ingame cutscenes and how to automatically generate the srt file in Kdenlive's speech recognition (I just had to edit it a bit).
      Kdenlive is a free and open source multiplatform pretty advanced video editor.
      Test case is the first builder gost scene in Requiem saying:
      1 00:00:00,180 --> 00:00:02,140 the builder be with you this night 2 00:00:02,600 --> 00:00:04,840 there will be secrets all around you 3 00:00:05,040 --> 00:00:06,439 so have a keen eye The following page gives you the basic info:
      https://wiki.thedarkmod.com/index.php?title=Subtitles
      These 2 tutorials give you the info for creating the srt files:
      If you run into the problem the Kdenlive cannot find your Python PATH, then here is a solution:
      https://www.mail-archive.com/kde-bugs-dist@kde.org/msg672183.html
      Edit: During the installation of Python, in the installer, if you select more options, you can specify to set the PATH. I tried this on another Windows computer and this fixed the issue. Much easier solution.
       
      This is all the code for the testcase:
       
      Maybe I will create a seperate (text,images based) tutorial on the wiki.
      · 8 replies
×
×
  • Create New...