Jump to content
The Dark Mod Forums
Sign in to follow this  
whoop

Multiple monitor problem

Recommended Posts

I have small secondary monitor left of my large primary monitor. When I start thedarkmod fullscreen it starts in the left most window not the primary window as I expect it should. When I disable my secondary monitor in nvidia-settings it starts thedarkmod in the large monitor but in the bottom only filling a portion of the entire screen (tried various resolutions in thedarkmod video settings).

 

Running Arch linux 64 bit with nVidia grahics

 

Any ideas?

 

Awesome project b.t.w.

Share this post


Link to post
Share on other sites

Try running it windowed, then set it to fullscreen in your WM.

Should also be able to move the monitor that it is on then.

Share this post


Link to post
Share on other sites

I have similar issues unless I run TDM in the max resolution of my monitor (1920x1200). My former resolutions of 1440x900 and 1680x1050 both display improperly.

The nvidia-settings utility used to have options for how full-screen programs were handled...whether to stretch or center the display with black borders, etc. That seems to have disappeared, so I can't test fixing it with that method.

 

BTW. this has been going on for quite a while now and has nothing to do with TDM 2.0. I think it is mostly to do with changes to X, and not the nvidia driver specifically.

 

I normally would not suggest running TDM in Wine. But, some games which act quirky in full screen can be controlled by forcing a graphics setting in winecfg.

Example:

I recently installed the game "Project IGI" in wine. I had some issues with display sometimes when launching the game full screen. It would sometimes display no graphics, but audio was fine.

In winecfg, I made a config for IGI.exe with the following Graphics tab options set:

Auto grab mouse = yes

Allow the window manager... = yes

Allow.... = yes

Emulate a virtual desktop = yes and set to 640 x 480

The IGI game itself is set to run full screen in max resolution.

Now the game launches to the main menu properly in a small window. Then it goes to fullscreen properly when missions are launched and back again when done. All display issues go away and the game (not) changing resolutions no longer re-sizes my plasma desktop panels.

Edited by PranQster

Linux pranqster 5.4.17-desktop-1.mga8 #1 SMP Sat Feb 1 21:43:33 UTC 2020 x86_64 x86_64 x86_64 GNU
/Linux

Share this post


Link to post
Share on other sites

Thanks for the responses guys...

 

Try running it windowed, then set it to fullscreen in your WM.

Should also be able to move the monitor that it is on then.

I can set it to windowed using the video settings ingame. I can move the (game) window around after bringing up the (game) console, using the mouse. I can move the window to the primary monitor. Setting fullscreen ingame still launches in secondary monitor. I do not understand or know how to: "set in to fullscreen in your WM".

 

 

 

 

I have similar issues unless I run TDM in the max resolution of my monitor (1920x1200). My former resolutions of 1440x900 and 1680x1050 both display improperly.

The nvidia-settings utility used to have options for how full-screen programs were handled...whether to stretch or center the display with black borders, etc. That seems to have disappeared, so I can't test fixing it with that method.

 

BTW. this has been going on for quite a while now and has nothing to do with TDM 2.0. I think it is mostly to do with changes to X, and not the nvidia driver specifically.

 

 

I do not completely agree on your standpoint that it has nothing to do with TDM. I could very well be the case that it is not TDM's fault but (Valve's) source games like portal for instance lauch fullscreen in primary monitor without any problems at all available resolutions...

Edited by whoop

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...